FIX: Il servizio di stampa host (Snaprint.exe) potrebbe smettere improvvisamente quando si stampa i processi con sezioni trasparente in Microsoft Host Integration Server

Traduzione articoli Traduzione articoli
Identificativo articolo: 974406 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In un ambiente Microsoft Host Integration Server 2006 o 2009 Microsoft Host Integration Server il servizio di stampa host (Snaprint.exe) potrebbe arrestarsi in modo imprevisto. Inoltre, verrà registrato il seguente evento nel registro eventi di sistema:

ID evento: 7034
Origine: Gestione controllo servizi
Messaggio: Il servizio SNAPrint terminato in modo imprevisto. Problema si è verificato questo %1 volta/e.

Note
  • Quando si lavora in un ambiente Host Integration Server 2006 o Host Integration Server 2009 a 64 bit, il servizio di stampa host si arresta in modo imprevisto.
  • Quando si lavora in un ambiente Host Integration Server 2006 o Host Integration Server 2009 a 32 bit, non viene interrotto il servizio di stampa host. Tuttavia, non viene completato il processo di stampa.

Cause

Questo problema si verifica perché il processo Snaprint.exe si blocca quando il sistema tenta di accedere trasparente dei dati nel registro eventi per indicare che i dati non verranno stampati.

Risoluzione

Service pack informazioni per Host Integration Server 2006

Per risolvere il problema, procurarsi il service pack più recente per Host Integration Server 2006. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
979497Come ottenere il service pack più recente di Host Integration Server 2006

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo aggiornamento rapido (hotfix) solo per i sistemi in cui si verificano il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale aggiornamento rapido (hotfix).

Se l'aggiornamento rapido (hotfix) è disponibile per il download, è disponibile una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se in questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è richiesta la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del servizio supporto tecnico clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido (hotfix). Se non viene visualizzata la lingua desiderata, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

È necessario disporre di Host Integration Server 2006 per applicare questo aggiornamento rapido (hotfix).

Necessità di riavvio

Non è necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce altri aggiornamenti rapidi (hotfix).

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi del file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file elencate in ora UTC (UTC). Quando si visualizzano le informazioni sul file, viene convertita in ora locale. Per calcolare la differenza tra ora UTC e quella locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Per x 86 versione di Host Integration Server 2006
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
winvprt.dll7.0.2935.0206,67221-Ago-200910: 06x 86

Per x 64 di versione di Host Integration Server 2006
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
winvprt.dll7.0.2935.0252,22421-Ago-200910: 08x 64

Per x 86 versione di Host Integration Server 2009
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Winvprt.dll8.0.3719.2208,70409-Set-200919: 41x 86

Per x 64 di versione di Host Integration Server 2009
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaformaRamo del servizio
Winvprt.dll8.0.3719.2247,12009-Set-200919: 43x 64Non applicabile
Winvprt.dll8.0.3719.2208,70409-Set-200919: 41x 86SYSWOW

Workaround

Nelle proprietà del servizio di stampa in SNA Manager, selezionare il registro eventi No per saltare la sezione trasparente opzione. Ciò consente di disattivare la registrazione e attiva i processi di stampa continuare.

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Proprietà

Identificativo articolo: 974406 - Ultima modifica: giovedì 4 febbraio 2010 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Host Integration Server 2009
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
Chiavi: 
kbmt kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbhotfixserver KB974406 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 974406
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com