Le service Gestionnaire distant Windows (WinRM) ne démarre pas après la désinstallation de WinRM 2.0

Cet article fournit une résolution du problème lié au fait que le service Windows Remote Manager (WinRM) ne démarre pas après la désinstallation de WinRM 2.0.

S’applique à : Windows Server 2012 R2, Windows 10 (toutes les éditions)
Numéro de la base de connaissances d’origine : 974504

Symptômes

Vous désinstallez Windows Remote Manager 2.0 (WinRM) d’un ordinateur exécutant Windows Server 2008 ou Windows Vista. Lorsque vous essayez de démarrer le service WinRM à l’aide de la commande net start winrm, le service WinRM ne démarre pas et vous recevez une erreur « Accès refusé ».

Cause

Ce problème se produit lorsque vous désinstallez WinRM 2.0 et qu’il existait un écouteur WinRM sur le port 5985.

Résolution

Pour résoudre ce problème, appliquez l’une des méthodes suivantes.

Restaurer la configuration WinRM

Pour restaurer la configuration WinRM à son état par défaut, procédez comme suit :

  1. Ouvrez une fenêtre d'invite de commandes.

  2. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :

    winrm quickconfig  
    

Supprimer l’écouteur WinRM sur le port 5985

  1. Ouvrez une fenêtre d'invite de commandes.

  2. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :

    winrm enumerate winrm/config/listener  
    

    Il énumère tous les écouteurs que WinRM utilise actuellement.

  3. Recherchez l’écouteur qui a les paramètres et valeurs suivants :

    • Port=5985
    • Transport=HTTP
  4. Notez la valeur répertoriée pour le paramètre Address de l’écouteur.

  5. Tapez la commande suivante, puis appuyez sur Entrée :
    winrm delete winrm/config/Listener ? Address= Address +Transport=HTTP
    Dans cette commande, l’espace réservé Adresse est la valeur que vous avez notée à l’étape 4.