WinRM 2.0 をアンインストールした後、Windows リモート マネージャー (WinRM) サービスが開始されない

この記事では、WinRM 2.0 をアンインストールした後に Windows リモート マネージャー (WinRM) サービスが起動しない問題の解決策について説明します。

適用対象:Windows Server 2012 R2、Windows 10 - すべてのエディション
元の KB 番号: 974504

現象

Windows Server 2008 または Windows Vista を実行しているコンピューターから Windows リモート マネージャー 2.0 (WinRM) をアンインストールします。 net start winrm コマンドを使用して WinRM サービスを開始しようとすると、WinRM サービスが開始せず、"アクセスが拒否されました" エラーが表示されます。

原因

この問題は、WinRM 2.0 をアンインストールし、ポート 5985 に既存の WinRM リスナーがあった場合に発生します。

解決方法

この問題を解決するには、以下のいずれかの手順を実行します。

WinRM 構成を復元する

WinRM 構成を既定の状態に復元するには、次の手順に従います。

  1. コマンド プロンプト ウィンドウを開きます。

  2. コマンド プロンプトで次のコマンドを入力し、Enter キーを押します。

    winrm quickconfig  
    

ポート 5985 で WinRM リスナーを削除する

  1. コマンド プロンプト ウィンドウを開きます。

  2. コマンド プロンプトで次のコマンドを入力し、Enter キーを押します。

    winrm enumerate winrm/config/listener  
    

    WinRM で現在使用されているすべてのリスナーが列挙されます。

  3. 次のパラメーターと値を持つリスナーを見つけます。

    • Port=5985
    • Transport=HTTP
  4. リスナーの Address パラメーターに一覧表示されている値に注意してください。

  5. 次のコマンドを入力し、Enter キーを押します。
    winrm delete winrm/config/Listener?Address= Address +Transport=HTTP
    このコマンドでは、 Address プレースホルダーは手順 4 で説明した値です。