ID do artigo: 974624 - Última revisão: terça-feira, 22 de dezembro de 2009 - Revisão: 1.1

Drivers de dispositivos integrados não funcionam após o logon em um sistema que foi preparado usando o utilitário Sysprep.exe no Windows 7 ou no Windows Server 2008 R2

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Você tem um computador que esteja executando o Windows 7 ou o Windows Server 2008 R2.
  • Instalar um driver de dispositivos integrados sem conectar-se o dispositivo ao computador.
  • Os arquivos .inf para o driver de dispositivo integrado usam identificadores de diretório (dirids). Os valores do dirids são entre 16384 e 32767.
  • Executar o utilitário Sysprep.exe juntamente com a opção / generalize para preparar uma instalação do Windows.
  • Faça logon no sistema preparado.
Nesse cenário, o driver não funciona corretamente.

Causa

Esse problema ocorre porque os dirids não são expandidos corretamente. Isso faz com que o driver de dispositivo integrado não funcionem corretamente.

Por exemplo, uma entrada em um dos arquivos .inf usa a seguinte sintaxe:
MyBinary = %16422%\MyFile.sys
Quando você faz logon no sistema preparado, você espera que o caminho no exemplo é expandido para o seguinte:
C:\Program Files\MyFile.sys
No entanto, o resultado real é o seguinte:
\MyFile.sys

Resolução

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando o Windows 7 ou o Windows Server 2008 R2.

Informações do registro

Para usar o hotfix neste pacote, não é necessário fazer qualquer alteração no registro.

Requisito de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações do arquivo

A versão em inglês (Estados Unidos) deste hotfix instala arquivos com os atributos listados nas tabelas a seguir. As datas e horários para esses arquivos estão listados no horário de universal coordenado (UTC). As datas e os horários desses arquivos no computador local são exibidos no seu horário local junto com a diferença do horário de verão (DST) atual. Além disso, as datas e os horários pode ser alteradas quando você executa certas operações nos arquivos.
Observações de informações de arquivo do Windows 7 e Windows Server 2008 R2
Importante Os hotfixes do Windows 7 e os hotfixes do Windows Server 2008 R2 estão incluídos nos mesmos pacotes. No entanto, os hotfixes na página solicitação Hotfix estão listados em ambos os sistemas operacionais. Para solicitar o pacote de hotfix que se aplica a um ou ambos esses sistemas operacionais, selecione o hotfix listado em "Windows 7/Windows Server 2008 R2" na página. Sempre consulte a seção "Aplica-se A" nos artigos para determinar o sistema operacional real que cada hotfix se aplica.
Para todas as versões com base em 86 do Windows 7 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Drvstore.dll6.1.7600.20530318,97618-Set-200904: 59x 86
Para todas as versões com base em 64 do Windows 7 e do Windows Server 2008 R2 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Drvstore.dll6.1.7600.20530418,30418-Set-200906: 27x 64
Drvstore.dll6.1.7600.20530318,97618-Set-200904: 59x 86
Para todas as versões com base em IA-64 do Windows Server 2008 R2 compatíveis
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Drvstore.dll6.1.7600.20530732,67218-Set-200904: 35IA-64
Drvstore.dll6.1.7600.20530318,97618-Set-200904: 59x 86

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a terminologia da atualização, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software

Referências

Para obter mais informações sobre dirids, visite o seguinte site da Microsoft TechNet:
http://msdn.microsoft.com/en-us/library/ms790174.aspx (http://msdn.microsoft.com/en-us/library/ms790174.aspx)

A informação contida neste artigo aplica-se a:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
Palavras-chave: 
kbmt kbautohotfix kbfix kbqfe kbexpertiseadvanced kbsurveynew kbhotfixserver KB974624 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 974624  (http://support.microsoft.com/kb/974624/en-us/ )