AD RMS 可能会停止工作时它会查询 Active Directory 的运行 Windows Server 2008 R2 计算机上的全局编录

文章翻译 文章翻译
文章编号: 974636 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

请考虑以下情形:
  • 您正在运行 Windows Server 2008 R2 的计算机上安装 Active Directory 权限管理服务 (AD RMS) 服务器角色。
  • AD RMS 会查询 Active Directory 全局编录。
在这种情况下活动目录权限管理服务 (AD RMS) 服务器角色可能会停止工作随机。此外,这种行为可能会阻止某些客户端打开 RMS 保护的内容。

原因

AD RMS 缓存池的全局编录服务器,以提高性能的 Active Directory 的查询。无法为全局编录服务器时应从池中删除全局编录服务器。

但是,按预期的方式,也无法正常工作的一些有故障的全局编录服务器删除。运行 Internet Information Services (IIS) 的服务器重新启动之前,这些故障的全局编录服务器将留在池中。因此,一些 RMS 作业失败时 AD RMS 查询这些全局编录服务器。此行为会导致停止工作时整个池包含有故障的全局编录服务器的 AD RMS。

替代方法

若要变通解决此问题,您可以重新启动 IIS 服务,而无需重新启动服务器运行 IIS 的服务器上使用"iisreset.exe"命令。

解决方案

修补程序信息

可以从 Microsoft 获得支持的修补程序。但是,此修补程序被用于解决本文所述的此问题。此修补程序仅应用于出现本文所述问题的系统。此修补程序可能会接受进一步的测试。因此,如果此问题没有对您造成严重的影响,我们建议您等待包含此修补程序的下一个软件更新。

是否可供下载此修补程序没有"提供修补程序下载"部分中,在这篇知识库文章的顶部。如果不会显示此部分,请联系 Microsoft 客户服务和支持以获取此修复程序。

注意如果出现其他问题,或者如果需要进行任何故障诊断,则您可能不得不创建单独的服务请求。将正常收取支持费用将应用于其他支持问题和不需要进行此特定的修补程序的问题。有关完整列表的 Microsoft 客户服务和支持的电话号码,或创建一个单独的服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意"提供修补程序下载"窗体所显示的此修复程序是可用的语言。如果您看不到您的语言,则是一个修复程序不能用于该语言。

系统必备组件

若要将此修补程序,计算机必须运行 Windows Server 2008 R2。 此外,$ 计算机必须安装的 Active Directory 权限管理服务。

重新启动要求

应用此修补程序后,您必须重新启动计算机。

修补程序替换信息

此修补程序不替代任何其他修补程序。

文件信息

此修补程序的英文版具有的文件属性 (或更新的文件属性) 在下表中列出。日期和时间对这些文件列出在协调世界时 (UTC)。当您查看文件信息时,将转换为本地时间。若要 UTC 与本地时间之间的时差使用控制面板中的 日期和时间 项中的 时区 选项卡。
Windows Server 2008 R2 文件信息注意

清单文件 (.manifest) 和 $ MUM 文件 (.mum) 已安装的每个环境都是 listed separately。维护更新组件的状态的关键 MUM 和清单的文件和关联的安全的目录 (.cat) 文件。用 Microsoft 的数字签名签名该安全编录文件 (未列出的属性)。

支持所有 Windows Server 2008 R2 的基于 x64 的版本 x

收起该表格展开该表格
文件的名称文件版本文件大小日期时间平台
Microsoft.rightsmanagementservices.shared.dll6.1.7600.205062,166,7842009 年八月 13 日06: 28x86


状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。

参考

有关软件更新术语的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684用于描述 Microsoft 软件更新的标准术语的说明

更多信息

Additional file information for Windows Server 2008 R2 2008

所有受支持的其他文件 x 的 Windows Server 2008 R2 的基于 x64 的版本

收起该表格展开该表格
文件的名称文件版本文件
大小
日期时间平台
Msil_microsoft.rightsmanmentservices.shared_31bf3856ad364e35_6.1.7600.20506_none_68dacb1e747a3ee2.manifest不适用2,0092009 年八月 13 日07: 00不适用
Package_for_kb974636_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mum不适用1,4522009 年八月 14 日01: 23不适用

属性

文章编号: 974636 - 最后修改: 2009年10月14日 - 修订: 1.1
这篇文章中的信息适用于:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
关键字:?
kbmt kbsurveynew kbexpertiseinter kbhotfixserver kbautohotfix kbqfe kbfix kbbug KB974636 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 974636
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com