FIX: An unexpected Failure Audit event is logged for the local credential when you run a .NET Framework 2.0-based application that tries to connect to a remote computer

Article translations Article translations
Article ID: 974893 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You run a Microsoft .NET Framework 2.0-based application that uses methods in the System.Management namespace to connect to a remote computer.
  • You enter a remote credential, and then a Windows Management Instrumentation (WMI) connection is created successfully.
  • Then, you check the Security log on the remote computer.
In this scenario, an unexpected Failure Audit event is logged for the local credential. Additionally, a Success Audit event is logged for the remote credential.

Note When you use the Wbemtest tool to connect to the remote computer, there is no event log for the local credential as expected. Only the Success Audit event for the remote credential is logged.

CAUSE

This problem occurs because WMI in the .NET Framework does not secure an object before it returns the pointer of the object to the .NET Framework. Then the WMI proxy calls the local credential instead of the remote credential.

RESOLUTION

The .NET Framework 2.0 SP1

To resolve this problem in the .NET Framework 2.0 Service Pack 1 (SP1), install the hotfix that is described in the following Microsoft Knowledge Base (KB) article.
967622 The local credential is audited instead of the remote credential that you enter when you run an application that uses the System.Management namespace to connect to a remote computer

The .NET Framework 2.0 SP2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Alternatively, you can download this hotfix from the following Microsoft Connect Web site:

https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=29014

Prerequisites

You must have the .NET Framework 2.0 Service Pack 2 (SP2) or the .NET Framework 3.5 SP1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix if no instance of the .NET Framework is being used.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2000, of Windows Server 2003, and of Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.management.dll2.0.50727.4065385,02431-Aug- 200911:38x86
Wminet_utils.dll2.0.50727.406532,07231- Aug-200911:38x86

For all supported x64-based versions of Windows Server 2000, of Windows Server 2003, and of Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.management.dll2.0.50727.4065385,02431-Aug- 200911:38x86
Wminet_utils.dll2.0.50727.406542,32828- Aug-200914:15x64

For all supported Itanium-based versions of Windows Server 2000, of Windows Server 2003, and of Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.management.dll2.0.50727.4065385,02431-Aug- 200911:38x86
Wminet_utils.dll2.0.50727.406579,70428- Aug-200914:24IA-64

For all supported x86-based versions of Windows Vista SP2 and of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.management.dll2.0.50727.4400385,02404-Sep-200906:59
Wminet_utils.dll2.0.50727.440032,07204- Sep-200906:59

For all supported x64-based versions of Windows Vista SP2 and of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.management.dll2.0.50727.4400385,02404-Sep- 200906:57x86
Wminet_utils.dll2.0.50727.440042,32804- Sep-200906:57x64

For all supported Itanium-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.management.dll2.0.50727.4400385,02404-Sep- 200907:00x86
Wminet_utils.dll2.0.50727.440079,68804- Sep-200907:00IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 974893 - Last Review: September 7, 2010 - Revision: 4.0
APPLIES TO
  • Microsoft .NET Framework 2.0 Service Pack 2
  • Microsoft .NET Framework 3.5 Service Pack 1
Keywords: 
kbexpertiseadvanced kbsurveynew kbqfe KB974893

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com