Exchange Server 2007 OWA users receive an error message when the users change the display line for the search results on the address books

Article translations Article translations
Article ID: 974946 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • In a Microsoft Exchange Server 2007 environment, you log on to Microsoft Office Outlook Web Access (OWA)
  • Exchange Server 2007 is in multiple Global Category servers' environment.
  • You use the address book to perform a search operation
  • You receive more than 50 search results. These search results are distributed over several pages.
  • You click Next Page to view more search results and then try to change the display line for the search results.
In this scenario, you may receive the following error message:

Could not connect to a directory server. If the problem continues, contact technical support for your organization.

Note There are two display line buttons available at the top of the Address Book search result window. You can click any one of them to switch between a Single Line display and a Multiple Lines display.

CAUSE

This error message occurs because LDAP queries occur for the Address Book search. In the multiple GC servers' environment, the LDAP queries for the Address Book search may use a cookie. The cookie is issued by one GC server to communicate with another GC server when you change the display line for the search results.

RESOLUTION

To resolve this problem, install the following update rollup:
972076 Description of Update Rollup 2 for Exchange Server 2007 Service Pack 2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 974946 - Last Review: January 22, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 2, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbexpertiseinter kbqfe kbfix kbsurveynew kbhotfixrollup KB974946

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com