A call transfer fails by using key mapping in a mixed Exchange Server 2007 UM server and OCS 2007 environment

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Article ID: 975050 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • In a mixed Microsoft Exchange Server 2007 Unified Messaging (UM) server and Microsoft Office Communications Server(OCS) 2007 environment, the Auto Attendant is configured for unauthenticated callers to call in.
  • Dual tone multi-frequency (DTMF) Auto Attendant is only configured to use Key Mapping.
  • The telephone keys map to extensions and the extensions belong to users who are in the same dial plan as the Auto Attendant.
  • A public switched telephone network (PSTN) telephone calls Auto Attendant and then selects a key.
  • Call-id of the PSTN telephone is blocked.
In this scenario, the call transfer fails.

Note A PSTN caller has anonymous caller-id when the caller-id is blocked. A call transfer only works if the caller selects someone from the Activity Directory. Only a call transfer by using key mapping is broken. However, if OCS 2007 is not involved, there is no problem by using key mapping to transfer a call. In other words, a caller with caller-id blocked can perform a call transfer by using key mapping when a call comes to an Exchange Server 2007 UM server directly from a Private Branch Exchange (PBX) device. Additionally, when this problem occurs, the Exchange Server 2007 UM server sets the caller's address as the following: sip: anonymous@<domain name>

CAUSE

The issue that is described in the "Symptoms" section occurs because Exchange Server 2007 UM server does not provide a valid host name for an anonymous call.

RESOLUTION

To resolve this problem, install the following update rollup:
972076 Description of Update Rollup 2 for Exchange Server 2007 Service Pack 2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about DTMF Auto Attendant, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb232158(EXCHG.80).aspx

For more information about Unified Messaging Auto Attendant call processing, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb123689(EXCHG.80).aspx

Properties

Article ID: 975050 - Last Review: January 22, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 2, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbexpertiseinter kbfix kbqfe kbhotfixrollup KB975050

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