Error message after you enable or disable Microsoft Bluetooth Enumerator in Device Manager on a Windows Vista-based computer that has Windows Vista Feature Pack for Wireless installed: “Stop 0x00000050”

Article translations Article translations
Article ID: 975192 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You have Windows Vista Feature Pack for Wireless installed on a computer that is running Windows Vista Service Pack 1 (SP1).
  • You enable or disable Microsoft Bluetooth Enumerator in Device Manager.
In this scenario, you receive the following Stop error message:

STOP 0x00000050 (parameter1, parameter2, parameter3, parameter4)
Notes
  • Windows Vista Feature Pack for Wireless is described in Microsoft Knowledge Base (KB) article 942567.
  • The four parameters in this error message vary, depending on the computer's configuration.
  • Not all "Stop 0x00000050" errors are caused by this problem.

CAUSE

This problem occurs when there is a problem in the Human Interface Device (HID) class driver (Hidclass.sys).

RESOLUTION

Hotfix information

This hotfix is not available to end-user customers through typical distribution channels. However, this hotfix is available to certain original equipment manufacturers (OEMs).

Prerequisites

To apply this hotfix, you must have Windows Vista Feature Pack for Wireless and hotfix 970694 installed on a computer that is running Windows Vista SP1. For more information, see the "Installation Instructions" section.

Installation instructions

OEMs must use this hotfix together with the hotfix that is described in KB article 970694 to make sure that the system functions correctly after end-users upgrade Windows Vista SP1 to Windows Vista Service Pack 2 (SP2). To install this hotfix, follow these steps:
  1. Uninstall Windows Vista Feature Pack for Wireless if it is already installed on the computer.
  2. Install the hotfix that is described in the following KB article:
    970694 You receive a "Stop 0x00000050" error message after you enable or disable Bluetooth Enumerator in Device Manager on a Windows Vista or Windows Server 2008-based computer
  3. Reinstall Windows Vista Feature Pack for Wireless as described in the following KB article:
    942567 Description of Windows Vista Feature Pack for Wireless
  4. Install hotfix 975192.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes

The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Hidclass.sys6.1.6001.2220239,93613-Aug-200922:14x86
Hidir.sys6.1.6001.2220221,50413-Aug-200922:14x86
Hidparse.sys6.1.6001.2220225,60013-Aug-200922:14Not Applicable
Hidusb.sys6.1.6001.2220212,28813-Aug-200922:14x86
For all supported x64-based versions of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Hidclass.sys6.1.6001.2220249,66413-Aug-200923:15x64
Hidir.sys6.1.6001.2220225,60013-Aug-200923:15x64
Hidparse.sys6.1.6001.2220231,74413-Aug-200923:15x64
Hidusb.sys6.1.6001.2220215,87213-Aug-200923:15x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Additional file information

Additional file information for Windows Vista

Additional files for all supported x86-based versions of Windows Vista SP1
Collapse this tableExpand this table
File namePackage_for_kb975192_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,627
Date (UTC)01-Sep-2009
Time (UTC)16:15
File namePackage_for_kb975192_client~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)01-Sep-2009
Time (UTC)16:15
File nameX86_input.inf_31bf3856ad364e35_6.1.6001.22202_none_e92a0650d804d89b.manifest
File versionNot Applicable
File size3,406
Date (UTC)01-Sep-2009
Time (UTC)16:15
Additional files for all supported x64-based versions of Windows Vista SP1
Collapse this tableExpand this table
File nameAmd64_input.inf_31bf3856ad364e35_6.1.6001.22202_none_4548a1d4906249d1.manifest
File versionNot Applicable
File size3,408
Date (UTC)01-Sep-2009
Time (UTC)16:21
File namePackage_for_kb975192_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,637
Date (UTC)01-Sep-2009
Time (UTC)16:21
File namePackage_for_kb975192_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)01-Sep-2009
Time (UTC)16:21

Properties

Article ID: 975192 - Last Review: September 18, 2009 - Revision: 2.1
APPLIES TO
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbexpertiseinter kbfix kbbug kbsurveynew kbqfe KB975192

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com