Article ID: 975213 - Last Review: January 22, 2010 - Revision: 1.0

You cannot log on to your mailbox and you receive an error in an Exchange server 2003 and an Exchange Server 2007 coexist environment

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • There is a Microsoft Exchange server 2003 and Microsoft Exchange Server 2007 coexist environment.
  • You access an Exchange Server 2003 mailbox through an Exchange Server 2007 Client Access server (CAS) with the IMAP4 protocol.
  • You use the PLAIN authentication mechanism.
In this scenario, you cannot log on to the mailbox. Additionally, you receive the following error message:
"NO AUTHENTICATE failed"

CAUSE

When you use the PLAIN authentication mechanism, Exchange Server 2007 CAS passes the display name instead of the logon account name to the Exchange Server 2003 mailbox server. When this behavior occurs, authentication fails.

RESOLUTION

To fix this problem, apply the following update rollup:
972076  (http://support.microsoft.com/kb/972076/ ) Description of Update Rollup 2 for Exchange Server 2007 Service Pack 2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the IMAP4 protocol and the PLAIN authentication mechanism, visit the following IETF Web sites:
http://www.ietf.org/rfc/rfc2595.txt (http://www.ietf.org/rfc/rfc2595.txt)
http://www.ietf.org/rfc/rfc3501.txt (http://www.ietf.org/rfc/rfc3501.txt)

APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 2, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbhotfixrollup kbsurveynew kbexpertiseinter kbfix kbqfe KB975213