Uppgraderingen slutar att svara (hänger sig) vid 62 % när du uppgraderar till Windows 7

Artikelöversättning Artikelöversättning
Artikel-id: 975253 - Visa produkter som artikeln gäller.
Visa alla | Dölj alla

På den här sidan

Symptom

När du försöker uppgradera datorn från Windows Vista till Windows 7 slutar uppgraderingen att svara för gott vid 62 %.

Windows skapar dessutom en fil med namnet system_drive:\$WINDOWS.~BT\Sources\Panther\setupact.log. Följande information finns i filen:

<date> <time>, Info                  MIG    IPostApply::ApplySuccess for Plugin={ServerPath="%windir%\system32\migration\IphlpsvcMigPlugin.dll", CLSID={ade10465-2a43-454e-b0a7-3f220a61bd03}, ThreadingModel=Apartment} - Working directory: C:\$UPGRADE.~OS\OnlineUpgradeApplyWork\srcworking\agentmgr\CCSIAgent\005AE0CB
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: Performing upgrade actions for all protocols
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, InterfaceCount = 0
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.Incrementing interface count
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, New value of *InterfaceCount = 1
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: RegEnumKeyEx return 259. key name: {AC049C3C-9B90-41A7-9385-DC5AD3E656F0}.new index: 2
Warning [0x080b50] MIG AsyncCallback_ApplyStatus: Progress appears to be stuck. Current progress: 62
OBS!drive är vanligtvis C-enheten på datorn.

Orsak

Problemet beror på att Iphlpsvc-tjänsten slutar att svara under uppgraderingen.

Obs! Andra tjänster kan också orsaka problem med att uppgraderingsprocessen slutar att svara vid 62 %.

Lösning

Viktigt! Använd inte den här lösningen om uppgraderingen slutar att svara vid en annan procentandel än 62 % eller om loggposterna inte är loggade. Mer information om hur du öppnar Seupact.log-filen finns i avsnittet Mer information.

Om du vill att vi ska åtgärda problemet går du till avsnittet Lös det åt mig. Om du föredrar att åtgärda problemet själv går du till avsnittet Jag löser det själv.

Lös det åt mig

Om du vill att problemet ska åtgärdas automatiskt startar du om den dator där uppgraderingen till Windows 7 stoppar på 62 %. Datorn återställs till Windows Vista. Antingen hämtar du följande korrigeringsfil till ett flashminne eller en cd-skiva eller också går du tillbaka till den här artikeln på datorn där uppdateringen misslyckades. Om du återgår till artikeln klickar du på länken Lös det här problemet. Klicka på Kör i dialogrutan Filhämtning och följ anvisningarna i guiden.


Lös det här problemet
Microsoft Fix it 50319


Obs! Den här guiden finns bara på engelska men den automatiska korrigeringsfilen fungerar även för andra språkversioner av Windows.

Obs! Om du inte sitter vid datorn där problemet finns, kan du spara den automatiska korrigeringsfilen på ett flashminne eller en cd-skiva och sedan köra den på rätt dator.

Gå sedan till avsnittet Löste det här problemet?.

Jag löser det själv

Så här löser du problemet själv:
  1. Starta om datorn. Datorn återställs då till Windows Vista.
  2. Klicka på Start, högerklicka på Dator och klicka på Egenskaper.
  3. Klicka på Miljövariabler på fliken Avancerat.
  4. Under Systemvariabler klickar du på Nytt.
  5. Skriv MIG_UPGRADE_IGNORE_PLUGINS i fältet Variabelnamn.
  6. Skriv IphlpsvcMigPlugin.dll i fältet Variabelvärde.
  7. Stäng alla dialogrutor genom att klicka tre gånger på OK.
  8. Starta uppgraderingen igen.

Mer Information

Öppna seupact.log-filen

Du öppnar setupact.log-filen under uppgraderingsprocessen genom att trycka på SKIFT+F10 för att öppna en kommandotolk, skriva C:\$WINDOWS.~BT\Sources\Panther\setupact.log och sedan trycka på RETUR.

Om du vill öppna setupact.log-filen efter att datorn har återställts till Windows Vista, klickar du på Start, skriver C:\$WINDOWS.~BT\Sources\Panther\setupact.log i rutan Påbörja sökning och trycker på RETUR.

Filen seupact.log öppnas i Anteckningar. Rulla till slutet av filen för att se de senaste loggposterna.

Löste det här problemet?

Se efter om problemet har lösts genom att uppgradera datorn från Windows Vista till Windows 7. Om uppgraderingen fortsätter längre än 62 % är du klar med den här artikeln. Om problemet inte är åtgärdat kan du kontakta supporten.

Egenskaper

Artikel-id: 975253 - Senaste granskning: den 14 maj 2011 - Revision: 3.0
Informationen i denna artikel gäller:
  • Windows 7 Service Pack 1
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 7 Home Basic
Nyckelord: 
kbfixme kbmsifixme kbexpertisebeginner kbsurveynew kbprb KB975253

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com