Update: Können nicht beim Bildlauf einer Seite oder besuchen Sie eine Verknüpfung mit eine .NET Compact Framework 3.5-basierte Anwendung, die ein WebBrowser-Steuerelement in Windows Mobile 6.1.4 oder in Windows Mobile 6.5 hostet

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 975281 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Berücksichtigen Sie die folgenden Scenerio. Auf einem Windows Mobile-Gerät oder auf ein Windows Mobile Device Emulator, ausführen eine .NET Compact Framework 3.5-basierten Anwendung. Diese Anwendung hostet ein System.Windows.Forms.WebBrowser -Steuerelement. Die Anwendung lädt dann eine HTML-Seite, die mehrere Verknüpfungen enthält. In dieser Scenerio treten die folgenden Probleme:
  • Sie können nicht die Verknüpfungen Bildlauf mithilfe der Schaltfläche Navigationsbereich . Stattdessen können Sie sich unerwartet die gesamte Webseite verschieben Sie besuchen.
  • Wenn Sie den Befehl drücken Schaltfläche eine angegebene Verbindung kann nicht geöffnet.
Dieses Problem tritt in Windows Mobile 6.1.4 und in Windows Mobile 6.5. Darüber hinaus werden in Windows Mobile 6.5, die horizontale und vertikale Bildlaufleisten nicht angezeigt.

Ursache

Dieses Problem wird durch einen Wrapper für Datei "Shdocvw.dll" verursacht. Sie bemerken das Problem, wenn Sie das System.Windows.Forms.WebBrowser -Steuerelement in .NET Compact Framework 3.5 verwenden.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft-Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Es gibt keine Voraussetzungen, um diesen Hotfix installieren.

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time aufgeführt (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateigrößeDatumUhrzeit
Netcfv35.WM.ARMV4i.CAB2,672,49420-Jul-200917: 39

Abhilfe

Um dieses Problem zu umgehen, Erstellen eines Benutzersteuerelements, das basiert auf systemeigenen Steuerelement Webview.dll und htmlview.dll systemeigenen Steuerelement.

Hinweis: Der systemeigene Code befindet sich an folgendem Speicherort:
Windows Mobile 6-SDK\Samples\PocketPC\CPP\win32\browse

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Eigenschaften

Artikel-ID: 975281 - Geändert am: Dienstag, 29. September 2009 - Version: 1.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft .NET Compact Framework 3.5
Keywords: 
kbmt kbexpertiseadvanced kbsurveynew kbqfe kbhotfixserver KB975281 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 975281
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com