Descrição do Hotfix Rollup 1 para o Antigen 9.0 Service Pack 2

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Sumário

A Microsoft lançou correcções 1 para Microsoft Antigen 9.0 Service Pack 2. Este artigo contém informações sobre como obter o pacote cumulativo e sobre os problemas corrigidos pelo pacote cumulativo.

Esse acúmulo inclui todas as correções no Antigen 9.0 Service Pack 2. Para obter mais informações sobre as correções incluídas no Service Pack 2, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
971063Descrição do Antigen 9.0 com Service Pack 2

Mais Informações

Novos recursos no pacote cumulativo de hotfix

  • StarEngine o serviço for interrompido quando SpamCure estiver desmarcada
    Em versões do Antigen anteriores ao Antigen 9.0 Service Pack 2 Rollup 1, StarEngine serviço continuaria em execução mesmo que o mecanismo anti-spam SpamCure não estava sendo usado e ambos o Cloudmark mecanismo anti-spam foi selecionado ou não há mecanismos anti-spam foram selecionados. Isso significava que o serviço StarEngine continua use memória e recursos. Rollup 1, o serviço StarEngine agora será interrompido se não estiver em Antigen Administrator e trabalhos de verificação estão desabilitados. Por exemplo, isso pode ocorrer quando ocorrer uma atualização de mecanismo ou os serviços são reciclados. Depois que os trabalhos de verificação estiverem reativados, o serviço StarEngine permanecerá parado.
  • Rollup 1 para o Antigen for Exchange versão 9.0 com o SP2 contém recursos de log de diagnóstico adicionais para o mecanismo Cloudmark
    Rollup 1 para o Antigen for Exchange versão 9.0 SP2 adiciona novos recursos que permitem registrar informações de diagnóstico adicionais sobre o mecanismo Cloudmark. Recomendamos que você habilite esse log somente quando for instruído pelo Atendimento Microsoft e suporte (CSS).

    Importante Nesta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir estas etapas cuidadosamente. Para obter mais proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    322756Como fazer backup e restaurar o registro no Windows

    Se instruído a ativar diagnóstico adicional Cloudmark registro em log, instalar Rollup 1 para Microsoft Antigen para Exchange versão 9.0 SP2 e, em seguida, siga estas etapas:

    Para conteúdo Cloudmark Scanner Diagnostics
    Esses diagnósticos registram informações de Cloudmark adicionais ao arquivo ProgramLog.txt.
    1. Clique em Iniciar, clique em Executar, digite regedit e, em seguida, clique em OK.
    2. Localize e clique na seguinte chave do registro:

      Para o Antigen para Exchange:
      HKEY_LOCAL_MACHINE/SOFTWARE/Sybari Software/Antigen for Exchange
      Para o Antigen para SMTP:
      HKEY_LOCAL_MACHINE/SOFTWARE/Sybari Software/Antigen for SMTP
    3. No menu Editar, aponte para novo e, em seguida, clique em Valor DWORD.
    4. Digite ContentScannerDiagnosticsLevel e, em seguida, pressione ENTER.
    5. No menu Editar, clique em Modificar.
    6. Digite 1 e, em seguida, clique em OK.
    7. Feche o Editor do registro
    Para ativar a nova configuração, faça uma alteração na área de Opções gerais da interface do usuário do administrador do Antigen. Isso faz com que o Antigen reler as configurações do registro e ver o novo valor do registro.

    Valores do registro correspondem às configurações da seguinte maneira.
    ContentScannerDiagnosticsLevel:
    • 0: Desabilita o log de todas as informações de atualização de assinatura Cloudmark.
    • 1: Habilita o log de todas as informações de atualização de assinatura Cloudmark.
    • 6: Habilita o log de informações de erro apenas.
    Para o log do mecanismo Cloudmark adaptador ETW
    Esses diagnósticos registrar informações de Cloudmark mecanismo adaptador adicionais para um arquivo de rastreamento ETW separado:
    1. Abra um prompt de comando e execute o seguinte comando para criar um novo rastreamento:
      logman create trace Forefront -o c:\CloudmarkAdapterLog.etl -p "{b873680d-be62-4181-b678-bb651fa11c25}" -f bincirc - 1000 máx.
    2. Execute o seguinte comando para iniciar a coleta de dados:
      Logman iniciar Forefront
    3. Reproduza o problema.
    4. Execute o seguinte comando para interromper a coleta de dados:
      Logman parar Forefront
    5. Execute o seguinte comando para remover o rastreamento do ETW:
      Logman excluir Forefront
    6. Colete o arquivo de rastreamento de sua pasta de saída. Por exemplo, colete o arquivo de c:\CloudmarkAdapterLog.etl.
  • Antigen 9.0 Service Pack 2 Rollup 1 exibe a versão atual de assinatura do mecanismo de autoridade Cloudmark no console do Antigen
    Como o mecanismo de autoridade Cloudmark atualizações ao longo do dia, os administradores podem exibir agora a versão de assinatura específico em Antigen Administrator em Atualizações do scanner. Cloudmark baixa novas atualizações de micro aproximadamente a cada minuto. Isso é exibido como um número de versão na caixa de Assinatura de versão para o mecanismo selecionado. O número de versão é construído a partir da data e hora (no horário de 24 horas) do último download atualização micro. Por exemplo, a seguinte versão de assinatura indica que Cloudmark foi atualizado pela última vez em 23 de setembro às 4: 18 horas:
    9.23.16.18
    Para exibir a versão de assinatura Cloudmark em Antigen Administrator, clique em configurações e, em seguida, clique em Atualizações do scanner.
  • Antigen 9.0 Service Pack 2 Rollup 1 fornece contadores de desempenho para Cloudmark autoridade Engine e dos mecanismos SpamCure

    Os contadores de desempenho a seguir são adicionados para mecanismos SpamCure e Cloudmark autoridade no Antigen 9.0 Service Pack 2 Rollup 1:
    • Tempo médio de verificação Cloudmark
    • Taxa de digitalização Cloudmark mensagem médio
    • Tempo médio de verificação Spamcure
    • Taxa de digitalização Spamcure mensagem médio
  • Informações adicionais adicionadas aos cabeçalhos de mensagens de email para detecção de spam
    Para cada email é verificado pelo Cloudmark para detecção de spam, Antigen adiciona as seguintes informações ao cabeçalho do email, independentemente de se a mensagem foi detectada como spam ou não:
    X-MS-Antispam-relatório: data
    Observação: O espaço reservado para os data são dados Cloudmark específicos que explique por que o email foi determinado como spam ou não spam Cloudmark. Essa informação ajuda Cloudmark sua detecção de spam.

Problemas corrigidos no Hotfix Rollup 1 para o Antigen 9.0 SP2

Juntamente com as correções incluídas em todos os service packs e pacotes cumulativos para o Antigen 9.0, esse pacote cumulativo de hotfix corrige os seguintes problemas:

Detalhes dos problemas corrigidos no pacote cumulativo de hotfix

  1. Scan engine updates fail, and the Antigen logs do not provide a valid error
  2. Mail is not scanned after you apply a new template in Antigen 9.0
  3. The AntigenClient.exe process in Antigen for Exchange version 9.0 may crash. This generates a Dr. Watson crash that references Bucket ID 1177692600
  4. Engine deprecation notifications continue to be sent even though the engine was disabled from all scan jobs and scanner updates.
  5. AntigenService crashes in Antigen 9.0 after you save changes that you made in the Antigen General Options panel
  6. Antigen 9.0 may detect that valid Office 2003 Word documents contain CorruptedComperssedFile viruses
  7. Antigen 9.0 may generate the following error in the ProgramLog.txt: "ERROR: AntigenInternet process returned 80010105 while processesing message"
  8. A scan engine update fails and generates a warning in the ProgramLog.txt file

Observação: Todas as correções listadas nesta seção se aplicam aos seguintes produtos, salvo indicação em contrário:
Antigen para Exchange versão 9.0
Antigen para Exchange versão 9.0 com SP1
Antigen para Exchange versão 9.0 com SP2
Antigen para SMTP Gateways versão 9.0
Antigen para SMTP Gateways versão 9.0 com SP 1
Antigen para SMTP Gateways versão 9.0 com SP 2
  1. Atualizações de engine de varredura falharem, e os logs do Antigen não fornecem um erro válido
    Sintomas
    Quando as atualizações de mecanismos de varredura falharem, normalmente há um erro registrado no arquivo ProgramLog.txt que indica uma possível causa. No entanto, nesse caso, os erros que estão conectados a ProgramLog.txt são insuficientes para a falha de atualização do mecanismo de solução de problemas.

    A seguinte mensagem de erro é registrada no arquivo ProgramLog.txt. O espaço reservado ScanEngineName contém o nome real do mecanismo de varredura que não foi atualizada.
    INFORMAÇÃO: O mecanismo de varredura ScanEngineName para Antigen foi descarregado
    INFORMAÇÃO: O mecanismo de varredura ScanEngineName para Antigen testado.
    INFORMAÇÃO: teste o mecanismo de varredura ScanEngineName. "
    Erro: Não é possível carregar o mecanismo de varredura ScanEngineName. hr = 0x800C0102. Ocorreu um erro ao carregar o mecanismo de varredura ScanEngineName.
    Erro: (0 x 00000002) O sistema não pode encontrar o arquivo especificado. O ScanEngineName varredura falha no teste de mecanismo. hr = 0 x 80004005

    Causa
    Esse problema ocorre quando a chave de registo DatabasePath contém caracteres inválidos. Portanto, o teste de mecanismo que ocorre durante o mecanismo de todas as atualizações falhar e faz com que cada atualização consecutiva falhe.

    Por exemplo, isso ocorre se a chave de registo DatabasePath possui a seguinte configuração:
    J:\\\\ProgramFiles\\AntigenCluster
    Neste exemplo, os caracteres adicionais barra invertida (\\\) são inválidos.

    Resolução
    Após a instalação Rollup 1, a seguinte mensagem de erro será registrada no arquivo ProgramLog.txt em vez da mensagem de erro anterior:
    Erro: O caminho do banco de dados no registro não existe.
  2. Emails não são verificados após aplicar um novo modelo no Antigen 9.0
    Sintomas
    Depois de aplicar um novo modelo no Antigen versão 9.0, email SMTP não será examinado para a existência de vírus.

    A seguinte mensagem de erro é registrada no arquivo ProgramLog.txt:
    Erro: scanjob.cpp::Load(): pStream->Read() retornado 0x80010108
    Erro: scanjob.cpp::Load(): assinatura inválida.

    Causa
    Antes de Rollup 1 quando modelos foram enviados, as configurações de ScanJob foram limpo antes que as novas configurações de substituem-los por meio da verificação extra de modelo. Durante esse processo, um problema pode ocorrer em que as novas configurações não substituem as configurações antigas que já tiverem sido corrigidas. Assim, o ScanJob não contém mais as configurações necessárias. Portanto, ele não é possível verificar emails.
  3. O processo de AntigenClient.exe Antigen para Exchange versão 9.0 pode falhar. Isso gera uma falha de Dr. Watson faz referência a lata ID 1177692600
    Sintomas
    O processo de AntigenClient.exe Antigen para Exchange versão 9.0 pode falhar. Isso gera uma falha de Dr. Watson faz referência a lata ID 1177692600. O travamento gera o seguinte despejo pilha de chamadas:
    ANTIGENCLIENT.EXE!memcpy [MEMCPY.ASM]
    ANTIGENCLIENT.EXE!CScanJob::ChangeFilterListName [scanjob.cpp]
    ANTIGENCLIENT.EXE!ChangeFilterList [antigenfiltering.cpp]
    ANTIGENCLIENT.EXE!CListNamesPane::OnNotify [antigenfiltering.cpp]
    ANTIGENCLIENT.EXE!CRoundedWnd::WndProc [roundedwnd.cpp]
    User32.dll! InternalCallWinProc [callproc.asm]
    User32.dll! UserCallWinProcCheckWow [clmsg.c]
    User32.dll! SendMessageWorker [clmsg.c]
    User32.dll! SendMessageW [cltxt.h]
    Comctl32.dll! CCSendNotify [notify.c]
    Comctl32.dll! ListView_DismissEdit [lvicon.c]
    Comctl32.dll! ListView_OnCommand [listview.c]
    Comctl32.dll! ListView_WndProc [listview.c]
    User32.dll! InternalCallWinProc [callproc.asm]
    User32.dll! UserCallWinProcCheckWow [clmsg.c]
    User32.dll! CallWindowProcAorW [clmsg.c]
    User32.dll! CallWindowProcW [clmsg.c]
    ANTIGENCLIENT.EXE!CListPane::SubclassListViewProc [roundedwnd.cpp]
    User32.dll! InternalCallWinProc [callproc.asm]
    User32.dll! UserCallWinProcCheckWow [clmsg.c]
    User32.dll! SendMessageWorker [clmsg.c]
    User32.dll! SendMessageW [cltxt.h]
    User32.dll! ECNotifyParent [editec.c]
    User32.dll! SLKillFocus [editsl.c]
    User32.dll! SLEditWndProc [editsl.c]
    User32.dll! EditWndProc [editec.c]
    User32.dll! EditWndProcWorker [editec.c]
    User32.dll! EditWndProcW [editec.c]
    User32.dll! InternalCallWinProc [callproc.asm]
    User32.dll! UserCallWinProcCheckWow [clmsg.c]
    User32.dll! CallWindowProcAorW [clmsg.c]
    User32.dll! CallWindowProcW [clmsg.c]
    Comctl32.dll! ListView_EditWndProc [lvicon.c]
    User32.dll! InternalCallWinProc [callproc.asm]
    User32.dll! UserCallWinProcCheckWow [clmsg.c]
    User32.dll! DispatchClientMessage [client.c]
    User32.dll! __fnDWORD [ntcb.h]
    NTDLL.DLL!KiUserCallbackDispatcher [userdisp.asm]
    User32.dll! NtUserSetFocus [usrstubs.c]
    User32.dll! InternalCallWinProc [callproc.asm]
    User32.dll! UserCallWinProcCheckWow [clmsg.c]
    User32.dll! DispatchMessageWorker [clmsg.c]
    User32.dll! DispatchMessageW [cltxt.h]
    ANTIGENCLIENT.EXE!wWinMain [antigenclient.cpp]
    ANTIGENCLIENT.EXE!__tmainCRTStartup [crt0.c]
    Kernel32.dll! BaseProcessStart [support.c]

    Aplica-se a
    Rollup 5 para Microsoft Antigen para Exchange versão 9.0 SP1
    Antigen para Exchange versão 9.0 SP2
  4. Atualizações de mecanismo de substituição notificações continuam a ser enviada, mesmo que o mecanismo foi desativado de todos os trabalhos de verificação e scanner
    Sintomas
    Um novo recurso foi adicionado para o Service Pack 2 para Antigen versão 9.0 no qual varredura mecanismos que foram descontinuados são removidos do produto. Alertas de email são enviadas ao administrador antes da aposentadoria. No entanto, no Antigen versão 9.0 para SMTP Gateways com Service Pack 2, os administradores ainda recebem esses aposentadoria notificações mesmo quando o mecanismo Descontinuado é desabilitado de todos os trabalhos de verificação e as atualizações de mecanismos.

    Causa
    Esse problema é causado porque o código para verificar quais mecanismos de verificação estão ativados para os trabalhos de verificação é o mesmo em Antigen para Exchange Server e do Antigen para SMTP gateways. No entanto, Antigen para SMTP gateways não contém uma verificação rápida para que você não pode confirmar que os mecanismos foram desativados na verificação rápida em um Antigen para SMTP gateway instalação.

    Aplica-se a
    Antigen 9.0 para SMTP Gateways SP2
  5. AntigenService falha em Antigen 9.0 depois de salvar as alterações feitas no painel Opções gerais do Antigen
    Sintomas
    Depois faça as alterações no painel Opções gerais do Antigen e, em seguida, clique em Salvar, o serviço AntigenService pode falhar.

    A falha será confirmada ao ir para o painel de trabalhos de verificação do administrador do Antigen. O seguinte erro é exibido na parte inferior do console:
    Não é possível conectar-se ao RealTime Scanjob.
    O seguinte erro de log de aplicativo também é registrado:
    O serviço AntigenService terminou inesperadamente.
    TheProgramLog.txt não registrará um erro.
  6. Antigen 9.0 pode detectar que documentos do Office 2003 Word válidos contêm vírus CorruptedCompressedFile
    Sintomas
    Antigen 9.0 erroneamente detecta documentos do Office 2003 Word válidos como CorruptedCompressedFiles. O anexo é removido como um vírus.

    Um anexo de email é removido e um incidente é registrado no painel de incidentes informando que o Antigen removido o arquivo como um vírus CorruptedCompressedFile. O arquivo ProgramLog.txt contém a seguinte entrada:
    INFORMAÇÃO: A verificação em tempo real encontrou vírus: pasta: Folder Name armazenamento Group\file Nomear mensagem: incidentes de linha de assunto: estado CorruptedCompressedFile: removido
    Onde o espaço reservado para Folder Name é o nome da pasta onde o Antigen encontrados vírus.

    Causa
    Este erro é causado pelo método em que o Antigen tenta analisar o documento do Word.
  7. Antigen 9.0 pode gerar o erro a seguir no ProgramLog.txt: "Erro: processo AntigenInternet retornou 80010105 enquanto processesing mensagem"
    Sintomas
    Antigen 9.0 pode gerar o erro a seguir no ProgramLog.txt:
    Erro: O processo de AntigenInternet retornou 80010105 enquanto processesing mensagem

    Causa
    Este erro é causado por um problema no arquivo MimeNavigator.dll Antigen.
  8. Uma atualização do mecanismo de verificação falha e gera um aviso no arquivo ProgramLog.txt
    Sintomas
    Se qualquer um dos Antigen externo mecanismo fornecedores lançam uma atualização de mecanismo incorporar arquivos compactados dentro de subdiretórios, a atualização de mecanismo do Antigen falhará. O seguinte aviso é registrado no arquivo ProgramLog.txt:
    Uma falha foi relatada por observador sincronização quando você instalou o mecanismo de varredura. Ação = 0 x 00000001. C:\Program Files\Microsoft Antigen para Exchange\Engines\x86\ \Bin\bases/stt/ (EngineName)

    Causa
    Esse problema é causado quando o Antigen não é possível atualizar com êxito qualquer mecanismo contém subdiretórios em seus pacotes de atualização.

Como instalar o pacote cumulativo de hotfix

  1. Execute o instalador clicando duas vezes no service pack ou rollup arquivo executável.

    Observação: Quando o instalador está sendo executado, os serviços do Exchange e do Antigen foram interrompidos e seu fluxo de mensagens for interrompido temporariamente.
  2. Após a instalação for concluída e os serviços do Exchange e do Antigen foram reiniciados (Isso ocorre automaticamente durante a instalação), verifique se o Antigen está funcionando corretamente.

    Observação: Antigen service packs ou rollups também pode ser instalado usando o trabalho de implantação de FFSMC. Para obter mais informações, consulte trabalhos de implantação no guia do usuário do Forefront Server Security Management Console. Nesse caso, o programa de instalação é executado no modo silencioso e não há nenhuma entrada de usuário necessária. O restante do processo permanece a mesma ao executar a instalação clicando duas vezes no arquivo executável.

Pré-requisitos

Este pacote cumulativo de hotfix requer o Antigen 9.0 Service Pack 2. Para obter mais informações sobre como obter o Antigen 9.0 Service Pack 2, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
971063Descrição do Antigen 9.0 com Service Pack 2

Informações do arquivo

Este hotfix pode não conter todos os arquivos que você deve ter para actualizar completamente um produto para a compilação mais recente. Esse hotfix contém apenas os arquivos que você deve ter para corrigir os problemas listados neste artigo.

A versão português (Brasil) deste hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas em UTC (hora coordenada universal COORDENADO). Quando você exibe as informações do arquivo, ele é convertido em hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
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Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Aexmladapter.dll9.2.1097.60525,82403-Set-200917: 48x 86
Ant5inst.dll9.2.1097.60963,07203-Set-200917: 48x 86
Antigenasj.dll9.2.1097.60313,85603-Set-200917: 48x 86
Antigenclient.exe9.2.1097.601,185,28003-Set-200917: 48x 86
Antigendiag.exe9.2.1097.60286,72003-Set-200917: 48x 86
Antigeninternet.exe9.2.1097.60823,29603-Set-200917: 48x 86
Antigenmanual.exe9.2.1097.60813,56803-Set-200917: 48x 86
Antigenpmdll.dll9.2.1097.60294,91203-Set-200917: 48x 86
Antigenpmsetup.exe9.2.1097.60272,38403-Set-200917: 49x 86
Antigenrealtime.exe9.2.1097.60794,11203-Set-200917: 49x 86
Antigenservice.exe9.2.1097.601,499,64803-Set-200917: 49x 86
Antigensmtpsink.dll9.2.1097.60430,08003-Set-200917: 49x 86
Antutil.exe9.2.1097.60316.92803-Set-200917: 49x 86
Fsecontentscanner.exe9.2.15.0670,06403-Set-200919: 33x 86
Getenginefiles.exe9.2.1097.60600,06403-Set-200917: 49x 86
Mimenavigator.dll9.2.1097.60296,96003-Set-200917: 49x 86
Scanenginetest.exe9.2.1097.60527,36003-Set-200917: 48x 86
Sfxcab.exe9.2.1097.5643.00803-Set-200919: 36x 86
Smimenavigator.dll9.2.1097.60221,69603-Set-200917: 48x 86
Structstgnavigator.dll9.2.1097.60272,89603-Set-200917: 48x 86
Sybariave.dllNão aplicável557,56803-Set-200919: 35x 86
Synchelper.dll1.2.0.110474,11203-Set-200919: 34x 86
Tnefnavigator.dll9.2.1097.60283,13603-Set-200917: 48x 86
Custom.dllNão aplicável73,72803-Set-200919: 37x 86
Updspapi.dll6.3.13.0382,84027 De julho de 200717: 41x 86

Propriedades

ID do artigo: 975355 - Última revisão: sexta-feira, 19 de março de 2010 - Revisão: 8.0
A informação contida neste artigo aplica-se a:
  • Microsoft Antigen 9.0 for Exchange Service Pack 2
  • Microsoft Antigen 9.0 for SMTP Gateways Service Pack 2
Palavras-chave: 
kbmt kbautohotfix atdownload kbregistry kbhotfixserver kbexpertiseadvanced kbhotfixrollup kbsurveynew kbfix KB975355 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
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