Problembehandlung bei Zugriffsfehlern bei Namespaces des verteilten Dateisystems in Windows

Dieser Artikel bietet eine Lösung zum Beheben von DFSN-Zugriffsfehlern (Distributed File System Namespace).

Gilt für: Windows 10 (alle Editionen), Windows Server 2012 R2
Ursprüngliche KB-Nummer: 975440

Symptome

Wenn Sie auf einem Computer mit Windows XP oder Windows Server 2003 versuchen, auf eine DFSN zuzugreifen, erhalten Sie die folgende Fehlermeldung:

\\<Domänenname>\<DFS-Namespace> ist nicht zugänglich. Sie haben eventuell keine Berechtigung, diese Netzwerkressource zu verwenden. Setzen Sie sich mit dem Administrator dieses Servers in Verbindung, um herauszufinden, ob Sie über Berechtigungen verfügen.

Konfigurationsinformationen konnten nicht vom Domänencontroller gelesen werden, weil der Computer nicht verfügbar ist oder der Zugriff verweigert wurde.

Unter Windows Vista und höheren Versionen von Windows wird möglicherweise eine der folgenden Fehlermeldungen angezeigt:

Windows kann nicht auf \\<Domänenname>\<DFS-Namespace zugreifen>

Der Netzwerkpfad wurde nicht gefunden.

Ursache

Dieser Fehler tritt in der Regel auf, weil der DFSN-Client die Verbindung mit einem DFSN-Pfad nicht herstellen kann.

Die Verbindung kann aus einem der folgenden Gründe fehlschlagen:

  • Fehler beim Herstellen einer Verbindung mit einem Domänencontroller zum Abrufen einer DFSN-Namespace-Empfehlung
  • Fehler beim Herstellen einer Verbindung mit einem DFSN-Server
  • Fehler beim Bereitstellen einer Ordnerverweis durch den DFSN-Server

Lösung

Um dieses Problem zu beheben, müssen Sie die Netzwerkkonnektivität, die Namensauflösung und die DFSN-Dienstkonfiguration auswerten. Sie können die folgenden Methoden verwenden, um jede dieser Abhängigkeiten auszuwerten.

Verbindung

In diesem Artikel bezieht sich Konnektivität auf die Fähigkeit des Clients, einen Domänencontroller oder einen DFSN-Server zu kontaktieren. Wenn ein Client keine Netzwerkverbindung mit einem Domänencontroller oder einem DFSN-Server herstellen kann, schlägt die DFSN-Anforderung fehl.

Sie können die folgenden Tests verwenden, um die Konnektivität zu überprüfen.

Ermitteln Sie mithilfe DFSUtil.exe /spcinfo des Befehls, ob der Client eine Verbindung mit einem Domänencontroller für Domäneninformationen herstellen konnte. Die Ausgabe dieses Befehls beschreibt die vertrauenswürdigen Domänen und ihre Domänencontroller, die vom Client über DFSN-Empfehlungsabfragen ermittelt werden. Dies wird als Domänencache bezeichnet.

Im folgenden Beispiel werden sowohl der DNS-Domänenname contoso.com als auch der NetBIOS-Domänenname CONTOSO vom Client ermittelt. Für den Domänennamen CONTOSO wurden zwei Domänencontroller identifiziert: 2003server2 und 2003server1. Wenn der Client in einer Anforderung auf den DNS-Namen contoso.comzugreift, werden die Einträge unter dem contoso.com Eintrag angezeigt.

[*][2003server1.contoso.com]
[*][CONTOSO]
[*][contoso.com]
[+][CONTOSO]
    [-2003server2]
    [+2003server1]
[-][contoso.com]

Einträge, die mit einem Sternchen (*) gekennzeichnet sind, wurden über den Arbeitsstationsdienst abgerufen. Die anderen Einträge wurden durch Empfehlungen des DFSN-Clients abgerufen. Die Einträge, die durch ein Pluszeichen (+) gekennzeichnet sind, sind die Domänencontroller, die derzeit vom Client verwendet werden. Weitere Informationen zu Empfehlungsprozessen finden Sie unter Funktionsweise von DFS.

Um die Konnektivität zu bewerten, versuchen Sie eine einfache Netzwerkverbindung mit dem aktiven Domänencontroller unter Verwendung seiner IP-Adresse. Geben Sie beispielsweise einen der folgenden Befehle ein:

  • start \\192.168.1.11
  • net view \\192.168.1.11

Eine erfolgreiche Verbindung listet alle Freigaben auf, die vom Domänencontroller gehostet werden.

Wenn die Verbindung erfolgreich ist, bestimmen Sie, ob eine gültige DFSN-Empfehlung an den Client zurückgegeben wird, nachdem er auf den Namespace zugegriffen hat. Dazu können Sie den Empfehlungscache (auch als PKT-Cache bezeichnet) mithilfe des DFSUtil.exe /pktinfo Befehls anzeigen.

Die folgende Ausgabe enthält die erwarteten Einträge im Empfehlungscache des Clients, nachdem der Client auf den DFSN-Pfad \\contoso.com\dfsroot\linkzugegriffen hat. Der Stamm hat zwei Ziele (rootserver1 und rootserver2). Der Link hat ein einzelnes Ziel (Dateiserver).

Entry: \contoso.com\dfsroot
ShortEntry: \contoso.com\dfsroot
Expires in 300 seconds
UseCount: 0 Type:0x81 ( REFERRAL_SVC DFS )
    0:[\ROOTSERVER1\dfsshare] State:0x119 ( ACTIVE )
    1:[\ROOTSERVER2\dfsshare] State:0x09 ( )

Entry: \contoso.com\dfsroot\link
ShortEntry: \contoso.com\dfsroot\link
Expires in 1800 seconds
UseCount: 0 Type:0x1 ( DFS )
    0:[\fileserver\data] State:0x131 ( ACTIVE )

Wenn Sie keinen Eintrag für den gewünschten Namespace finden, ist dies ein Beweis dafür, dass der Domänencontroller keine Empfehlung zurückgegeben hat. DfSN-Dienstfehler werden weiter unten in diesem Artikel erläutert.

Wenn ein Eintrag für den Namespace (d. h. ) angezeigt wird, beweist der Eintrag, \contoso.com\dfsrootdass der Client einen Domänencontroller kontaktieren konnte, dann aber keine DFSN-Namespaceziele erreicht hat. Wenn keines der aufgelisteten Namespaceziele als ACTIVE festgelegt ist, bedeutet dies, dass alle Ziele nicht erreichbar waren.

Versuchen Sie, mithilfe von IP-Adressen auf jeden Namespaceserver zuzugreifen. Für diesen Test müssen Sie nur die IP-Adresse des Servers angeben, und Sie dürfen die Namespacefreigabe nicht einschließen (also net view \\192.168.1.11 nicht net view \\192.168.1.11\dfsroot). Andernfalls können Sie unwissentlich auf einen anderen DFS-Stammserver verwiesen werden. In diesem Fall erhalten Sie irreführende Ergebnisse. Notieren Sie sich alle Fehlermeldungen, die während dieser Aktionen gemeldet werden.

Sie müssen alle Fehler eines Domänencontrollers oder der Kommunikation des DFS-Namespaceservers untersuchen und beheben. Weitere Informationen zu TCP/IP-Netzwerkdetails und zur Problembehandlung von Hilfsprogrammen finden Sie in der technischen Referenz zu TCP/IP.

Namensauflösung

Clients müssen den Namen des DFS-Namespace und aller Server auflösen, die den Namespace hosten. Überprüfen Sie die Ausgabe, die zuvor mit den dfsutil /pktinfo Befehlen und dfsutil /spcinfo generiert wurde. Die aufgeführten Servernamen müssen vom Client in IP-Adressen aufgelöst werden.

Sie können die folgenden Methoden verwenden, um die ordnungsgemäße Namensauflösung zu überprüfen.

  • WINS- und NetBIOS-Namen

    NetBIOS-Namensauflösungsfehler können auftreten, weil Namensdatensätze fehlen oder weil Sie die falsche IP-Adresse für den Namen erhalten haben. Um dies zu testen, versuchen Sie, auf den Domänencontroller zuzugreifen, indem Sie nur dessen NetBIOS-Computernamen verwenden (d. a. mithilfe des Befehls net view \\2003server1). Vergewissern Sie sich dann, dass es sich bei den aufgelisteten Freigaben um die Freigaben handelt, die vom Server gehostet werden sollen. Als Administrator können Sie den NetBIOS-Namenscache des Clients anzeigen, indem Sie den nbtstat -c Befehl verwenden, um alle aufgelösten Namen und ihre IP-Adressen zu überprüfen. Sehen Sie sich das folgende Beispiel an:

    Name Netbios Remotetyp Hostadresse des Cachenamens der Tabelle Leben [Sek.]
    2003server1 <00> EINZIGARTIGE 192.168.1.11 462

    Lesen Sie die folgenden Dokumente, um WINS-Fehler zu beheben:

  • DNS-Namen

    Standardmäßig speichert DFSN NetBIOS-Namen für Stammserver. DFSN kann auch für die Verwendung von DNS-Namen für Umgebungen ohne WINS-Server konfiguriert werden. Weitere Informationen finden Sie unter Konfigurieren von DFS für die Verwendung vollqualifizierter Domänennamen in Empfehlungen.

    Sie können den DNS-Resolvercache des Clients anzeigen, um aufgelöste DNS-Namen zu überprüfen. Öffnen Sie dazu eine Eingabeaufforderung, und geben Sie den ipconfig /displaydns Befehl ein.

    Sehen Sie sich das folgende Beispiel an:

    Windows-IP-Konfiguration

    2003server1

    Datensatzname . . . . . : 2003server1.contoso.com
    Datensatztyp . . . . . : 1
    Gültigkeitsdauer . . . . : 882
    Datenlänge . . . . . : 4
    Abschnitt. . . . . . . :Antwort
    Ein (Host)-Datensatz . . . : 192.168.1.11

    Lesen Sie die folgenden Dokumente, um DNS-Fehler zu beheben:

  • Netzwerkerfassung

    Eine Netzwerkerfassung kann Ihnen bei der Diagnose eines Namensauflösungsfehlers helfen. Bevor Sie eine Erfassung durchführen, leeren Sie zwischengespeicherte Benennungsinformationen auf dem Client. Wenn Sie dies tun, werden Sie keine Probleme offenlegen, die möglicherweise in der Erfassung vorhanden sind, da zwischengespeicherte Empfehlungsdaten oder Namen nicht erneut über das Netzwerk angefordert werden. Führen Sie die folgenden Befehle in dieser Reihenfolge aus, um die Namenscaches zu leeren:

    • nbtstat -RR
    • ipconfig /flushdns
    • dfsutil /pktflush
    • dfsutil /spcflush

Weitere Informationen zum Microsoft-Netzwerkmonitor 3 finden Sie unter Informationen zum Netzwerkmonitor 3.

Weitere Informationen zum Netzwerkdatenverkehr, der zwischen einem Client und einer domänenbasierten DFS-Umgebung beobachtet wird, finden Sie unter Funktionsweise von DFS.

Weitere Informationen zu DNS und WINS finden Sie unter Namensauflösungstechnologien.

DFS und Systemkonfiguration

Selbst wenn konnektivitäts- und namensauflösung ordnungsgemäß funktionieren, können DFS-Konfigurationsprobleme dazu führen, dass der Fehler auf einem Client auftritt. DFS basiert auf aktuellen DFS-Konfigurationsdaten, ordnungsgemäß konfigurierten Diensteinstellungen und Active Directory-Standortkonfiguration.

Überprüfen Sie zunächst, ob der DFS-Dienst auf allen Domänencontrollern und auf DFS-Namespace-/Stammservern gestartet wurde. Wenn der Dienst an allen Standorten gestartet wird, stellen Sie sicher, dass in den Systemereignisprotokollen der Server keine DFS-bezogenen Fehler gemeldet werden.

Wenn ein Administrator eine Änderung am domänenbasierten Namespace vornimmt, erfolgt die Änderung am PDC-Emulator (Primary Domain Controller) master. Domänencontroller und DFS-Stammserver fragen in regelmäßigen Abständen PDC nach Konfigurationsinformationen ab. Wenn der PDC nicht verfügbar ist oder der "Stammskalierbarkeitsmodus" aktiviert ist, können Wartezeiten und Fehler bei der Active Directory-Replikation verhindern, dass Server korrekte Verweise ausgeben. Weitere Informationen zum Stammskalierbarkeitsmodus finden Sie unter Überprüfen von DFS-Größenempfehlungen.

Eine Methode zum Auswerten der Replikationsintegrität besteht darin, die status des letzten eingehenden Replikationsversuchs für jeden Domänencontroller abzufragen. Führen Sie dazu den Befehl repadmin.exe aus. Die erforderliche Syntax für diesen Befehl lautet wie folgt:

repadmin /showrepl * DN_of_domain

Hinweis

In diesem Befehl stellt * alle Domänencontroller dar, die abgefragt werden sollen, und DN_of_domain stellt den Distinguished Name der Domäne dar, z. B. dc=contoso,dc=com.

Überprüfen Sie die status und den Zeitpunkt der letzten erfolgreichen Replikation, um sicherzustellen, dass die DFSN-Konfigurationsänderungen alle Domänencontroller erreicht haben. Sie sollten alle Fehler untersuchen, die für die eingehende Replikation auf einem Domänencontroller gemeldet werden.

DfSN-Konfigurationsprobleme können auch den Zugriff auf den Namespace verhindern. Ein häufiges Szenario, in dem dies geschieht, ist ein Client, der zu einem Standort gehört, der keine Namespace- oder Ordnerziele enthält. Wenn der Namespace so konfiguriert ist, dass Empfehlungsziele nur innerhalb des Standorts des Clients (option insite ) ausgestellt werden, stellt DFSN keine Empfehlung bereit. Um auszuwerten, ob die Option "Insite" für einen Namespace konfiguriert ist, öffnen Sie eine Eingabeaufforderung, und geben Sie dann den dfsutil /path:\\contoso.com\dfs /insite /display Befehl ein.

Ebenso können Probleme mit der Active Directory-Standortkonfiguration verhindern, dass DFSN-Server den Clientstandort ordnungsgemäß bestimmen. Daher können diese Probleme zu Empfehlungsfehlern führen, wenn insite konfiguriert ist. Der DFSN-Dienst ordnet den Client einem Standort zu, indem er die Quell-IP-Adresse der Empfehlungsanforderung des Clients analysiert. Der DFS-Dienst ordnet auch jeden Stammzielserver einem Standort zu, indem der Name des Zielservers in eine IP-Adresse aufgelöst wird. Um zu bewerten, ob ein Domänencontroller oder ein DFS-Stamm den richtigen Standort des Systems ermitteln kann, führen Sie einen der folgenden Befehle lokal auf den Domänencontrollern und auf dem DFS-Namespaceserver aus:

  • dfsutil /sitename:root_target_name
  • dfsutil /sitename:client_ip_address

References