Article ID: 975470 - Last Review: November 26, 2009 - Revision: 2.0

CPU usage may reach 100 percent when you use the Input Method Editor (IME) for Japanese characters on a computer that is running Windows Server 2003

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SYMPTOMS

On a computer that is running Windows Server 2003, the Imjputy.exe, Imjpuex.exe, or Imjpdct.exe process consumes lots of CPU resources when you use the Microsoft Input Method Editor (IME) for Japanese characters. In this situation, the CPU usage of the computer may reach 100 percent.

CAUSE

This problem occurs because the IME enters an infinite loop when it tries to fix a corrupted dictionary.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Server 2003 Service Pack 2 (SP2)
  • Windows XP Professional x64 Edition
For more information about how to obtain the latest Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Imjp81k.dll8.1.7103.0696,32022-Sep-200903:43x86

For all supported x64-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Imjp81k.dll8.1.7103.01,107,45622-Sep-200901:25x64SP2Not Applicable
Wimjp81k.dll8.1.7103.0696,32022-Sep-200901:25x86SP2WOW

For all supported Itanium-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Imjp81k.dll8.1.7103.02,219,00822-Sep-200901:25IA-64SP2Not Applicable
Wimjp81k.dll8.1.7103.0696,32022-Sep-200901:25x86SP2WOW

For all supported Windows XP professional X64 Edition
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Imjp81k.dll8.1.7103.01,107,45622-Sep-200901:25x64SP2Not Applicable
Wimjp81k.dll8.1.7103.0696,32022-Sep-200901:25x86SP2WOW


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbbug kbfix kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbqfe KB975470