Chyba č: 120793 (Údržba obsahu)Chyba #: 718934 (Dev10)
Příznaky
Při pokusu nainstalovat Microsoft Commerce Server 2009 v počítači se systémem Windows Server 2008 R2, instalace se nezdaří. Dále se zobrazí následující chybová zpráva:
Rozhraní.NET Framework 3.5 SP1 není v počítači k dispozici. Je nutné nainstalovat na rozhraní.NET Framework 3.5 s aktualizací SP1 Chcete-li pokračovat v instalaci.
Poznámka: K tomuto problému dochází i v případě, že máte rozhraní.NET Framework 3.5 Service Pack 1 (SP1) nebo novější verze rozhraní.NET Framework, nainstalován.
Příčina
Během instalace Commerce Server 2009 hledá instalační program rozhraní.NET Framework 3.5 SP1 vyhledejte klíče registru konkrétní. Verze rozhraní.NET Framework, která je integrována s Windows Server 2008 R2 nemá klíč registru. Proto instalační program přestane reagovat.
Řešení
Chcete-li vyřešit tento problém, použijte následující opravu hotfix v počítači se systémem Windows Server 2008 R2, před instalací Commerce Server 2009.
Tato oprava hotfix neaktualizuje žádné soubory v počítači. Tato oprava hotfix bude vytvořit položky registru vyžadované Instalační Commerce Server 2009. Pokud požadované položky registru již existují, systém zobrazí následující zpráva:
Není nutné použít tuto opravu pro tento počítač.Důrazně doporučujeme po úspěšné instalaci Commerce Server 2009 odebrat tuto opravu hotfix. Opravy hotfix lze odinstalovat pomocí položky programy a funkce v Ovládacích panelech.
Informace o opravě hotfix
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.
Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.
Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Pro úplný seznam služeb zákazníkům společnosti Microsoft a podpoře telefonní čísla nebo vytvořit zvláštní požadavek na službu, navštivte následující Web společnosti Microsoft:-
http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Předpoklady
Windows Server 2008 R2 nainstalovat tuto opravu hotfix, musí mít.
Požadavek na restartování
Po instalaci této opravy hotfix nemusíte restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje žádné další opravy hotfix.
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Další informace
Podpora je k dispozici pro následující verze serveru Commerce Server se systémem Windows Server 2008 R2:
-
Commerce Server 2009
-
Commerce Server 2007 Service Pack 2 (SP2)
Při upgradu ze systému Windows Server 2008 Windows Server 2008 R2 s aktualizací SP2 Microsoft Commerce Server 2007 a Commerce Server 2009 fungovat očekávaným způsobem.