Při použití aplikace, která sleduje protokolu událostí otevřít soubor protokolu událostí v počítači se systémem Windows Server 2003 SP2 se zobrazí chybová zpráva: „ soubor protokolu událostí je poškozen. „

Překlady článku Překlady článku
ID článku: 975652 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při použití protokolu událostí, jako je například Prohlížeč událostí sleduje aplikace otevřít soubor protokolu událostí v počítači se systémem Windows Server 2003 Service Pack 2 (SP2), obdržíte následující chybová zpráva:
Protokol událostí je poškozen (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).).
Poznámka: Z mnoha důvodů může dojít k poškození protokolu událostí. Tato oprava hotfix řeší pouze zvláštní důvod uvedených v části "Příčina" způsobené poškození protokolu událostí.

Příčina

K tomuto problému dochází, protože položka protokolu událostí chybí hodnota pole "Název počítače" nebo "Zdroj" pole v souboru protokolu událostí. Pokud aplikace volá funkci ReadEventLog načíst položky protokolu událostí, je vrácen kód chyby STATUS_EVENTLOG_FILE_CORRUPT. Proto aplikace zobrazí chybová zpráva.

Položka protokolu událostí chybět hodnotu pro pole "Název počítače" nebo "Zdroj" pole může způsobit mnoho faktorů.

Aplikace například volání funkce GetComputerName načíst název počítače. Potom tato aplikace zapíše vrácená hodnota přímo položka nově vytvořený protokol událostí bez kontroly hodnotu. Však důvodu nedostatku paměti počítače, funkce GetComputerName nezdaří a vrátí hodnotu NULL. V tomto příkladu položka protokolu událostí chybí hodnota pro pole "Název počítač".

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li použít tuto opravu hotfix, musí být v počítači Windows Server 2003 Service Pack 2 (SP2).

Požadavek na restartování

Máte po použití této opravy hotfix restartovat počítač.

Další informace o instalaci aktualizace Windows Server 2003 service pack klepněte na následující číslo článku databáze Microsoft Knowledge Base:
889100Jak získat nejnovější aktualizaci Service Pack pro systém Windows Server 2003

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné jiné opravy hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi UTC a místním časem, použití kartu časové pásmo v datum a čas v ovládacím panelu.
Poznámka informace o souboru Windows Server 2003

Pro všechny podporované verze x86 systému Windows Server 2003

Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Advapi32.dll5.2.3790.4589619,00814. Září 200917: 19X86
Pro všechny podporované verze x64 systému Windows Server 2003
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Advapi32.dll5.2.3790.45891,065,47215. Září 200906: 03X64SP2
Wadvapi32.dll5.2.3790.4589619,00815. Září 200906: 03X86SP2
Pro všechny podporované verze systému Windows Server 2003 pro procesory Itanium
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Advapi32.dll5.2.3790.45891,483,77615. Září 200906: 03IA-64SP2
Wadvapi32.dll5.2.3790.4589619,00815. Září 200906: 03X86SP2

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Odkazy

Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 975652 - Poslední aktualizace: 14. října 2009 - Revize: 1.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Klíčová slova: 
kbmt kbexpertiseinter kbautohotfix kbqfe kbbug kbfix kbsurveynew kbhotfixserver KB975652 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:975652

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com