Mensaje de error cuando utiliza una aplicación que supervisa el registro de sucesos para abrir un archivo de registro de sucesos en un equipo que ejecuta Windows Server 2003 SP2: "el archivo de registro de sucesos está dañado"

Seleccione idioma Seleccione idioma
Id. de artículo: 975652 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando utiliza una aplicación que supervisa el registro de sucesos, como el Visor de sucesos, para abrir un archivo de registro de sucesos en un equipo que ejecuta Windows Server 2003 Service Pack 2 (SP2), recibirá el siguiente mensaje de error:
El archivo de registro de sucesos está dañado.
Nota Puede experimentar daños en el registro de sucesos por muchos motivos. Esta revisión corrige los daños de registro de eventos causados por sólo el motivo específico que se menciona en la sección "Causa".

Causa

Este problema se produce porque falta un valor para el campo "Nombre de equipo" o para el campo "Source" en el archivo de registro de eventos en una entrada del registro de eventos. Si una aplicación llama a la función ReadEventLog para recuperar las entradas del registro de eventos, se devuelve un código de error STATUS_EVENTLOG_FILE_CORRUPT. Por tanto, la aplicación muestra un mensaje de error.

Muchos factores pueden provocar una entrada del registro de eventos que le falta un valor para el campo "Nombre de equipo" o el campo "Source".

Por ejemplo, una aplicación llama a la función GetComputerName para recuperar el nombre de equipo. A continuación, en esta aplicación se escribe el valor devuelto directamente en una entrada del registro de eventos recién creado sin comprobar el valor. Sin embargo, porque la memoria del equipo es baja, la función GetComputerName se produce un error y devuelve un valor NULL. En este ejemplo, la entrada del registro de sucesos le falta un valor para el campo "Nombre de equipo".

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si se requiere cualquier solución de problemas, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión específica. Para obtener una lista completa de servicio de atención al cliente y soporte números de teléfono o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponible" muestra los idiomas para el que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, el equipo debe ejecutar Windows Server 2003 Service Pack 2 (SP2).

Requisito de reinicio

Tiene que reiniciar el equipo después de aplicar este hotfix.

Para obtener más información acerca de cómo instalar el service pack de Windows Server 2003, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a ningún otro hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para encontrar la diferencia entre la UTC y la hora local, utilice la ficha zona horaria en la fecha y hora elemento del panel de control.
Nota de información de archivo de Windows Server 2003

Para todas las versiones de 86 de Windows Server 2003 x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Advapi32.dll5.2.3790.4589619,00814-Sep-200917: 19x 86
Para todas las versiones de 64 de Windows Server 2003 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaRequisito de SP
Advapi32.dll5.2.3790.45891,065,47215-Sep-200903: 06x 64SP2
Wadvapi32.dll5.2.3790.4589619,00815-Sep-200903: 06x 86SP2
Para todas las versiones basadas en Itanium de Windows Server 2003
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaRequisito de SP
Advapi32.dll5.2.3790.45891,483,77615-Sep-200903: 06IA-64SP2
Wadvapi32.dll5.2.3790.4589619,00815-Sep-200903: 06x 86SP2

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Referencias

Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 975652 - Última revisión: miércoles, 14 de octubre de 2009 - Versión: 1.1
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Palabras clave: 
kbmt kbexpertiseinter kbautohotfix kbqfe kbbug kbfix kbsurveynew kbhotfixserver KB975652 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 975652

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com