รหัสข้อผิดพลาดเมื่อคุณพยายามติดตั้งบทบาทของเซิร์ฟเวอร์ DNS หากอะแดปเตอร์ของเครือข่ายทั้งหมดถูกปิดการใช้งาน หรือถอดสายออกบนคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Server 2008:"0x80070643"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 975654 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

บนคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Server 2008 คุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้เมื่อคุณพยายามติดตั้งบทบาทของเซิร์ฟเวอร์ DNS ด้วยเครื่องมือของ Dcrpromo.exe:
พยายามที่จะทำการติดตั้งเซิร์ฟเวอร์ DNS ที่ล้มเหลว ด้วยรหัสข้อผิดพลาด 0x80070643 ข้อผิดพลาดร้ายแรงในระหว่างการติดตั้ง

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากการติดตั้งบทบาทของเซิร์ฟเวอร์ DNS ไม่สำเร็จหากไม่มีอะแดปเตอร์เครือข่ายจะมี ip แอดเดรส ใช้คอมโพเนนต์ Servicing จำเป็นต้องให้บริการเซิร์ฟเวอร์ DNS เริ่มต้นในระหว่างขั้นตอนการติดตั้ง DNS เซิร์ฟเวอร์บทบาท โดยการออกแบบ การบริการเซิร์ฟเวอร์ DNS ไม่สามารถเริ่มต้นถ้าไม่มีการเชื่อมต่อเครือข่าย ดังนั้น การติดตั้งบทบาทเซิร์ฟเวอร์ DNS ล้มเหลว

หมายเหตุหลังจากที่คุณติดตั้งโปรแกรมแก้ไขด่วนที่อธิบายไว้ในบทความนี้ ข้อจำกัดนี้จะถูกเอาออก

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ใช้โปรแกรมแก้ไขด่วนนี้ โดยการใช้ต่อไปนี้ขั้นตอน:
  1. ขยายแฟ้ม Msu โดยใช้โปรแกรมอรรถประโยชน์ Expand.exe ตัวอย่างเช่น:
    ขยาย –f: Windows6.0-KB971347-x86.cab "C:\Windows6.0-KB975654-x86.msu" % TEMP %


    สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการขยายตัวเลือกบรรทัดคำสั่ง แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://technet.microsoft.com/en-us/library/cc722332 (WS.10) .aspx
  2. ใช้โปรแกรมอรรถประโยชน์ Pkgmgr เพื่อติดตั้งแฟ้ม.cab ที่มาจากแฟ้ม Msu ตัวอย่างเช่น:
    เริ่มการทำงานของ /m:%TEMP%\Windows6.0-KB975654-x86.cab /ip pkgmgr ของ /w


    สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการอ้างอิงทางเทคนิคของการจัดการชุด (Pkgmgr.exe) แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://technet.microsoft.com/en-us/library/cc749302 (WS.10) .aspx
มีโปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มุ่งหวังเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น การนำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณจะไม่ได้รับความเสียหายรุนแรงผลจากปัญหานี้ เราขอแนะนำให้ คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่ประกอบด้วยโปรแกรมแก้ไขด่วนนี้

หากโปรแกรมแก้ไขด่วนพร้อมใช้งานสำหรับการดาวน์โหลด จะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมใช้งานดาวน์โหลด" ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ติดต่อ Microsoft ฝ่ายบริการสนับสนุนลูกค้าเพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุหากเกิดปัญหาอื่น ๆ หรือการแก้ไขปัญหาใด ๆ จำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะนำไปใช้กับคำถามเพิ่มเติมและเรื่องที่ไม่สามารถจัดหาโปรแกรมแก้ไขด่วนนี้เฉพาะ สำหรับรายการทั้งหมด ของหมายเลขโทรศัพท์ของฝ่ายบริการลูกค้าของ Microsoft สนับสนุน หรือเมื่อต้อง การสร้างการร้องขอบริการแยกต่างหาก แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=support
หมายเหตุแบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมใช้งาน" ดาวน์โหลด"แสดงภาษาโปรแกรมแก้ไขด่วนจะพร้อมใช้งาน ถ้าคุณไม่เห็นภาษาของคุณ ไม่ได้เนื่องจากไม่มีโปรแกรมแก้ไขด่วนพร้อมใช้งานสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

คุณต้องใช้โปรแกรมแก้ไขด่วนนี้บนคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Server 2008 Service Pack 2 (SP2) และมีการติดตั้งบทบาทของเซิร์ฟเวอร์ DNS

ความต้องการเริ่มต้นใหม่

คุณไม่มีการเริ่มระบบของคอมพิวเตอร์ใหม่หลังจากที่คุณนำโปรแกรมแก้ไขด่วนนี้

ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่แทนการแก้ไขด่วนอื่น ๆ

แฟ้มข้อมูล

เวอร์ชันภาษาอังกฤษของ hotfix นี้มีแอตทริบิวต์ของแฟ้ม (หรือแอตทริบิวต์ของแฟ้มที่ใหม่กว่า) ซึ่งแสดงอยู่ในตารางต่อไปนี้ วันและเวลาของแฟ้มเหล่านี้จะแสดงรายการในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้มข้อมูล จะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC และเวลาท้องถิ่น ใช้โซนเวลาแท็บในวันและเวลาสินค้าใน'แผงควบคุม'

สำหรับข้อมูลทั้งหมดที่ได้รับการสนับสนุน Windows Server 2008 SP2 รุ่นที่ใช้ x86
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดของแฟ้มวันที่เวลาแพลตฟอร์ม
Cache.dnsไม่เกี่ยวข้อง3,17903 2009 เมษายน20:42ไม่เกี่ยวข้อง
Dns.exe6.0.6002.22228510,97617-200909:49x 86
Dnsserver.events.xmlไม่เกี่ยวข้อง60903 2009 เมษายน20:42ไม่เกี่ยวข้อง
สำหรับข้อมูลทั้งหมดที่ได้รับการสนับสนุน Windows Server 2008 SP2 รุ่นที่ใช้ x64
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดของแฟ้มวันที่เวลาแพลตฟอร์ม
Cache.dnsไม่เกี่ยวข้อง3,17903 2009 เมษายน20:39ไม่เกี่ยวข้อง
Dns.exe6.0.6002.22228639,48817-200909:59x 64
Dnsserver.events.xmlไม่เกี่ยวข้อง60903 2009 เมษายน20:39ไม่เกี่ยวข้อง

การหลีกเลี่ยงปัญหา

เมื่อต้องการแก้ไขปัญหา ตรวจสอบให้แน่ใจว่า การ์ดเชื่อมต่อเครือข่ายอย่างน้อยหนึ่งที่มีที่อยู่ IP ที่กำหนดให้

สถานะ

Microsoft ยืนยันว่า ปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งแสดงไว้ในส่วน"ใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
824684คำอธิบายเกี่ยวกับคำศัพท์เฉพาะทางมาตรฐานที่ใช้เพื่ออธิบายปรับปรุงซอฟต์แวร์ของ Microsoft

คุณสมบัติ

หมายเลขบทความ (Article ID): 975654 - รีวิวครั้งสุดท้าย: 12 กุมภาพันธ์ 2554 - Revision: 1.0
ใช้กับ
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbhotfixserver kbautohotfix kbexpertiseadvanced kbqfe kbsurveynew kbmt KB975654 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:975654

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com