Une capture instantanée peut-être être endommagée lorsque les fournisseurs d'instantanés de Volume Shadow Copy Service (VSS) prend plus de 10 secondes pour créer sur un ordinateur qui exécute Windows 7 ou Windows Server 2008 R2

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Numéro d'article: 975688 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

VSS (Volume Shadow Copy Service) ne renvoie pas d'erreur lorsque les fournisseurs d'instantanés prend plus de 10 secondes pour créer une capture instantanée sur un ordinateur qui exécute Windows 7 ou Windows Server 2008 R2. Par conséquent, vous ne connaissez pas de risque d'altération des données jusqu'à ce que vous essayez de restaurer un instantané créé.

Cause

VSS (Volume Shadow Copy Service) offre les 10 secondes de fournisseurs pour bloquer les demandes d'e/S et pour créer une capture instantanée. Si une capture instantanée est créée ou que le minuteur arrive à 10 secondes, VSS libère writers de reprendre les demandes d'e/S. Si une capture instantanée n'est pas créée dans les 10 secondes, la corruption de capture instantanée peut se produire. Par conséquent, VSS est censée pour renvoyer une erreur lorsque la limite de 10 secondes est atteint.

Cependant, VSS dans Windows Server 2008 R2 et Windows 7 ne renvoie pas l'erreur VSS_E_HOLD_WRITES_TIMEOUT lorsqu'un fournisseur de capture instantanée prend plus de 10 secondes pour créer une capture instantanée. Cette capture instantanée est créée sans erreur renvoyée.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible au téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions supplémentaires et aux problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète des numéros de téléphone Microsoft auprès des services de support technique ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, l'ordinateur doit exécuter l'un des systèmes d'exploitation suivants :
  • Windows Server 2008 R2
  • Windows 7

La nécessité de redémarrer

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif possède les attributs de fichier (ou version ultérieure fichier) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel (UTC). Lorsque vous affichez les informations de fichier, il est converti en heure locale. Pour connaître le décalage entre l'UTC et heure locale, utilisez le fuseau horaire onglet dans date et heure dans le panneau de configuration.
Windows Server 2008 R2 et Windows 7 note d'information de fichier

Les fichiers MANIFEST (.manifest) et le MUM (.mum) installés pour chaque environnement est listed separately. MUM et fichiers MANIFEST et les fichiers du catalogue (.cat) de sécurité associés, sont essentiels pour conserver l'état du composant mis à jour. Les fichiers du catalogue de sécurité (attributs non répertoriés) sont signés à l'aide d'une signature numérique Microsoft.
Pour toutes les x 86 exécutant des versions de Windows 7

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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Volsnap.sys6.1.7600.20528245,33616-Sep-200905 : 28x 86
Volume.infNon applicable1,94815-Sept-200922 : 59Non applicable
Pour toutes les versions 64 de Windows Server 2008 R2 et de Windows 7 x

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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Volsnap.sys6.1.7600.20528294,98416-Sep-200905 : 52x 64
Volume.infNon applicable1,96815-Sept-200922 : 48Non applicable
Pour toutes les prises en charge les versions IA-64 de Windows Server 2008 R2

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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Volsnap.sys6.1.7600.20528675,41616-Sep-200904 : 51IA-64
Volume.infNon applicable1,95815-Sept-200922 : 46Non applicable


Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "S'applique à".

Plus d'informations

Pour plus d'informations sur la terminologie de mise à jour de logiciel, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
824684Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Informations sur les fichiers supplémentaires

Informations sur les fichiers supplémentaires pour Windows Server 2008 R2 et Windows 7

Fichiers supplémentaires pour toutes les prises en charge x 86 exécutant des versions de Windows 7

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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Package_for_kb975688_rtm ~ 31bf3856ad364e35 ~ x 86 ~ ~ 6.1.1.0.mumNon applicable1,71416-Sep-200916 : 07Non applicable
X86_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_165a8cbb7652d18e.manifestNon applicable2,08316-Sep-200907 : 08Non applicable
Fichiers supplémentaires pour toutes les versions 64 de Windows Server 2008 R2 et de Windows 7 x

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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Amd64_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_7279283f2eb042c4.manifestNon applicable2,08716-Sep-200906 : 13Non applicable
Package_for_kb975688_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mumNon applicable1,72416-Sep-200916 : 07Non applicable
Fichiers supplémentaires pour toutes les prises en charge les versions Itanium de Windows Server 2008 R2

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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Ia64_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_165c30b17650da8a.manifestNon applicable2,08516-Sep-200906 : 16Non applicable
Package_for_kb975688_rtm ~ 31bf3856ad364e35 ~ ia64 ~ ~ 6.1.1.0.mumNon applicable1,44416-Sep-200916 : 07Non applicable

Références

Pour plus d'informations sur la durée de validité pour créer des clichés VSS instantanés, cliquez sur le numéro ci-dessous pour afficher la sixième étape dans la section «Shadow Copies création» dans le site Web Microsoft suivant :
http://technet.microsoft.com/en-us/library/cc785914(WS.10).aspx

Propriétés

Numéro d'article: 975688 - Dernière mise à jour: mercredi 4 novembre 2009 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Entreprise
  • Windows 7 Édition Familiale Basique
  • Windows 7 Édition Familiale Premium
  • Windows 7 Professionnel
  • Windows 7 Édition Starter
  • Windows 7 Édition Integrale
Mots-clés : 
kbmt kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB975688 KbMtfr
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La version anglaise de cet article est la suivante: 975688
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