Uno snapshot potrebbe venire danneggiato quando i provider di servizio Copia Shadow del volume (VSS) snapshot accettano pi¨ di 10 secondi per creare in un computer che esegue Windows Server 2008 R2 o Windows 7

Traduzione articoli Traduzione articoli
Identificativo articolo: 975688 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Servizio copia shadow del volume (VSS) non viene restituito un errore quando i provider snapshot accettano pi¨ di 10 secondi per creare uno snapshot in un computer che esegue Windows Server 2008 R2 o Windows 7. Di conseguenza, non si Ŕ a conoscenza di potenziale danneggiamento dei dati fino a quando si tenta di ripristinare un'istantanea creata.

Cause

Servizio copia shadow del volume (VSS) offre un provider di 10 secondi per bloccare le richieste di I/O e per creare uno snapshot. Quando viene creato uno snapshot o il timer giunge a 10 secondi, VSS rilascia i writer per riprendere le richieste di I/O. Se entro 10 secondi non viene creato uno snapshot, snapshot potrebbero essere danneggiati. Di conseguenza, VSS dovrebbe per restituire un errore quando viene raggiunto il limite di 10 secondi.

Tuttavia, VSS in Windows Server 2008 R2 e in Windows 7 non viene restituito l'errore VSS_E_HOLD_WRITES_TIMEOUT quando un provider di istantanee richiede pi¨ di 10 secondi per creare uno snapshot. Questo snapshot viene creato senza alcun errore restituito.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo aggiornamento rapido (hotfix) solo per i sistemi in cui si verificano il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se il problema non causa gravi difficoltÓ, si consiglia di attendere il successivo aggiornamento software contenente tale aggiornamento rapido (hotfix).

Se l'aggiornamento rapido (hotfix) Ŕ disponibile per il download, Ŕ disponibile una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se in questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se Ŕ richiesta la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del servizio supporto tecnico clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido (hotfix). Se non viene visualizzata la lingua desiderata, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), Ŕ necessario che il computer sia in esecuzione uno dei seguenti sistemi operativi:
  • Windows Server 2008 R2
  • Windows 7

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri aggiornamenti rapidi (hotfix).

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi del file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertita in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare scheda fuso orario nella Data e ora nel Pannello di controllo.
Nota le informazioni di file di Windows Server 2008 R2 e Windows 7

I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono listed separately. MUM e MANIFEST dei file e i file di catalogo (CAT) protezione associati sono fondamentali per mantenere lo stato del componente aggiornato. I file di catalogo della protezione (attributi non in elenco) sono firmati con una firma digitale Microsoft.
Per tutte le versioni x 86 versioni di Windows 7

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Volsnap.sys6.1.7600.20528245,33616-Set-200905: 28x 86
Volume.infNon applicabile1,94815-Set-200922: 59Non applicabile
Per tutte le versioni x 64 basati su versioni di Windows Server 2008 R2 e Windows 7

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Volsnap.sys6.1.7600.20528294,98416-Set-200905: 52x 64
Volume.infNon applicabile1.96815-Set-200922: 48Non applicabile
Per tutte le versioni basate su IA-64 di Windows Server 2008 R2

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Volsnap.sys6.1.7600.20528675,41616-Set-200904: 51IA-64
Volume.infNon applicabile1,95815-Set-200922: 46Non applicabile


Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows Server 2008 R2 e per Windows 7

File aggiuntivi per tutte le versioni x 86 versioni di Windows 7

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Package_for_kb975688_rtm ~ 31bf3856ad364e35 ~ x 86 ~ ~ 6.1.1.0.mumNon applicabile1,71416-Set-200916: 07Non applicabile
X86_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_165a8cbb7652d18e.manifestNon applicabile2,08316-Set-200908: 07Non applicabile
File aggiuntivi per tutte le versioni x 64 basati su versioni di Windows Server 2008 R2 e Windows 7

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Amd64_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_7279283f2eb042c4.manifestNon applicabile2,08716-Set-200906: 13Non applicabile
Package_for_kb975688_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mumNon applicabile1,72416-Set-200916: 07Non applicabile
File aggiuntivi per tutte le versioni basate su Itanium di Windows Server 2008 R2 supportati

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Ia64_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_165c30b17650da8a.manifestNon applicabile2.08516-Set-200916: 06Non applicabile
Package_for_kb975688_rtm ~ 31bf3856ad364e35 ~ ia64 ~ ~ 6.1.1.0.mumNon applicabile1,44416-Set-200916: 07Non applicabile

Riferimenti

Per ulteriori informazioni sul limite massimo di tempo per la creazione di copie shadow VSS, fare clic sul numero dell'articolo riportato di seguito per visualizzare il sesto passaggio nella sezione "Come Shadow Copies creare" nel seguente sito Web Microsoft:
http://technet.microsoft.com/en-us/library/cc785914(WS.10).aspx

ProprietÓ

Identificativo articolo: 975688 - Ultima modifica: mercoledý 4 novembre 2009 - Revisione: 2.1
Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Chiavi:á
kbmt kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB975688 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 975688
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com