El código de error 0x81000031 se produce al intentar realizar copias de seguridad de archivos mediante el Asistente para copia de seguridad y restauración en un equipo basado en Windows 7

En este artículo se describe un problema que se produce cuando se usa el Asistente para copia de seguridad y restauración en Windows 7 para realizar copias de seguridad de archivos en una unidad de disco duro externa.

Se aplica a: Windows 7 Service Pack 1
Número de KB original: 975692

Síntomas

Tenga en cuenta las situaciones siguientes.

Escenario 1: Las bibliotecas personalizadas no están disponibles

  • Tiene un equipo que ejecuta Windows 7.
  • Agregue una biblioteca personalizada que se encuentre en una unidad extraíble o en una unidad de red.
  • Intenta realizar una copia de seguridad cuando una o varias de las bibliotecas personalizadas no están disponibles.

En este escenario, al intentar realizar una copia de seguridad de los archivos mediante el Asistente para Copias de seguridad de Windows y restauración, recibirá un mensaje de error similar al siguiente:

Código de error: 0x81000031

Escenario 2: Cifrado de unidad bitlocker está habilitado

  • Tiene un equipo que ejecuta Windows 7.
  • Conecte una unidad de disco duro externa al equipo.
  • El cifrado de unidad bitlocker de Windows se habilita en la unidad del sistema.

En este escenario, al intentar realizar una copia de seguridad de los archivos en la unidad externa mediante el Copias de seguridad de Windows y el Asistente para restauración, recibirá un mensaje de error similar al siguiente:

El cifrado de unidad BitLocker no se puede usar porque faltan o están dañados archivos críticos del sistema de BitLocker.

Código de error: 0x81000031

Causa

Escenario 1: Las bibliotecas personalizadas no están disponibles

Este problema puede producirse si ha agregado bibliotecas personalizadas que no son accesibles al realizar una copia de seguridad mediante el Asistente para Copias de seguridad de Windows. Las bibliotecas personalizadas pueden dejar de estar disponibles si esas bibliotecas se encuentran en una unidad de red que no está disponible o si esas bibliotecas se encuentran en medios extraíbles.

Escenario 2: Cifrado de unidad bitlocker está habilitado

Este problema se produce porque el Asistente para BitLocker mueve el entorno de recuperación de Windows (Windows RE) de la unidad del sistema a la unidad de disco duro externo. Esto impide crear una copia de seguridad en el disco duro externo.

Solución alternativa

Para solucionar este problema, siga los pasos adecuados para su escenario.

Escenario 1: Las bibliotecas personalizadas no están disponibles

Para restablecer las bibliotecas a las bibliotecas predeterminadas (Documentos, Música, Imágenes y Vídeos), siga estos pasos:

  1. Haga clic en Inicio y, a continuación, en Equipo.

  2. Haga clic con el botón derecho en Bibliotecas en el panel de navegación del lado izquierdo de la ventana Explorador y, a continuación, haga clic en Restaurar bibliotecas predeterminadas.

    Nota:

    Esta operación quita las bibliotecas personalizadas que se encuentran en la ubicación de las bibliotecas. Puede restaurar estas bibliotecas cuando las ubicaciones de la biblioteca vuelvan a estar disponibles.

  3. Inicie el Asistente para copia de seguridad y restauración para hacer una copia de seguridad de los archivos y los datos.

Escenario 2: Cifrado de unidad bitlocker está habilitado

Para deshabilitar y volver a habilitar el cifrado de unidad de BitLocker, siga estos pasos:

  1. Conecte la unidad de disco duro externa al equipo. Asegúrese de que la unidad de disco duro externo está encendida.

  2. Cree un disco de reparación del sistema de Windows 7. Para ello, siga estos pasos:

    1. Haga clic en Inicio y, a continuación, escriba crear un disco de reparación del sistema en el cuadro Iniciar búsqueda .
    2. En la lista Programas , haga clic en Crear un disco de reparación del sistema.
    3. Siga las instrucciones de la pantalla para crear el disco.

    Nota:

    Debe tener un quemador de CD o DVD para crear un disco de reparación del sistema.

  3. Inicie un símbolo del sistema con privilegios elevados. Para ello, siga estos pasos:

    1. Haga clic en Inicio y, a continuación, escriba el símbolo del sistema en el cuadro Iniciar búsqueda .
    2. En la lista Programas , haga clic con el botón derecho en Símbolo del sistema y, a continuación, haga clic en Ejecutar como administrador.
  4. En el símbolo del sistema con privilegios elevados, escriba el siguiente comando y presione ENTRAR:

    C:\Windows\System32\REAgentC.exe /disable
    
  5. Desconecte la unidad de disco duro externa.

  6. En el símbolo del sistema con privilegios elevados, escriba el siguiente comando y presione ENTRAR:

    C:\Windows\System32\REAgentC.exe /enable
    

    Nota:

    Es posible que se produzca un error en esta operación. En este caso, use el disco de reparación del sistema de Windows 7 que creó en el paso 2 si tiene que tener acceso a las herramientas de recuperación.

  7. Vuelva a conectar la unidad de disco duro externo al equipo.

  8. Inicie el Asistente para copia de seguridad y restauración para hacer una copia de seguridad de los archivos y los datos en la unidad de disco duro externo.

Más información

Para obtener más información sobre cómo crear y usar un disco de reparación del sistema, visite el siguiente sitio web de Microsoft:

Creación de un disco de reparación del sistema

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".