Oprava: odchozí dávky vytváření selže, pokud jednotlivé zprávy obsahovat koncové oddělovače

Překlady článku Překlady článku
ID článku: 975761 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Zvažte následující scénář:
  • v aplikaci Microsoft BizTalk Accelerator HL 7 (BTAHL7) Explorer konfigurace, povolitPovolit koncové oddělovače (oddělovače)v části ověření na kartě obchodní stranou.
  • V případě vytvoření dávky jeden samostatný vstupní zprávy obsahuje koncové oddělovače.

    Poznámka:Vytvořit dávkové scénář je scénář při BTAHL7 spojuje samostatné vstupní zprávy do šarže výstupu. Další informace naleznete v části "Další informace".
v tomto případěPovolit koncové oddělovače (oddělovače)možnost není použita. Vytváření odchozí dávky proto nezdaří. Chybová zpráva je zaznamenána v protokolu událostí aplikace, která se podobá následující:

Typ události: Chyba
Zdroj události: BizTalk Accelerator pro HL7
ID události: 4133
Popis: Chyba během serializace chyby # 1 došlo v těle
ID segmentu: PID_PatientIdentification
Pořadové číslo:< Pořadové Číslo >
Pole číslo:< Číslo Pole >
Číslo chyby: 207
Popis chyby: Vnitřní chyba aplikace
Systém kódování: HL7nnnn
Alternativní číslo chyby: Z100
Alternativní popis chyby: konci oddělovač nalezen
Alternativní systém Encoding: HL7-BTA

Příčina

k tomuto problému dochází z důvodu chyby v BizTalk Accelerator pro verzi HL7 2.0.

Řešení

Informace o opravě hotfix

Pro BizTalk Server 2006 R2

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku.. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému..

v případě, že je oprava hotfix k dispozici ke stažení, je sekce "Oprava Hotfix k dispozici stahování" na začátku tohoto článku znalostní báze Knowledge Base. Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft..

Poznámka:-Li další dojít k potížím nebo je-li řešení potíží, je nutné, budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix.. Úplný seznam služby Microsoft a podporu telefonního čísla nebo chcete-li vytvořit zvláštní požadavek na službu, navštivte následující web společnosti Microsoft:-
http://support.microsoft.com/contactus/?ws=support
Poznámka:Ve formuláři "Oprava Hotfix k dispozici stahování" zobrazí jazyky, pro které je k dispozici je oprava hotfix. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk..

Požadavky

Je třeba Microsoft BizTalk Server 2006 R2 a Microsoft BizTalk Accelerator HL7 2.0 nainstalována, je možné použít tuto opravu hotfix.

Požadavek na restartování

Není nutné po instalaci této opravy hotfix restartovat počítač. Hostitelské instance BizTalk musíte restartovat však po instalaci této opravy hotfix. Další informace o tomto postupu, naleznete souboru Readme.txt. soubor, který je součástí balíčku opravy hotfix.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souborech

The Anglická verze této opravy hotfix má atributy souborů (nebo novější atributy souboru), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time).. Pokud zobrazíte informace o souboru, bude převedena na místní čas.. Rozdíl mezi místním časem a UTC časemČasové pásmokarty vDatum a časpoložky v Ovládacích panelech.
Microsoft BizTalk Server 2006 R2
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Microsoft.Solutions.btahl7.hl72fasm.dll2.0.314.059,25622. Září – 200923: 24x 86

Pro BizTalk Server 2006 R2 SP1

Opravy hotfix, která řeší tento problém je zahrnuta v balíčku kumulativní aktualizace 3 pro BizTalk Server 2006 R2 SP1.

Další informace o způsobu získání balíčku kumulativní aktualizace, klepněte na následující číslo článku databáze Microsoft Knowledge Base:

2286501Kumulativní balíček 3 pro BizTalk Server 2006 R2 Service Pack 1 aktualizace

Další informace o opravách hotfix pro BizTalk Server 2006 R2 SP1, klepněte na následující číslo článku databáze Microsoft Knowledge Base:

974563Seznam z Microsoft BizTalk Server hotfix opravuje, které jsou součástí aktualizace Service Pack 1 pro BizTalk Server 2006 R2

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Další informace o způsobu konfigurace nastavení ověření, navštivte následující web společnosti Microsoft Developer Network (MSDN):
http://msdn.microsoft.com/en-us/library/ee409406%28BTS.10%29.aspx
Další informace o vytvoření list scénář, navštivte následující web společnosti Microsoft Developer Network (MSDN):
http://msdn.microsoft.com/en-us/library/ee404911%28BTS.10%29.aspx

Vlastnosti

ID článku: 975761 - Poslední aktualizace: 31. srpna 2010 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Klíčová slova: 
kbautohotfix kbbtsaccelerators kbbiztalk2006r2sp1fix kbsurveynew kbqfe kbfix kbmt KB975761 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:975761

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com