Update: Batch erstellen ausgehender schlägt fehl, wenn einzelne Nachrichten nachgestellte Trennzeichen enthalten

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Problembeschreibung

Folgendes Szenario:
  • In Microsoft BizTalk Accelerator für HL-7 (BTAHL7) Configuration-Explorer können Sie dieNachgestellte Trennzeichen zu ermöglichen (Trennzeichen)Option auf der Registerkarte Überprüfung von Ihrem Handelspartner von Drittanbietern.
  • In einem Szenario mit Create-Stapel eine der separaten Eingabemeldungen enthält nachgestellte Trennzeichen.

    Hinweis:Erstellen Stapelverarbeitung Szenario ist ein Szenario, wenn BTAHL7 separate Eingabemeldungen in einer Ausgabe Batch kombiniert. Weitere Informationen finden Sie in den im Abschnitt "Weitere Informationen".
In diesem Szenario dieNachgestellte Trennzeichen zu ermöglichen (Trennzeichen)-Option wird nicht angewendet. Aus diesem Grund schlägt das ausgehende Batch erstellen. Außerdem wird eine Fehlermeldung protokolliert, im Anwendungsprotokoll der Ereignisanzeige protokolliert, die die folgenden ähnelt:

Ereignistyp: Fehler
Ereignisquelle: BizTalk Accelerator für HL7
Ereignis-ID: eid 4133
Beschreibung: Fehler ist während der Serialisierung Fehler # 1 im Textkörper passiert
Segment Id: PID_PatientIdentification
Sequenznummer:< Sequenznummer >
Feldnummer:< Feldnummer >
Fehlernummer: 207
Fehlerbeschreibung: Interner Fehler-Anwendung
System-Codierung: HL7nnnn
Alternative Fehlernummer: Z100
Alternative Fehlerbeschreibung: nachfolgende Trennzeichen gefunden
Alternative Encoding System: HL7 BTA
?

Ursache

Dieses Problem tritt aufgrund eines Fehlers in der BizTalk Accelerator für HL7 2.0 Version.

Lösung

Hotfix-Informationen

Für BizTalk Server 2006 R2

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur das Problem zu beheben, das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systeme an, bei die dieses spezielle Problem auftritt.

Ist der Hotfix zum Download zur Verfügung, ein Abschnitt "Hotfix Download verfügbar" am Anfang dieses Knowledge Base-Artikels hat. Wenn dieser Abschnitt nicht angezeigt wird, senden Sie eine Anfrage an den technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis:, Wenn weitere Probleme auftreten, oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen möchten, finden Sie auf folgender Website von Microsoft:-
http://support.Microsoft.com/contactus/?ws=Support
Hinweis:Zeigt das Formular "Hotfix Download verfügbar" die Sprachen, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen:

Sie benötigen Microsoft BizTalk Server 2006 R2 und Microsoft BizTalk Accelerator für HL7 2.0 installiert haben, um das Anwenden dieses Hotfixes.

Neustartanforderung

Sie keinen Neustart des Computers nach der Installation dieses Hotfixes. Allerdings müssen Sie die BizTalk-Hostinstanz starten, nachdem Sie diesen Hotfix anwenden. Weitere Informationen zu diesem Verfahren finden Sie in der Datei Readme.txt-Datei, die in dem Hotfix-Paket enthalten ist.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Updates besitzt die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgeführt. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln, verwenden dieMicrosoft Time ZoneRegisterkarte derDatum und UhrzeitElement in der Systemsteuerung.
Microsoft BizTalk Server 2006 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
Microsoft.Solutions.btahl7.hl72fasm.dll2.0.314.059,25622-Sep 200923: 24X 86

Für BizTalk Server 2006 R2 SP1

Der Hotfix, der dieses Problem behebt, die in kumulativen Updatepaket 3 enthalten ist für BizTalk Server 2006 R2 SP1.

Weitere Informationen dazu, wie Sie das kumulative Updatepaket zu erhalten, klicken Sie auf die folgende KB-Artikelnummer:

2286501Kumulative Updatepaket 3 für BizTalk Server 2006 R2 Service Pack 1

Finden Sie weitere Informationen zu BizTalk Server 2006 R2 SP1-Hotfixes, die folgende KB-Artikelnummer:

974563Liste von Microsoft BizTalk Server hot behebt in BizTalk Server 2006 R2 Service Pack 1 enthalten sind

Status

Microsoft hat bestätigt, dass es ein Problem bei den Microsoft-Produkten, die in der im Abschnitt "Beziehen sich auf" aufgelisteten handelt

Weitere Informationen

Weitere Informationen über das Konfigurieren von Einstellungen für die Gültigkeitsprüfung finden Sie auf folgender Website von Microsoft Developer Network (MSDN):
http://msdn.Microsoft.com/en-us/library/ee409406%28BTS.10%29.aspx
Weitere Informationen über das Erstellen Batch-Szenario finden Sie auf folgender Website von Microsoft Developer Network (MSDN):
http://msdn.Microsoft.com/en-us/library/ee404911%28BTS.10%29.aspx

Eigenschaften

Artikel-ID: 975761 - Geändert am: Dienstag, 31. August 2010 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2006 R2 Branch Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Keywords: 
kbautohotfix kbbtsaccelerators kbbiztalk2006r2sp1fix kbsurveynew kbqfe kbfix kbmt KB975761 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 975761
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