Código HTML que se encuentra en un campo en una plantilla de correo electrónico se muestra como texto sin formato en Microsoft Dynamics CRM 4.0

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Síntomas

Tiene una plantilla de correo electrónico que tiene código HTML que está contenida en un campo de plantilla en Microsoft Dynamics CRM 4.0. A continuación, cree un mensaje de correo electrónico que utiliza la plantilla de correo electrónico. Sin embargo, el código HTML que se encuentra en el campo plantilla se muestra inesperadamente como texto sin formato. Se espera que el código HTML con formato en lugar de texto sin formato del código HTML que se va a mostrar.

Causa

Este problema se produce porque la plantilla de correo electrónico intenta hacer seguro el código HTML cuando la plantilla de correo electrónico detecta cualquier formato de HTML. Este comportamiento impide que código HTML de sistemas no fiables o código de secuencias de comandos que se ejecutará en el formulario de correo electrónico de CRM.

Solución

Este problema se corrigió en el paquete de continuación de la actualización acumulativa más reciente para Microsoft Dynamics CRM 4.0.Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
949256Revisiones y actualizaciones de Microsoft Dynamics CRM 4.0


Después de instalar el paquete acumulativo de actualizaciones más reciente para Microsoft Dynamics CRM 4.0, tendrá que agregar la clave del registro de EmailTemplateBodyHTMLNoEncode. Para ello, siga estos pasos:
Importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de seguir estos pasos cuidadosamente. Para conseguir una protección adicional, haga una copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, presione ENTRAR.
  2. En el Editor del registro, busque la siguiente subclave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Haga clic con el botón secundario del mouse en MSCRM, elija nuevo, haga clic en Valor DWORD y, a continuación, escriba EmailTemplateBodyHTMLNoEncode.
  4. Haga doble clic en EmailTemplateBodyHTMLNoEncode y, a continuación, escriba 1 en el campo de datos de valor.

    NotaCuando la entrada de registro EmailTemplateBodyHTMLNoEncode se establece en 1, Microsoft Dynamics CRM descodifica el código HTML en el cuerpo de la plantilla y, a continuación, se muestra el código HTML con formato. Sin embargo, si la entrada de registro EmailTemplateBodyHTMLNoEncode está configurada para ser 0 o no hay ninguna entrada de registro EmailTemplateBodyHTMLNoEncode, no se codifica el cuerpo de la plantilla de correo electrónico. Por lo tanto, el código HTML se muestra inesperadamente como texto sin formato.
  5. Haga clic en Aceptar.

Propiedades

Id. de artículo: 975770 - Última revisión: jueves, 11 de febrero de 2010 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Dynamics CRM 4.0
Palabras clave: 
kbmt kbqfe kbfix kbsurveynew kbmbsmigrate kbexpertiseinter KB975770 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 975770

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