HTML que está inserido um campo num modelo de correio electrónico é apresentado como texto simples no Microsoft Dynamics CRM 4.0

Traduções de Artigos Traduções de Artigos
Artigo: 975770 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Tem um modelo de correio electrónico com o código HTML que é inserido num campo de modelo no Microsoft Dynamics CRM 4.0. Em seguida, crie uma mensagem de correio electrónico que utiliza o modelo de correio electrónico. No entanto, o código HTML que está contido no campo modelo é apresentado inesperadamente como texto simples. Pensa que o código HTML formatado em vez do texto simples do código HTML a ser apresentado.

Causa

Este problema ocorre porque o modelo de correio electrónico tenta efectuar o código HTML seguro quando o modelo de correio electrónico detecta qualquer formatação HTML. Este comportamento impede que o código HTML não controlados ou código de script a ser executado sob a forma de correio electrónico do CRM.

Resolução

Este problema é corrigido no conjunto de actualizações cumulativas mais recente para o Microsoft Dynamics CRM 4.0.Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
949256O Microsoft Dynamics CRM 4.0 actualizações e correcções


Depois de instalar o update rollup mais recente do Microsoft Dynamics CRM 4.0, tem de adicionar a chave de registo EmailTemplateBodyHTMLNoEncode. Para tal, siga estes passos:
Importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo incorrectamente. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Clique em Iniciar, clique em Executar, escreva regedit e, em seguida, prima ENTER.
  2. No Editor de registo, localize a seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Clique com o botão direito do rato MSCRM, aponte para Novo, clique em Valor DWORD e, em seguida, escreva EmailTemplateBodyHTMLNoEncode.
  4. Faça duplo clique EmailTemplateBodyHTMLNoEncode e, em seguida, escreva 1 no campo dados do valor.

    NotaQuando a entrada de registo EmailTemplateBodyHTMLNoEncode está definida como 1, do Microsoft Dynamics CRM descodifica o código HTML no corpo do modelo e, em seguida, é apresentado o código HTML formatado. No entanto, se a entrada de registo EmailTemplateBodyHTMLNoEncode está configurada para ser 0 ou não existe qualquer entrada de registo EmailTemplateBodyHTMLNoEncode, o corpo do modelo de correio electrónico não está codificado. Por conseguinte, o código HTML é apresentado inesperadamente como texto simples.
  5. Clique em OK.

Propriedades

Artigo: 975770 - Última revisão: 11 de fevereiro de 2010 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmt kbqfe kbfix kbsurveynew kbmbsmigrate kbexpertiseinter KB975770 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 975770

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com