O HTML contido em um campo em um modelo de email é exibido como texto sem formatação no Microsoft Dynamics CRM 4.0

Traduções deste artigo Traduções deste artigo
ID do artigo: 975770 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Você ter um modelo de email que tem o código HTML contido em um campo de modelo no Microsoft Dynamics CRM 4.0. Em seguida, você cria uma mensagem de email que usa o modelo de email. No entanto, o código HTML contido no campo modelo é exibido inesperadamente como texto sem formatação. Você espera que o código HTML formatado em vez do texto sem formatação do código HTML a ser exibido.

Causa

Esse problema ocorre porque o modelo de email tenta tornar o código HTML seguro quando o modelo de email detecta qualquer formatação HTML. Esse comportamento impede que código HTML não autorizado ou código de script que está sendo executado em um formulário de email do CRM.

Resolução

Esse problema é corrigido no pacote cumulativo de atualizações cumulativas mais recente do Microsoft Dynamics CRM 4.0.Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
949256Hotfixes e atualizações do Microsoft Dynamics CRM 4.0


Depois de instalar o pacote cumulativo de atualizações mais recente do Microsoft Dynamics CRM 4.0, você precisará adicionar a chave de registro EmailTemplateBodyHTMLNoEncode. Para fazer isso, execute as seguintes etapas:
Importante Nesta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir estas etapas cuidadosamente. Para obter mais proteção, faça backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows
  1. Clique em Iniciar, clique em Executar, digite regedit e pressione ENTER.
  2. No Editor do registro, localize a seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Clique com o botão direito do mouse em MSCRM, aponte para novo, clique em Valor DWORD e digite EmailTemplateBodyHTMLNoEncode.
  4. Clique duas vezes em EmailTemplateBodyHTMLNoEncode e, em seguida, digite 1 no campo de dados do valor.

    Observação:Quando a entrada de registro EmailTemplateBodyHTMLNoEncode é definida como 1, Microsoft Dynamics CRM decodifica o código HTML no corpo do modelo e, em seguida, o código HTML formatado é exibido. No entanto, se a entrada de registro EmailTemplateBodyHTMLNoEncode está configurada para ser 0 ou não há nenhuma entrada de registro EmailTemplateBodyHTMLNoEncode, corpo do modelo de email não está codificado. Portanto, o código HTML é inesperadamente exibido como texto sem formatação.
  5. Clique em OK.

Propriedades

ID do artigo: 975770 - Última revisão: quinta-feira, 11 de fevereiro de 2010 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 4.0
Palavras-chave: 
kbmt kbqfe kbfix kbsurveynew kbmbsmigrate kbexpertiseinter KB975770 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 975770

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com