Article ID: 975849 - Last Review: October 7, 2011 - Revision: 2.0

Memory usage increases for a .NET Framework 2.0-based application when you use the ImageList.ImageCollection.Item property to obtain an image or when you call the ImageList.ImageCollection.GetEnumerator method

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SYMPTOMS

Consider the following scenario:
  • You have an application that is based in the Microsoft .NET Framework 2.0.
  • You use the ImageList.ImageCollection.Item property to obtain an image. Or, you call the ImageList.ImageCollection.GetEnumerator method in the application.
  • You run the application.
In this scenario, memory usage increases for the application. Additionally, when the call loops many times in the application, you may receive a System.OutOfMemoryException exception.

CAUSE

This problem occurs because a method that is inside the call generates an intermediate bitmap object from full native Imagelist objects. However, the method does not call the Dispose method to release the resource.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have the .NET Framework 2.0 Service Pack (SP2) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix if no instance of the .NET Framework is being used.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Vista SP2 and of Windows Server 2008 SP2
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File nameFile versionFile sizeDateTime
System.windows.forms.dll2.0.50727.44205,025,79210-Nov-200910:30

For all supported x64-based versions of Windows Vista SP2 and of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
System.windows.forms.dll2.0.50727.44205,025,79210-Nov-200910:31

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft .NET Framework 2.0
  • Microsoft .NET Framework 2.0 Service Pack 1 (x86)
  • Microsoft .NET Framework 2.0 Service Pack 2
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