ID do artigo: 975891 - Última revisão: quarta-feira, 17 de agosto de 2011 - Revisão: 1.0

Soluções de impressoras de Multifunções HP e HP completa de recurso de Software ou Driver básico da HP não funcionam como esperado após um computador atualizações do Windows Vista para o Windows 7

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Para impressoras locais

Atualização do Windows Vista para o Windows 7 em um computador que tem a solução completa de Software de recurso da HP ou o Driver básico da HP instalado. Em seguida, você percebe que sua impressora HP de multifuncionais (MFP) não funciona conforme o esperado. Em particular, os botões físicos no painel frontal da impressora de múltiplas funções parar de responder. O dispositivo é reconhecido corretamente e é exibido como instalado. Entretanto, o software da HP não é iniciado e não relata que não pode se conectar ao dispositivo. Portanto, você não conseguir imprimir, digitalizar ou copiar.

Observação Se a solução de HP completa de recurso de Software ou Driver básico da HP não está instalado antes que as atualizações de computador para o Windows 7, impressão e digitalização funcionalidade básica devem estar presentes. Para obter a funcionalidade avançada de seu MFP, os usuários podem instalar a solução de HP completa de recurso de Software ou Driver básico da HP após atualizações de computador para o Windows 7.

Em computadores baseados no Windows 7 de 64 bits, o HP Digital Imaging monitor não é possível iniciar e o ícone não aparecer na área de notificação. Além disso, quando você tenta iniciar o Centro de soluções da HP, você receber a seguinte mensagem de erro:
Centro de solução não pode ser iniciado.

Nenhum dispositivo encontrado

Para corrigir esses problemas, aplique a atualização descrita neste artigo.

Para impressoras em rede

Impressoras de rede e impressoras compartilhadas os problemas descritos para impressoras locais. Os problemas ocorrem quando você conecta impressoras em um computador local que possui o Centro de soluções da HP instalado e, em seguida, atualizar o computador para o Windows 7.
  • Se o MFP HP fisicamente conectado ao e compartilhado de um computador que não está executando o Windows 7 e outros computadores estão conectados à impressora, somente o Windows 7 computadores atualizar do Vista e que tem a solução de HP completa de recurso de Software ou Driver básico da HP instalado antes de atualizar para o Windows 7 são afetados.
  • Se o MFP HP está fisicamente conectado ao e compartilhado de um computador do Windows 7 que atualizações do Windows Vista e que tem a solução de HP completa de recurso de Software ou Driver básico da HP instalado antes de atualizar para o Windows 7, todos os computadores que estão conectados à impressora compartilhada são afetados.
Impressoras de rede podem enfrentar os seguintes sintomas adicionais:
  • Funciona de impressão a partir de aplicativos, mas nenhuma funcionalidade do Centro de soluções da HP (por exemplo, verificando o status de tinta) pode se comunicar com a impressora.
  • Varredura não funciona porque ele usa os serviços da HP especiais para a digitalização.
Para corrigir esses problemas, aplique a atualização descrita neste artigo. Além disso, faça o download e instalar o software do dispositivo HP apropriado para o Windows 7 do http://www.Home da HP.com (http://www.HP.com) .

Causa

Esse problema ocorre porque necessário bibliotecas não são migradas do Windows Vista para o Windows 7. Sem as bibliotecas necessárias, o software não pode se comunicar com o dispositivo multifuncional. Tentativas de desinstalar ou reinstalar o software HP não resolverem o problema.

Resolução

Windows Update

Uma atualização está disponível no site Windows Update na Web. Esta atualização substitui alguns arquivos ausentes e os registros no computador do usuário para corrigir um cenário de impressora quebrado para HP. Para obter a atualização, execute estas etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    Iniciar btton
    , clique em Painel de controlee então clique em Sistema e segurança.
  2. Em Windows Update, clique em Verificar se há atualizações.

Observação Durante a instalação, a atualização não cria uma entrada de Atualizações instaladas seção. Isso serve para evitar desinstala não intencionais.

Importante Esta é um versão somente de atualização da Microsoft do Windows. O autônomo é disponível na HP.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Desinstalar a atualização.

Para desinstalar a atualização, você precisa executar um comando de desinstalação no prompt de comando. Para desinstalar a atualização, siga estas etapas:
Observação Esta atualização de desinstalação ou a restauração do sistema para uma data anterior reverte para o problema descrito na seção "Sintomas". Para resolver o problema, a atualização deve ser reinstalado.
  1. Inicie um prompt de comando elevado. Para fazer isso, siga estas etapas:
    1. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
      Iniciar btton
      , tipo cmd no Iniciar pesquisa caixa, o botão direito do mouse cmd. exe no Programas e, em seguida, clique Executar como administrador.
      Observação Se você for solicitado uma senha de administrador ou confirmação, digite a senha ou forneça a confirmação.
  2. Digite o comando associado ao seu sistema operacional e pressione ENTER.
    • Para sistemas de operacionais do Windows de 32 bits, digite o seguinte e pressione ENTER:
      msiexec /Uninstall {859D40CF-8491-44AD-8FA8-7389CB418C64}
    • Para sistemas de operacionais do Windows de 64 bits, digite o seguinte e pressione ENTER:
      msiexec /Uninstall {9301985B-D116-4A93-A93D-94580084FF86}
  3. Quando a desinstalação estiver concluída, saia do prompt de comando.
Observação Para ver se o seu computador está executando uma versão de 32 bits ou 64 bits do Windows, siga estas etapas:
  1. Clique em Iniciar
    Recolher esta imagemExpandir esta imagem
    Iniciar btton
    , clique em Painel de controlee então clique em Sistema e segurança.
  2. Em Sistema, você pode exibir o tipo de sistema.

AINDA PRECISA DE AJUDA?

Se este artigo não responder sua pergunta, clique neste botão para fazer sua pergunta para outros membros da comunidade em respostas da Microsoft:

Fazer uma pergunta



Se você gostaria de ver respostas para questões relacionadas, clique nos seguintes links para exibir os tópicos no Fórum de respostas da Microsoft:
As informações e a solução contidas neste documento representa o modo de exibição atual da Microsoft Corporation desses problemas como a data da publicação. Esta solução está disponível através da Microsoft ou por meio de um provedor de terceiros. A Microsoft não recomenda especificamente qualquer provedor de terceiros ou a solução de terceiros que possam ser descritos neste artigo. Também pode haver outros provedores de terceiros ou soluções de terceiros que não descritos neste artigo. Como a Microsoft deve responder às mudanças nas condições do mercado, essas informações não devem ser interpretadas como um compromisso pela Microsoft. A Microsoft não garante ou endossa a precisão de qualquer informação ou solução apresentada pela Microsoft ou por qualquer fornecedor de terceiros mencionado.

A Microsoft não oferece garantias e exclui todas as representações, garantias e condições expressas, implícitas ou ESTATUTÁRIAS. Esses incluem, mas não estão limitados a representações, garantias ou condições de título, não infração, condições satisfatórias, comercialização e adequação a uma finalidade específica, com relação a qualquer serviço, solução, produto, ou outros materiais ou informações. Em nenhuma hipótese Microsoft serão responsabilizado por qualquer solução de terceiros mencionadas neste artigo.

A informação contida neste artigo aplica-se a:
  • Windows 7 Service Pack 1
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Palavras-chave: 
kbgraphxlink kbexpertiseinter atdownload kbtshoot kbsurveynew kbprb kbmt KB975891 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 975891  (http://support.microsoft.com/kb/975891/en-us/ )