No se puede realizar ciertas operaciones relacionadas con los discos después de una excepción cuando un proveedor de hardware intenta crear una instantánea en Windows Server 2008 R2 o en Windows 7

Seleccione idioma Seleccione idioma
Id. de artículo: 975921 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:

  • Crear un volumen que abarque uno o más discos en un equipo que ejecuta Windows Server 2008 R2 o Windows 7.
  • Un proveedor de hardware intenta crear una instantánea del volumen. Sin embargo, se produce una excepción y la acción no se realiza correctamente.
En este escenario, no se puede realizar ciertas operaciones relacionadas con los discos. Estas operaciones pueden incluir la siguiente:
  • Se hacer una copia de seguridad uno de estos discos utilizando una aplicación de copia de seguridad, como System Center fecha Protection Manager (DPM).
  • Uno de estos discos se utiliza como un disco compartido en un clúster de conmutación por error de Windows. Sin embargo, no es posible poner el disco compartido en línea.
  • Ejecutar una aplicación que llama a la función de devolución de llamada ResourceControl junto con el código de control de recurso CLUSCTL_RESOURCE_STORAGE_GET_DISK_INFO_EX contra estos discos. Sin embargo, la aplicación devuelve código de error 1168.

Causa

Como se va a crear la instantánea de un volumen, Volume Shadow Copy Service (VSS) establece los discos que están cubiertos por el volumen a un estado especial. Una vez finalizada la instantánea, VSS re establece los discos en el estado correcto. Si se produce una excepción cuando un proveedor de hardware crea una instantánea de un volumen, VSS no restablece nunca los discos al estado correcto.

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, el equipo debe estar ejecutando uno de los siguientes sistemas operativos:
  • Windows Server 2008 R2
  • Windows 7

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.Debe detener el servicio de instantáneas de volumen antes de instalar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y hora local, utilice la zona horaria de ficha en la fecha y hora elemento del panel de control.
Nota de información de archivo de Windows Server 2008 R2 y Windows 7
Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instalan para cada entorno están listed separately. MUM y MANIFEST archivos y los archivos de catálogo (.cat) seguridad asociados, son críticos para mantener el estado del componente actualizado. Los archivos del catálogo de seguridad (atributos no enumerados) están firmados con una firma digital de Microsoft.
Para todas versiones de 86 de Windows Server 2008 R2 y Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Vssvc.exe6.1.7600.205321,025,53622-Sep-200905: 57x 86
Para todas versiones de 64 de Windows Server 2008 R2 y Windows7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Vssvc.exe6.1.7600.205321,599,48822-Sep-200906: 22x 64
Para todas las versiones basadas en Itanium de Windows Server 2008 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Vssvc.exe6.1.7600.205322,168,83222-Sep-200905: 01IA-64


Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Additional file information for Windows Server 2008 R2 and for Windows 7

Archivos adicionales para todas versiones de 86 de Windows Server 2008 R2 y Windows 7 x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Package_for_kb975921_rtm ~ 31bf3856ad364e35 ~ x 86 ~ ~ 6.1.1.0.mumNo aplicable1,89123-Sep-200931: 00No aplicable
Ventanas de X86_microsoft de vssservice_31bf3856ad364e35_6.1.7600.20532_none_5b5fd2099222ce6f.manifestNo aplicable18,23522-Sep-200906: 22No aplicable
Archivos adicionales para todas versiones de 64 de Windows Server 2008 R2 y Windows 7 x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Ventanas de Amd64_microsoft de vssservice_31bf3856ad364e35_6.1.7600.20532_none_b77e6d8d4a803fa5.manifestNo aplicable18,24122-Sep-200906: 59No aplicable
Package_for_kb975921_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mumNo aplicable2,12523-Sep-200931: 00No aplicable
Archivos adicionales para todos los compatibles las versiones basadas en Itanium de Windows Server 2008 R2

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Ventanas de Ia64_microsoft de vssservice_31bf3856ad364e35_6.1.7600.20532_none_5b6175ff9220d76b.manifestNo aplicable18,23822-Sep-200906: 49No aplicable
Package_for_kb975921_rtm ~ 31bf3856ad364e35 ~ ia64 ~ ~ 6.1.1.0.mumNo aplicable1,68323-Sep-200931: 00No aplicable

Referencias

Para obtener más información acerca de la función ResourceControl, haga clic en el siguiente artículo en el sitio Web de Microsoft:
http://msdn.microsoft.com/en-us/library/aa372150(VS.85).aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
975832Es posible que no pueda realizar determinadas operaciones relacionadas en disco después de un proveedor de hardware no puede crear instantáneas en Windows Server 2008 o en Windows Vista

Propiedades

Id. de artículo: 975921 - Última revisión: miércoles, 04 de noviembre de 2009 - Versión: 1.2
La información de este artículo se refiere a:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Palabras clave: 
kbmt kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB975921 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 975921

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com