FIX: Special characters are not written into the output document after they are processed by a send pipeline that uses the Flat File Assembler in BizTalk Server 2009

Article translations Article translations
Article ID: 976074 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario in Microsoft BizTalk Server 2009:
  • You create a custom send pipeline component that uses the Flat File Assembler component that is provided with BizTalk Server.
  • In an orchestration, you specify the character encoding of outgoing messages by setting the XMLNorm.TargetCharSet property in the message context.
  • You specify a character encoding that incorporates special characters. For example, you specify Windows-1252.
  • You create a send port that uses the custom send pipeline for the orchestration.
  • You receive an incoming message that contains special characters.
In this scenario, you may find that the special characters are written incorrectly into the output document. For example, you may find that "ó" or "á" in the incoming message is written as "?" in the output document.

CAUSE

This problem occurs because the character encoding set in the XMLNORM.TargetCharSet property on the message context is not applied correctly in the Flat File Assembler.

RESOLUTION

After you apply this hotfix, the character encoding that you set in the XMLNORM.TargetCharSet property in the message context will be applied correctly in the Flat File Assembler.

Cumulative updated information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2429050 Cumulative update package 1 for BizTalk Server 2009

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Server 2009 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk host instance service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.pipeline.components.dll3.8.412.2292,75227-Oct-200917:48x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the Flat File Assembler pipeline component, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/aa559695%28BTS.10%29.aspx
For more information about the different levels of character encoding in the Flat File Assembler Pipeline component, visit the following MSDN Web site:
http://msdn.microsoft.com/en-us/library/ee267840(BTS.10).aspx

For more informationabout the BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907Information on BizTalk Server hot fixes


Properties

Article ID: 976074 - Last Review: December 8, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbbtspipeline kbbiztalk2009presp1fix kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe KB976074

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com