文書番号: 976162 - 最終更新日: 2010年3月30日 - リビジョン: 2.0

Outlook 2007、Outlook 2003 および Outlook Express 6 で、特定の設定がされた HTML 形式のメールを受信すると文字化けが発生する場合がある

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。

目次

すべて展開する | すべて折りたたむ

現象

Microsoft Office Outlook 2007、Microsoft Office Outlook 2003 および Microsoft Outlook Express 6 で、特定の条件の HTML 形式のメールを受信すると文字化けが発生する場合があります。

文字化けが発生する特定の条件
受信したメッセージの charset が、テキスト パート (text/plain) と HTML パート (text/html) で別のエンコードが指定されている場合に文字化けが発生する場合があります。たとえば、テキスト パートで charset=iso-2022-jp、HTML パートで charset=utf-8 が設定されている場合にこの現象が発生します。

なお、Outlook 2007、Outlook 2003 および Outlook Express 6 では、特定の条件のような設定をするメッセージを作成することはできません。

原因

この現象は、Outlook 2007、Outlook 2003 および Outlook Express 6 が、MIME (Multipurpose Internet Mail Extension) の multipart/alternative 形式 のメッセージでパートごとに別の charset が指定されることを想定していないために発生します。

Outlook 2007、Outlook 2003 および Outlook Express 6 では、メッセージ全体のコード ページとして、MIME の multipart/alternative 形式の先頭のパートで指定されている charset を使用します。その結果、先頭のパートがテキスト パートであり、テキスト パートと HTML パートの charset が異なり、かつ HTML パートをテキスト パートの charset で正しく表示することができない場合に文字化けが発生します。

回避策

Outlook 2007 でこの問題を回避するには、以下の修正プログラム パッケージをインストールしてください。
978401? (http://support.microsoft.com/kb/978401/JA/ ) Office Outlook 2007 修正プログラム パッケージ (Outlook x none.msp): 2010 2 月 23日
Outlook 2007、Outlook 2003 および Outlook Express 6 で文字化けしたメールを受信した場合は、以下の手順を実行して正しい文字が表示されるように適切なエンコードに変更してください。

Outlook 2007 の場合 :

  1. 文字化けしたメッセージの [メッセージ] タブをクリックします。
  2. [その他のアクション] をクリックして、[エンコード] をポイントし、文字化けしている文字が正しく表示される適切なエンコードを指定します。(たとえば、[Unicode (UTF-8)] をクリックします。)

Outlook 2003 および Outlook Express 6 の場合 :

  1. 文字化けしたメッセージの [表示] メニューをクリックします。
  2. [エンコード] をポイントし、文字化けしている文字が正しく表示される適切なエンコードを指定します。(たとえば、[日本語 (EUC)] をクリックします。)

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

Outlook 2007 および Outlook 2003 では、以下の設定をしている場合でも、HTML パートをテキストに変換して表示するため、この現象が発生します。

Outlook 2007 の場合 :
[ツール] メニュー の [セキュリティ センター] をクリックして、[電子メールのセキュリティ] をクリックし、[テキスト形式で表示] 項目の [すべての標準メールをテキスト形式で表示する] チェック ボックスがオンに設定されている。

Outlook 2003 の場合 :
[ツール] メニュー の [オプション] をクリックして、[メール オプション] ボタンをクリックし、[メッセージの取り扱い] 項目の [すべての標準メールをテキスト形式で表示する] チェック ボックスがオンに設定されている。

また、Outlook Express 6 の場合は、[ツール] メニュー の [オプション] をクリックして、[読み取り] タブをクリックし、[メッセージはすべてテキスト形式で読み取る] チェック ボックスがオンに設定されている場合には、この現象が発生しません。

この資料は以下の製品について記述したものです。
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
  • Microsoft Outlook Express 6.0
キーワード:?
kbexpertisebeginner kbexpertiseinter kbtshoot kbbug kbharmony KB976162
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"