Riceverai un messaggio di errore contenente il codice di errore evento 11, quando si tenta di aggiornare un computer basato su Windows Vista utilizzando Windows Update o Microsoft Update

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importante In questo articolo contiene informazioni che viene illustrato come per le impostazioni di protezione inferiore o su come disattivare la funzionalitÓ di protezione in un computer. ╚ possibile apportare queste modifiche per risolvere un problema specifico. Prima di apportare queste modifiche, si consiglia di valutare i rischi associati all'implementazione questa soluzione alternativa in un ambiente particolare. Se si implementa questa soluzione, adottare ogni ulteriore procedura per proteggere il computer.
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Sintomi

Quando si tenta di aggiornare un computer basato su Windows Vista utilizzando Windows Update o Microsoft Update, viene visualizzato il seguente messaggio di errore:
Nome di accesso: applicazione
Origine: Microsoft-Windows-CAPI2
Date: date time
ID evento: 11
Categoria di attivitÓ: nessuno
Livello: errore
Parole chiave: classico
Utente: N/d
Computer: computer_name
Descrizione: Impossibile estrarre l'elenco principale terze parti di dal file .cab di aggiornamento automatico in: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> con errore: un certificato richiesto non rientra nel periodo di validitÓ se verificato rispetto all'ora corrente del sistema o al timestamp sul file firmato.
Inoltre, potresti ricevere il messaggio di errore ogni volta che si riavvia il computer.

Cause

Questo problema pu˛ verificarsi per uno dei seguenti motivi.

Causa 1

Questo problema potrebbe essere causato da conflitti con programmi di protezione antivirus e altri. Questo errore pu˛ verificarsi ogni volta che il computer viene avviato. Per aggirare il problema, vedere il Method 1 nella sezione "Workaround".

Causa 2

Questo problema pu˛ verificarsi se il connesso account utente non dispone autorizzazioni sufficienti scrivere la cartella temporanea (Temp). Per risolvere questo problema, vedere il Method 2 nella sezione "Workaround".

Workaround

Per risolvere questo problema, risolvere il problema provando il metodo appropriato per il particolare scenario. Se dubbio dello scenario, provare Method 1. Se non viene risolto il problema, provare il Method 2.

Metodo 1

Per risolvere questo problema, Ŕ necessario identificare al programma o servizio che causa il messaggio di errore. ╚ necessario attivare la registrazione operativi CAPI2 e riavviare il computer per raccogliere i registri eventi necessari. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic su Start , digitare il Visualizzatore eventi nella casella Inizia ricerca e quindi fare clic su Visualizzatore eventi in programmi .

    Riduci l'immagineEspandi l'immagine
    User Account Control permission
    Se viene chiesto di immettere una password di amministratore o di confermare, digitare la password o confermare.
  2. Espandere registri applicazioni e servizi .
  3. Espandere Microsoft .
  4. Espandere Windows .
  5. Espandere CAPI2 e quindi fare clic su operativo . Apre il registro CAPI2 operativo.
  6. Nel riquadro attivitÓ Azioni , fare clic su Attiva registro .
  7. Riavviare il computer.
  8. Aprire il registro CAPI2 operativi. Per effettuare questa operazione, ripetere i passaggi da 1 a 5.
  9. Cercare nell'elenco eventi in operativo , un ID evento 11 ha un livello di errore . Fare clic su ogni istanza che si trova e quindi esaminare la descrizione del programma che causa il messaggio di errore all'evento.
Uno o pi¨ gli eventi registrati potrebbe indicare il programma che causa il messaggio di errore. Il seguente antivirus e il programmi firewall sono noti per questo messaggio di errore:
  • McAfee
  • Vsmon.exe
  • MEDIA
  • TrendMicro
  • Avviso di zona
  • Altri prodotti antivirus e protezione
note
  • Un programma antivirus Ŕ progettato per proteggere il computer dai virus. Non occorre scaricare o aprire file da origini non affidabili, visitare siti Web non attendibili oppure di aprire gli allegati di posta elettronica quando il programma antivirus Ŕ disattivato. Per ulteriori informazioni sui virus, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
    129972Virus informatici: descrizione, prevenzione e ripristino
  • Un firewall Ŕ progettato per proteggere il computer da attacchi di utenti malintenzionati o programmi software dannosi, quali i virus che utilizzano il traffico di rete in ingresso non richiesto per attaccare il computer. Prima di disattivare il firewall, Ŕ necessario disconnettere il computer da tutte le reti, inclusa Internet.
avviso Questa soluzione alternativa potrebbe rendere un computer o una rete pi¨ vulnerabile agli attacchi di utenti malintenzionati o da software dannoso, ad esempio virus. Si sconsiglia di questa soluzione tuttavia queste informazioni vengono fornite in modo che Ŕ possibile implementare questa soluzione alternativa a propria discrezione. Utilizzare questa soluzione alternativa a proprio rischio.

Per determinare se uno di questi programmi o un altro programma menzionato nell'evento Descrizione errore log causa il problema, Ŕ possibile verificare il programma da disattivare temporaneamente o disinstallare temporaneamente il programma e quindi riavviare il computer. Quindi, eseguire una ricerca il registro operativo CAPI2 per un'istanza di ID evento 11 con un livello di errore se il messaggio di errore si verifica ancora.

importante Se si desidera disinstallare il programma, Ŕ necessario assicurarsi di disporre dell'accesso per il supporto di installazione e qualsiasi numero di serie Ŕ necessario per reinstallare il programma dopo il completamento dei test.

Se temporaneamente la disattivazione o disinstallazione temporaneamente il programma consente di risolvere il problema, contattare il produttore di programmi per un aggiornamento, un aggiornamento rapido (hotfix) o altre informazioni.

Metodo 2

L'aggiornamento automatico certificati principali Scarica un file CAB per la cartella Temp del computer locale, estrae il contenuto del file e quindi aggiorna l'elenco di certificati principale. Le autorizzazioni appropriate devono essere applicati alla cartella Temp per il file CAB Ŕ stato installato correttamente.

Per verificare le autorizzazioni per la cartella Temp, attenersi alla seguente procedura:
  1. Fare clic su Start , digitare %userprofile%\AppData\Local nella casella Inizia ricerca e quindi fare clic su locale nell'elenco.
  2. Fare clic con il pulsante destro del mouse sulla cartella TEMP nell'elenco delle cartelle e quindi fare clic su ProprietÓ .
  3. Fare clic sulla scheda protezione .
  4. Selezionare l'account utente nell'elenco utenti e gruppi utilizzata per accedere al computer e assicurarsi che l'account utente disponga di autorizzazioni Full Control .
Nota Se l'account utente che si Ŕ utilizzato per accedere al computer non dispone di autorizzazioni Full Control, attenersi alla seguente procedura:
  1. Fare clic su Modifica .
  2. Selezionare l'account utente utilizzato per accedere al computer nell'elenco di utenti e gruppi e fare clic quindi per selezionare la casella di controllo controllo sotto Consenti .
  3. Fare clic su Applica e quindi fare clic su OK due volte.

Riferimenti

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ProprietÓ

Identificativo articolo: 976235 - Ultima modifica: martedý 6 ottobre 2009 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Business N
  • Windows Vista Business N 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Basic N
  • Windows Vista Home Basic N 64-bit Edition
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Chiavi:á
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