Windows Update 또는 Microsoft Update를 사용하여 Windows Vista 기반 컴퓨터를 업데이트하려고 하면 이벤트 ID 11 오류 코드가 포함된 오류 메시지가 나타난다

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현상

Windows Update 또는 Microsoft Update를 사용하여 Windows Vista 기반 컴퓨터를 업데이트하려고 하면 다음 오류 메시지가 나타날 수 있습니다.
로그 이름: 응용 프로그램
원본: Microsoft Windows CAPI2
Date: date time
이벤트 ID: 11
작업 범주: 없음
수준: 오류
키워드: 일반
사용자: N/A
컴퓨터: computer_name
제 3 루트 목록 추출 시 자동 업데이트 CAB에서 설명: 실패: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> 오류: 한 필요한 인증서가 유효 기간 내에 없는 현재 시스템 시계를 또는 서명된 파일의 타임스탬프와 비교하여 확인할 때.
또한 컴퓨터를 다시 시작할 때마다 오류 메시지가 나타날 수 있습니다.

원인

다음과 같은 이유로 이 문제가 발생할 수 있습니다.

원인 1

이 문제는 바이러스 백신 및 기타 보안 프로그램에서 충돌을 인해 발생할 수 있습니다. 컴퓨터를 시작할 때마다가 오류 메시지가 발생할 수 있습니다. 이 문제를 해결하려면 "해결 과정" 절의 Method 1 을 참조하십시오.

원인 2

경우 이 문제가 발생할 수 있습니다 현재 로그온한 사용자 계정에 임시 (임시) 폴더에 쓰는 데 충분한 사용 권한이. 이 문제를 해결하려면 "해결 과정" 절의 Method 2 를 참조하십시오.

해결 과정

이 문제를 해결하려면 해당 특정 시나리오에 대한 적절한 방법을 시도하여 문제를 해결하십시오. 시나리오 중 확실하지 않은 경우 Method 1 을 보십시오. 문제가 해결되지 않으면 Method 2 를 시도하십시오.

방법 1

이 문제를 해결하려면 프로그램 또는 오류 메시지의 원인이 서비스를 식별해야 합니다. CAPI2 작업 로깅, 사용 및 필요한 이벤트 로그를 수집할 컴퓨터를 다시 시작해야 합니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 시작 을 누르고 검색 시작 상자에 이벤트 뷰어프로그램 아래의 이벤트 뷰어 를 클릭하십시오.

    그림 축소그림 확대
    User Account Control permission
    관리자 암호나 확인을 묻는 메시지가 나타나면 암호를 입력하거나 확인하십시오.
  2. 응용 프로그램 및 서비스 로그 확장하십시오.
  3. Microsoft을 확장하십시오.
  4. Windows 를 확장하십시오.
  5. CAPI2 를 확장한 다음 작업 을 클릭하십시오. CAPI2 작업 로그가 열립니다.
  6. 동작 작업창에서 사용 로그 를 클릭하십시오.
  7. 컴퓨터를 다시 시작하십시오.
  8. CAPI2 작업 로그를 엽니다. 이렇게 하려면 1-5단계 반복하십시오.
  9. 작업 [NULL]에 대한 오류 수준이 11 이벤트 ID 이벤트 목록을 검색하십시오. 찾은, 각 인스턴스에 클릭한 다음 오류 메시지를 일으키는 프로그램을 확인하려면 이벤트에 대한 설명을 검토하십시오.
기록된 이벤트 중 하나 이상이 오류 메시지의 원인이 되는 프로그램을 나타낼 수 있습니다. 다음 바이러스 백신 및 방화벽 프로그램이 오류 메시지가 발생할 것으로 알려져 있습니다.
  • McAfee
  • Vsmon.exe
  • 평균
  • TrendMicro
  • 영역 경보
  • 다른 바이러스 백신 및 보안 제품
슬라이드 노트
  • 바이러스 백신 프로그램은 바이러스로부터 컴퓨터를 보호하기 위한 것입니다. 없습니다 다운로드 또는 신뢰하지 않는 원본의 웹 사용자가 수행할 없습니다 신뢰, 바이러스 백신 프로그램이 해제된 경우 전자 메일 첨부 파일을 열지 사이트를 방문하거나 파일을 열어야 합니다. 컴퓨터 바이러스에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
    129972컴퓨터 바이러스: 설명, 예방 및 복구
  • 방화벽은 악의적인 사용자에 의해 또는 원하지 않는 들어오는 네트워크 트래픽을 사용하여 컴퓨터를 공격하는 바이러스 같은 악의적인 소프트웨어의 공격으로부터 컴퓨터를 보호하기 위한 것입니다. 방화벽을 해제하기 전에 인터넷을 포함한 모든 네트워크에서 컴퓨터의 연결을 끊어야 합니다.
경고 이 문제를 해결하려면 컴퓨터 또는 네트워크에 더 취약한 악의적인 사용자나 바이러스와 같은 악의적인 소프트웨어의 공격을 할 수 있습니다. 따라서 이 해결 방법을 사용하지 않는 것이 좋습니다 않지만 사용자의 판단에 따라 이 해결 방법을 구현할 수 있도록 이 정보를 제공하고 있습니다. 이 해결 방법은 모든 책임은 사용하십시오.

여부를 중 하나를 프로그램 또는 이벤트 로그 오류 설명이 이 문제를 일으키는 설명하는 다른 프로그램을 확인하기 위해 일시적으로 사용하지 않도록 설정하면 또는 일시적으로 프로그램을 제거한 다음 컴퓨터를 다시 시작하면 의해 프로그램을 테스트할 수 있습니다. 그런 다음 오류 메시지가 여전히 발생하는지 오류 수준이 이벤트 ID 11 인스턴스 CAPI2 작업 로그를 검색하십시오.

중요한 해당 프로그램을 제거해야 할 경우 설치 미디어와 테스트를 완료한 후 프로그램을 다시 설치하여 필요한 모든 제품 ID를 액세스 권한이 있는지 확인해야 합니다.

일시적으로 해제하거나 프로그램을 일시적으로 제거하는 문제가 해결되는 경우, 업데이트, 핫픽스, 또는 기타 도움말 프로그램 제조업체에 문의해야 합니다.

방법 2

자동 루트 인증서 업데이트 CAB 파일을 다운로드하여 로컬 컴퓨터의 Temp 폴더에 있는 파일의 내용을 추출하고 루트 인증서 목록을 업데이트합니다. 적절한 사용 권한이 제대로 설치되어 CAB 파일 Temp 폴더에 적용되어야 합니다.

Temp 폴더에 대한 사용 권한을 확인하려면 다음과 같이 하십시오.
  1. 시작 을 누르고, 검색 시작 상자에 %userprofile%\AppData\Local 입력하고 목록에서 로컬 을 클릭하십시오.
  2. 폴더 목록에서 임시 폴더를 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.
  3. 보안 탭을 클릭하십시오.
  4. 컴퓨터에 로그온하고 사용자 계정에 모든 권한이 있는지 확인해야 하는 데 사용한 그룹 또는 사용자 이름 목록에서 해당 사용자 계정을 누릅니다.
참고 사용자 계정을 사용하면 데 사용되는 경우 컴퓨터에 로그온하는 모든 권한이 있어야 다음과 같이 하십시오.
  1. 편집 을 클릭하십시오.
  2. 그룹 또는 사용자 이름 목록 및 허용제어 전체 확인란을 선택한 다음 컴퓨터에 로그온하는 데 사용된 사용자 계정을 선택하십시오.
  3. 적용 을 누른 다음 확인 을 두 번 누릅니다.

참조

이 문서에 나와 있는 다른 공급업체 제품은 Microsoft와 무관한 회사에서 제조한 것입니다. Microsoft는 이러한 제품의 성능이나 신뢰성에 관하여 명시적이든 묵시적이든 어떠한 보증도 하지 않습니다.

속성

기술 자료: 976235 - 마지막 검토: 2009년 10월 6일 화요일 - 수정: 1.0
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  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
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