FIX: Fast Cache causes Windows Media Player to stop playback as soon as a video is fully cached on a computer that is running Windows Server 2003

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Article ID: 976249 - View products that this article applies to.
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SYMPTOMS

On a computer that is running Windows Server 2003, you use Microsoft Windows Media Player to play streaming content from a Windows Media server. Fast Cache is enabled on the server. When the content is fully cached, Windows Media Player stops playing, behaving as if you had clicked the Stop button.

Notes
  • The Windows Media service can be running locally or on a remote server.
  • The time that is required for Windows Media Player to stop playing may vary, depending on the following:
    • The connection speed between the Windows Media Player client on the computer and the Windows Media Player service on the server.
    • The Fast Cache content delivery rate.
    • The length and bit rate of the content.

CAUSE

Windows Media Player enters "slow skip" mode to transition from playing the streaming content from the server to playing the content from the cached content on the computer. However, Windows Media Player never exits "slow skip" mode after the transition.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

x86 versions of Windows Server 2003 Service Pack 2
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File nameFile versionFile sizeDateTime
Wmvcore.dll10.0.0.40062,330,62411-Nov- 200914:28
x64 versions of Windows Server 2003 Service Pack 2
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File nameFile versionFile sizeDateTime
Wwmvcore.dll10.0.0.40062,330,62411-Nov- 200912:25

Prerequisites

You must have Windows Server 2003 Service Pack 2 installed to apply this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 976249 - Last Review: October 7, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbfix kbbug kbexpertiseinter kbautohotfix kbsurveynew kbqfe KB976249

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