The Search Results Web Parts display invalid URLs for items in a SharePoint Services 3.0 environment

Article translations Article translations
Article ID: 976432 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

In Windows SharePoint Services 3.0 and Microsoft Office SharePoint Server 2007 environments, the Web Parts containing search results display invalid URLs for each item. This problem occurs when the SharePoint farm is configured to use reverse proxy publishing (off-box SSL termination). The URLs show HTTPS as the protocol. However, the URLs incorrectly include ":80" as the port address.

RESOLUTION

To resolve this issue, apply the following updates:
  • 975002 Description of the Windows SharePoint Services 3.0 Cumulative Update Server Hotfix Package (Sts-x-none.msp): October 27, 2009
  • 975731 Description of the SharePoint Server 2007 Cumulative Update Server Hotfix Package (Coreserver-x-none.msp): October 27, 2009

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 976432 - Last Review: November 12, 2009 - Revision: 1.2
APPLIES TO
  • Microsoft Windows SharePoint Services 3.0
  • Microsoft Office SharePoint Server 2007
Keywords: 
kbfix kbqfe kbexpertiseinter kbsurveynew kbprb KB976432

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com