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Síntomas

Imagine el siguiente escenario:

  • Instalar el servicio de puerta de enlace de escritorio remoto (puerta de enlace de escritorio remoto) en un equipo que ejecuta Windows Server 2008 R2.

  • Hay varios enlaces de certificado en el puerto 443 de este equipo.

En este escenario, la puerta de enlace de escritorio remoto no funcionen correctamente. El comportamiento incorrecto depende el nombre del almacén de certificados del enlace de certificado seleccionado. Los dos valores siguientes del certificado almacenan el nombre de enlace causas diferentes temas:

  • Nombre del almacén de certificados no es NULL para el enlace

    En este caso, todas las conexiones atraviesan excepto en las situaciones siguientes:

    • Autenticación de tarjeta inteligente está configurada en el lado de puerta de enlace de escritorio remoto.

    • Se exigen comprobaciones de estado de protección de acceso de red del cliente.

  • Nombre del almacén de certificados es NULL para el enlace

    En este caso, fallan todas las conexiones entre sí, y recibirá el siguiente mensaje de error:

    El equipo no puede conectarse al equipo remoto porque se ha configurado ningún certificado para usar en el servidor de puerta de enlace de escritorio remoto. Para obtener ayuda, póngase en contacto con su administrador de red.

    Al mismo tiempo, se agrega el siguiente evento TerminalServices-puerta de enlace que tiene el ID 306 el registro TerminalServices-puerta de enlace:
    Nota: Para comprobar si el nombre del almacén de certificados es NULL, siga estos pasos:

    1. En el símbolo del sistema, escriba el comando siguiente y, a continuación, presione ENTRAR:

      netsh http mostrar sslcert

    2. Compruebe el valor para El nombre del almacén de certificados del primer enlace que está escuchando en el puerto 443. Un valor NULL () indica que el nombre del almacén de certificados es NULL para ese enlace concreto.

Causa

Los problemas se producen porque el servicio de puerta de enlace de escritorio remoto recupera un enlace de certificado incorrecto.

Solución

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, el equipo debe estar ejecutando Windows Server 2008 R2.

Requisito de reinicio


Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión


Este hotfix no sustituye a otras.

Información de archivo


La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha
Zona horaria
ficha en el
Fecha y hora
en Panel de Control.

Para todas las versiones basadas en x64 compatibles de Windows Server 2008 R2

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Aaedge.dll

6.1.7600.20546

304,128

10-Oct-2009

06:12

x64

Aaedge.mof

No aplicable

1.268

10-Jun-2009

20:31

No aplicable

Aatspp.dll

6.1.7600.16385

65.024

14-Jul-2009

01:39

x64

Aatspp.mof

No aplicable

1.271

10-Jun-2009

20:31

No aplicable

Rap.xml

No aplicable

895

10-Jun-2009

20:31

No aplicable

Tsgateway.xml

No aplicable

429

10-Jun-2009

20:31

No aplicable

Tsgclean.exe

6.1.7600.16385

428.032

14-Jul-2009

01:39

x64

Tsproxy-edgeadapter-ppdlic.xrm-ms

No aplicable

3,018

10-Oct-2009

08:55

No aplicable



Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft



Información adicional de archivos para Windows Server 2008 R2


Archivos adicionales para todas las versiones compatibles basadas en x64 de Windows Server 2008 R2

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Amd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.20546_none_9ab543bbff629cbd.manifest

No aplicable

99,560

11-Oct-2009

19:00

No aplicable

Package_for_kb976484_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum

No aplicable

1.458

11-Oct-2009

19:00

No aplicable

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