FIX: You receive an error message when you log on to or log off from a Commerce Server 2007 SP2 site

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Article ID: 976555 - View products that this article applies to.
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SYMPTOMS

You log on to or log off from a Microsoft Commerce Server 2007 Service Pack 2 (SP2) site. However, you intermittently receive an error message that resembles the following:
A duplicate value for unique key member <profile property> found while building indices for profile Contact. Check the underlying store for uniqueness of the property.
Notes
  • Values for "profile property" vary according to the UNIQUE key that is set in the profile definition. "GeneralInfo.Username" is an example of a "profile property" value.
  • You can use Profiles Schema Manager to specify a UNIQUE key. For more information about Profiles Schema Manager, refer to the "More information" section.

Additionally, an event that resembles the following is logged in the Application log:
Log Name:      Application
Source:        ASP.NET 2.0.50727.0
Event ID:      1309
Task Category: Web Event
Level:         Warning

Description:
Event code: 3005 
Event message: An unhandled exception has occurred. 
Event time: <Time>
Event time (UTC): <UTC time>
Event ID: <ID> 
Event sequence: <number> 
Event occurrence: <number>
Event detail code: <number>
 
Application information: 
    Application domain: <application domain>
    Trust level: Full 
    Application Virtual Path: <virtual path>
		  
    Application Path: <path>
    Machine name: <machine name>
		  
 
Process information: 
    Process ID: <process ID> 
    Process name: w3wp.exe 
    Account name: <account name>
 
Exception information: 
    Exception type: CommerceProfileSystemException 
    Exception message: Failed to retrieve profile.
...

CAUSE

This problem occurs because Commerce Server 2007 SP2 does not handle exceptions that occur when a duplicate value is found for a UNIQUE key in the profile cache.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: -
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 SP2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) after you apply this hotfix. To restart IIS, at a command prompt, type the following command, and then press ENTER:
IISRESET /RESTART
Note This command stops and then restarts all IIS services that are running.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all 32-bit versions of Commerce Server 2007
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mscsups.dll6.0.4109.37209,40805-Mar-201012:28x86
For all 64-bit versions of Commerce Server 2007
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mscsups.dll6.0.4109.37368,64005-Mar-201013:04x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about product definition keys, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/bb509002.aspx
For more information about Commerce Server 2007 Profiles System, visit the following MSDN Web site:
http://msdn.microsoft.com/en-us/library/aa545016.aspx
For more information about Profiles Schema Manager, visit the following MSDN Web site:
http://msdn.microsoft.com/en-us/library/ms916440.aspx

Properties

Article ID: 976555 - Last Review: October 7, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Commerce Server 2007 Developer Edition
  • Microsoft Commerce Server 2007 Enterprise Edition
  • Microsoft Commerce Server 2007 Standard Edition
Keywords: 
kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe KB976555

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