A new user cannot use touch capacity to log on to a computer that is running Windows 7or Windows Server 2008 R2 after it resumes from sleep or hibernation

Article translations Article translations
Article ID: 976755 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You have a computer that is running Windows 7 Tablet PC. Or, you have a computer that is running Windows 7 or Windows Server 2008 R2 that has Human Input Devices (HID) connected.
  • Several users are logged on to the computer.
  • The computer enters sleep or hibernation.
  • The computer resumes from sleep or hibernation.
  • Another user tries to log on to the computer.
In this scenario, the touch capability is lost unexpectedly. Therefore, the user cannot log on to the computer by using the pen or the touch screen.

Note The touch capability functions correctly for users who were logged on to the computer before it entered sleep or hibernation.

CAUSE

This issue occurs when a new user tries to log on to the computer after it resumes from sleep or hibernate. In this situation, the Human Input Devices change their power state from the working power state to the sleeping power state.

Note The Human Input Devices in this scenario are the pen and touch screen.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites to apply this hotfix.

Restart requirement

You have to restart the computer after you apply this hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows 7 and Windows Server 2008 R2 file information notes

  • Windows 7 and Windows Server 2008 R2 file information notes
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.7600.16xxxWindows 7 and Windows Server 2008 R2RTMGDR
    6.1.7600.20xxxWindows 7 and Windows Server 2008 R2RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread and very important issues. LDR service branches contain hotfixes in addition to widely released fixes.

For all supported x86-based versions of Windows 7

Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Hidclass.sys6.1.7600.2055455,80821-Oct-200903:03
Hidparse.sys6.1.7600.1638525,72813-Jul-200923:51
Hidusb.sys6.1.7600.1638524,06413-Jul-200923:51

For all supported x64-based versions of Windows Server 2008 R2 and of Windows 7

Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Hidclass.sys6.1.7600.2055476,28821-Oct-200903:27
Hidparse.sys6.1.7600.1638532,89614-Jul-200900:06
Hidusb.sys6.1.7600.1638530,20814-Jul-200900:06

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Human Input Devices, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/ms789872.aspx
http://msdn.microsoft.com/en-us/library/ms790197.aspx

Properties

Article ID: 976755 - Last Review: October 7, 2011 - Revision: 2.0
APPLIES TO
  • Windows 7 Starter
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Web Server 2008 R2
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
Keywords: 
kbfix kbexpertiseadvanced kbautohotfix kbsurveynew kbqfe KB976755

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com