Windows search error "Search cannot return results for this view" in the People Pane

Article ID: 976786 - View products that this article applies to.
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Symptoms

In the People Pane, the Microsoft Outlook Social Connector feature does not display information about your contact, such as activities, meetings, status updates, email messages, or meetings. Instead, the following text is displayed:

There are no items to display in this view.
Additionally, a warning bar displays the following notices in the People Pane:

Search cannot return results for this view. Click here for more information.
If the People Pane is minimized, the following notification is displayed:

Windows Desktop Search is not available.
Note In this configuration, you receive one of the following error messages when you try to perform a search in Outlook:
  • Instant Search is not available when Outlook is running with administrator permissions. To use Instant Search, exit and restart Outlook without administrator permissions.
  • To enable the Instant Search feature in Outlook, you must download and install a component for Microsoft Windows.

Cause

This problem occurs because the Outlook Social Connector feature depends on Windows Search to provide information in the People Pane. However, the Windows Search functionality is not available in either of the following scenarios:
  • You run Outlook 2010 by using administrator-elevated permissions.
  • You do not have Windows Search installed.

Resolution

If you want to use this feature in the Outlook Social Connector, please use one of the following solutions, depending on the source if the problem.

You started Outlook by using the "Run as Administrator" command

In this scenario, exit Outlook 2010, and then start Outlook 2010, but do not use the Run as Administrator command. To do this, follow these steps:
  1. Exit Outlook 2010
  2. Click Start, click All Programs, and then click Microsoft Office.
  3. Click Microsoft Outlook 2010.

You do not have the required Windows Search components installed

Windows 7:
If you are running Windows 7, and the Windows Search component is not installed, please follow these steps to add this feature to your Windows installation.
  1. Exit Outlook 2010.
  2. In Control Panel, click Programs and Features.
  3. In the Programs and Feature control panel, click Turn Windows features on or off.
  4. In the Windows Features dialog box, locate and then click to select the check box for the Windows Search feature.

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    Windows Features
  5. Click OK.
  6. After the Windows Search feature is installed, click Restart Now to restart your computer.
  7. Start Outlook after your computer restarts.

    Note You may see a dialog box that resembles the following when Outlook is first started after you make this change to your Windows 7 installation.

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    Outlook installing Windows Search
Windows XP or Windows Vista:

If you are running Windows XP or Windows Vista, and Windows Search 4.0 is not installed, you must install Windows Search 4.0. To download the update, visit the following Download Center pages for your version of Windows:
Windows Search 4.0 for Windows XP (KB940157)

Windows Search 4.0 for Windows Vista SP1 (KB940157)

For more information about how to install Windows Search 4.0, click the following article number to view the article in the Microsoft Knowledge Base:
940157 Description of Windows Search 4.0 and the Multilingual User Interface Pack for Windows Search 4.0

Disable the notification messages

If you do not want to want to install the necessary Windows Search components, and you want to disable these alerts, you must modify the Windows registry. To have us disable the notification messages for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.
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Fix this problem
Microsoft Fix it 50516
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Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not using the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To to disable these alerts yourself, please follow these steps to update the Windows registry:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following subkey in the registry:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Search
    Note You must manually create this subkey in the registry if this subkey currently does not exist. To do this, follow these steps:
    1. Locate and then click the following subkey in the registry:
      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook
    2. On the Edit menu, point to New, and then click Key.
    3. Type Search, and then press ENTER.
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DisableDownloadSearchPrompt, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 1, and then click OK.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 976786 - Last Review: February 12, 2013 - Revision: 8.0
Applies to
  • Microsoft Outlook 2010
Keywords: 
kbexpertiseinter kbtshoot kbsurveynew kbprb kbfixme kbmsifixme KB976786

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