Windows Server 2008 R2 には、メンバー サーバーをアップグレード完全 FRS 削除されるわけではありません。

文書翻訳 文書翻訳
文書番号: 976826 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows Server 2008 R2 を実行しているサーバーを起動すると、ファイル レプリケーション サービス (FRS) が起動しないと、次のエラーが FRS イベント ログに記録されます。
ファイル レプリケーション サービスのログ名:
ソース: NtFrs
発行日: 2009/1/6 11時 12分: 45 AM
イベント ID: 13574
タスクのカテゴリ: なし
レベル: エラー
キーワード: クラシック
ユーザー : N/A
コンピューター: Server_name
説明:
ファイル レプリケーション サービスは、このサーバーをドメイン コントローラーではないことが検出されました。 ファイル レプリケーション サービスの非-SYSVOL コンテンツ セットのレプリケーションの使用は推奨されていませんし、したがって、サービスが停止されています。 DFS レプリケーション サービスは、ドメイン コントローラーと DFS リンク ターゲット上の SYSVOL 共有フォルダーのレプリケーションをお勧めします。
メモ このエラーでは、プレースホルダー Server_name を FRS が起動していないサーバーの名前を表します。

原因

この問題は、Windows Server 2008 R2 に Windows Server 2008 の Service Pack 2 (SP2) を実行していたサーバーまたは Windows Server 2003 Service Pack 2 (SP2) をアップグレードする際に発生したコードの欠陥のために発生します。 FRS コンポーネント サーバーのアップグレード中に削除されることはありません。

Windows Server 2008 R2 は、従来の FRS コンポーネント メンバー サーバーで deprecates します。 Windows Server 2008 R2 にサーバーをアップグレードすると、アップグレード処理は、FRS コンポーネント完全に削除されないことを検索します。

Windows Server 2003 SP2 からアップグレードしたサーバーでは、[次のイベントが発生します。
  • FRS サービスが削除されます。
  • FRS は、イベント ログが削除されていないがイベント ログを消去します。
Windows Server 2008 SP2 からアップグレードしたサーバーでは、[次のイベントが発生します。
  • FRS サービスが停止または削除されていません。
  • サーバーの再起動ではすべて、エラーが FRS イベント ログに記録されます。
メモ インプレース アップグレードはサポートされていますが、サーバー オペレーティング システムのクリーン インストールで読み込まれていることを推奨の。

回避策

この問題を回避するには、以下の回避策のいずれかを使用します。

重要 このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。 ただし、レジストリを誤って変更すると深刻な問題が発生する可能性があります。 レジストリを変更する際には十分に注意してください。 変更する前に追加された保護のために、レジストリをバックアップします。 問題が発生した場合でも、レジストリを復元できます。 バックアップを作成し、レジストリを復元する方法の詳細については、「サポート技術情報」(Microsoft Knowledge Base) の資料を表示するには、以下「Base をクリックします。
322756バックアップを作成し、Windows レジストリを復元する方法

サーバーの Windows Server 2003 SP2 からのアップグレード

  1. スタート ボタンをクリックして、実行] をクリックして、regedit を入力し、[OK] をクリックします。
  2. レジストリの次のキーに移動し、クリックします:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\File 複製サービス
  3. [ファイル] メニューの [エクスポート] をクリックします。
  4. [ファイル名] ボックスで、FRSREG1.reg を入力し、[保存]</a0> をクリックします。
  5. [編集] メニューの [削除] をクリックし、[はい] をクリックします。
  6. レジストリの次のキーに移動し、クリックします:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Application\NTFRSPerf
  7. [ファイル] メニューの [エクスポート] をクリックします。
  8. [ファイル名] ボックスで、FRSREG2.reg を入力し、[保存]</a0> をクリックします。
  9. [編集] メニューの [削除] をクリックし、[はい] をクリックします。
  10. レジストリ エディターを終了します。
  11. サーバーを再起動してください。

サーバーの Windows Server 2008 SP2 からのアップグレード

  1. サービス スナップイン (Services.msc) を起動します。
  2. 検索しは、ファイル レプリケーション サービスを停止し、[サービス] スナップインを終了します。
  3. スタート ボタンをクリックして、実行] をクリックして、regedit を入力し、[OK] をクリックします。
  4. レジストリの次のキーに移動し、クリックします:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Ntfrs
  5. [ファイル] メニューの [エクスポート] をクリックします。
  6. [ファイル名] ボックスで、FRSREG1.reg を入力し、[保存]</a0> をクリックします。
  7. [編集] メニューの [削除] をクリックし、[はい] をクリックします。
  8. レジストリの次のキーに移動し、クリックします:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\File 複製サービス
  9. [ファイル] メニューの [エクスポート] をクリックします。
  10. [ファイル名] ボックスで、FRSREG2.reg を入力し、[保存]</a0> をクリックします。
  11. [編集] メニューの [削除] をクリックし、[はい] をクリックします。
  12. レジストリ エディターを終了します。
  13. 高度セキュリティ スナップインで (Wf.msc) は、Windows ファイアウォールを起動します。
  14. [受信の規則] ノードを開きます。
  15. 次の 2 つの規則を無効にします。
    • ファイル レプリケーション (RPC)
    • ファイルのレプリケーション (RPC EPMAP
  16. [Windows ファイアウォールでは、[セキュリティ] スナップインを終了します。
  17. サーバーを再起動してください。

状況

マイクロソフトでは、この問題を記載されているマイクロソフト製品の問題として認識しています。

プロパティ

文書番号: 976826 - 最終更新日: 2009年10月21日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Service Pack 2?を以下の環境でお使いの場合
    • Windows Server 2008 Datacenter
    • Windows Server 2008 Enterprise
    • Windows Server 2008 Standard
  • Microsoft Windows Server 2003 Service Pack 2?を以下の環境でお使いの場合
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
キーワード:?
kbtshoot kbregistry kbprb kbexpertiseinter kbmt kbsurveynew KB976826 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:976826
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com