การแก้ไข: แฟ้มจะไม่ถูกลบออกจากที่ตั้ง FTP เมื่อคุณใช้ BizTalk Server 2006 R2 หรือ 2009 เซิร์ฟเวอร์ BizTalk

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 976891 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้ใน Microsoft BizTalk Server 2006 R2 หรือ BizTalk Server 2009:
  • เรียกคืนแฟ้มจากโฟลเดอร์ย่อยใน FTP ตำแหน่งที่ตั้ง โดยใช้ FTP ตำแหน่งที่ตั้งที่ได้รับ
  • ในขณะที่ BizTalk Server 2006 R2 กำลังประมวลผลแฟ้มนี้ การเชื่อมต่อ FTP หมดเวลา
  • หลังจากเวลา BizTalk Server 2006 R2 เปิดเซสชัน FTP ใหม่ และจากนั้น ออกคำสั่ง DELE
ในสถานการณ์สมมตินี้ BizTalk Server 2006 R2 ไม่สามารถลบแฟ้มที่ได้รับจากโฟลเดอร์ย่อยในตำแหน่งที่ตั้ง FTP นอกจากนี้ ปิดเซสชัน FTP ใหม่ และคุณสามารถดูรายการบันทึกในแฟ้มบันทึกของ BizTalk Server 2006 R2 FTP ที่มีลักษณะต่อไปนี้:
< 220="" microsoft="" ftp="" service="">
> USER แบบไม่ระบุชื่อ
< 331="" anonymous="" access="" allowed,="" send="" identity="" (e-mail="" name)="" as="" password.="">
> PASS xxxx
< 230="" anonymous="" user="" logged="" in.="">
> pwd
< 257="" "/"="" is="" current="" directory.="">
> delefile_name
< 550="">file_name: ระบบไม่พบแฟ้มที่ระบุ
> ปิด
< 221="">
เมื่อที่ BizTalk Server 2006 R2 หรือ 2009 เซิร์ฟเวอร์ BizTalk อยู่ถัดจาก polls ตำแหน่งที่ตั้ง FTP, BizTalk Server 2006 R2 หรือ BizTalk Server 2009 เปิดตำแหน่งที่ตั้ง FTP และดาวน์โหลดแฟ้มเดียวกันอีกครั้ง

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจาก BizTalk Server 2006 R2 หรือ BizTalk Server 2009 ไม่ออกคำสั่ง CWD ก่อนที่จะออกคำสั่ง DELE ดังนั้น แทนที่การพยายามที่จะลบแฟ้มออกจากโฟลเดอร์ย่อยที่กำหนดไว้ BizTalk Server 2006 R2 หรือ BizTalk Server 2009 พยายามลบแฟ้มออกจากไดเรกทอรีรากของ FTP

การแก้ไข

ข้อมูลการปรับปรุงที่สะสม

สำหรับ 2009 เซิร์ฟเวอร์ BizTalk โปรแกรมแก้ไขด่วนเพื่อแก้ไขปัญหานี้ถูกรวมใน 1 สะสมของการปรับปรุงสำหรับ 2009 เซิร์ฟเวอร์ BizTalk

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการขอรับแพคเกจโปรแกรมปรับปรุงที่สะสม คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
2429050แพคเกจโปรแกรมปรับปรุงที่สะสม 1 สำหรับ 2009 เซิร์ฟเวอร์ BizTalk

ข้อมูลโปรแกรมแก้ไขด่วน

สำหรับ BizTalk Server 2006 R2

โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว แต่มีเป้าหมายเพียงเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น ใช้ hotfix นี้เฉพาะกับระบบต่างๆ ที่พบปัญหานี้เท่านั้น hotfix นี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณไม่ได้รับอย่างจากจากปัญหานี้ เราขอแนะนำให้ คุณรอ service pack รุ่นถัดไปของ Microsoft BizTalk Server 2004 ซึ่งประกอบด้วยโปรแกรมแก้ไขด่วนนี้

เมื่อต้องการแก้ไขปัญหานี้ทันที ให้ติดต่อฝ่ายบริการสนับสนุนผลิตภัณฑ์ของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน สำหรับรายการทั้งหมดของหมายเลขโทรศัพท์ของบริการการสนับสนุนลูกค้าของ Microsoft และข้อมูลเกี่ยวกับการจ่ายสนับสนุน แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:ในกรณีพิเศษ อาจมีการยกเว้นค่าใช้จ่ายสำหรับการสนับสนุนทางโทรศัพท์หากผู้เชี่ยวชาญในการให้การสนับสนุนของ Microsoft ระบุว่าการปรับปรุงเฉพาะจะแก้ปัญหาของคุณได้ ค่าใช้จ่ายปกติจะใช้กับการให้การสนับสนุนสำหรับคำตอบเพิ่มเติมและเรื่องที่ไม่สามารถจัดเป็นคำถามเกี่ยวกับการอัพเดทเฉพาะ

ข้อกำหนดเบื้องต้น

ไม่มีข้อกำหนดเบื้องต้นสำหรับการติดตั้งแพคเกจโปรแกรมแก้ไขด่วนนี้ได้

ข้อกำหนดในการเริ่มต้นระบบคอมพิวเตอร์ใหม่

คุณไม่ต้องรีสตาร์ทคอมพิวเตอร์หลังจากที่คุณนำแพคเกจโปรแกรมแก้ไขด่วนนี้อย่างไรก็ตาม คุณต้องเริ่มต้นการบริการโปรแกรมประยุกต์ของเซิร์ฟเวอร์ BizTalk หลังจากที่คุณใช้โปรแกรมแก้ไขด่วนนี้

ข้อมูลการทดแทนโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้แทนเป็นแพคเกจโปรแกรมแก้ไขด่วนที่นำออกใช้ก่อนหน้านี้

ข้อมูลแฟ้ม

รุ่นภาษาอังกฤษ (สหรัฐอเมริกา) ของแพคเกจโปรแกรมแก้ไขด่วนนี้ใช้เป็นแพคเกจ Microsoft Windows Installer เพื่อติดตั้งแพคเกจโปรแกรมแก้ไขด่วน วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบ Coordinated Universal Time (UTC) ในตารางต่อไปนี้ เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในรายการวันและเวลาใน'แผงควบคุม'
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์ม
Interop.xceedftplib.dll3.6.1550.259,22430 2009 Oct16:15x86
Microsoft.biztalk.coreadapter.dll3.6.1550.2104,32030 2009 Oct16:15x86
Xceedftpbiztalk.dll3.6.1550.2300,88030 2009 Oct16:17x86
หมายเหตุ:เนื่องจากการอ้างอิงแฟ้ม โปรแกรมแก้ไขด่วนที่สุดที่ประกอบด้วยแฟ้มเหล่านี้อาจประกอบด้วยแฟ้มเพิ่มเติม

สำหรับ BizTalk Server 2006 R2 SP1


โปรแกรมแก้ไขด่วนที่แก้ไขปัญหานี้จะรวมอยู่ในแพคเกจโปรแกรมปรับปรุงที่สะสม 1 สำหรับ BizTalk Server 2006 R2 SP1

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการขอรับแพคเกจโปรแกรมปรับปรุงที่สะสม คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:

982061แพคเกจโปรแกรมปรับปรุงที่สะสม 1 สำหรับ BizTalk Server 2006 R2 Service Pack 1

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับโปรแกรมแก้ไขด่วนของ BizTalk Server 2006 R2 SP1 คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:

974563รายการของการแก้ไขลัด Microsoft BizTalk Server ที่รวมอยู่ใน BizTalk Server 2006 R2 Service Pack 1

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
824684คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายปรับปรุงซอฟต์แวร์ของ Microsoft
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับโปรแกรมแก้ไขด่วนของ BizTalk Server คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
203907ข้อมูลเกี่ยวกับการแก้ปัญหาการพิมพ์ลัดเซิร์ฟเวอร์ BizTalk
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการกำหนดค่า FTP ได้รับการตั้ง เยี่ยมชมเว็บไซต์ของ Microsoft สำหรับนักพัฒนาเครือข่าย (MSDN) ต่อไปนี้:
http://msdn.microsoft.com/en-us/library/aa559095%28BTS.20%29.aspx

คุณสมบัติ

หมายเลขบทความ (Article ID): 976891 - รีวิวครั้งสุดท้าย: 8 ธันวาคม 2553 - Revision: 2.0
ใช้กับ
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbbtsadapters kbbiztalk2006r2presp2fix kbexpertiseinter kbsurveynew kbbug kbfix kbqfe kbmt KB976891 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:976891

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com