"仅允许 Windows 应用程序运行"组策略设置在 Windows Vista、 Windows Server 2008,或 Windows 7 运行的计算机上显示没有条目

文章翻译 文章翻译
文章编号: 976922 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

您正在运行 Windows Vista、 Windows Server 2008、 Windows 7 或更高版本的 Windows 操作系统的计算机上启动组策略管理控制台 (GPMC)。然后,您可以使用组策略管理编辑器窗口来编辑组策略设置。在这种情况下 运行只允许使用 Windows 应用程序 组策略设置显示没有项。 但是,如果您编辑组策略设置在运行 Windows Server 2003 的服务器上或在运行 Windows XP 的计算机上,将显示此设置的项。

不管操作系统的系统正确应用的 $ 组策略设置。

原因

仅在满足下列条件都为真时才会出现此问题:
  • 网络是操作系统的混合的环境,包括下列不同:
    • Windows 2008 Server
    • Windows Server 2008 R2
    • Windows Vista (RSAT)
    • Windows 7 (RSAT)
  • 网络还具有至少一台计算机正在运行下列操作系统之一:
    • Windows 2003 Server
    • Windows Server 2003 R2
    • Windows XP
  • 您以前已编辑了正在运行 Windows XP 或 Windows Server 2003 的计算机上组策略设置。
满足这些条件时外壳-CommandPrompt RegEditTools.admx 程序中的一个问题阻止组策略管理编辑器窗口中正确显示在 Windows Vista、 Windows Server 2008,或 Windows 7 运行的计算机上的 运行只允许使用 Windows 应用程序 设置。

替代方法

若要解决这些问题,您可以使用下列方法之一。

方法 1: 重新创建打开 Windows 7 或 Windows Server 2008 上此设置

要变通解决此问题,您必须通过使用组策略管理编辑器窗口,在运行 Windows Server 2008 的服务器上或在一台基于 Windows 7 的计算机上重新创建 运行只允许使用 Windows 应用程序 组策略设置。重新创建该设置后,不要编辑组策略设置在运行 Windows Server 2003 的服务器上或在一台基于 Windows XP 的计算机上。

方法 2: 编辑 Windows Server 2003 上或在 Windows XP 上此设置

若要变通解决此问题,只编辑 运行只允许使用 Windows 应用程序 组策略设置在运行 Windows Server 2003 的服务器上或在一台基于 Windows XP 的计算机上。

状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。

属性

文章编号: 976922 - 最后修改: 2009年10月27日 - 修订: 1.0
这篇文章中的信息适用于:
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional x64 Edition
关键字:?
kbmt kbgrppolicyprob kbtshoot kbexpertiseinter kbsurveynew kbprb KB976922 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 976922
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com