Message d'erreur lorsque vous essayez d'importer des personnalisations de Microsoft Dynamics CRM Online dans une organisation de Microsoft Dynamics CRM 4.0: «Soit Impossible de télécharger le fichier ou ce n'est pas un fichier de personnalisation valide»

Traductions disponibles Traductions disponibles
Numéro d'article: 976978 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Lorsque vous essayez d'importer des personnalisations de Microsoft Dynamics CRM Online dans une organisation de Microsoft Dynamics CRM 4.0, vous recevez le message d'erreur suivantes :
Impossible de télécharger le fichier, soit ce n'est pas un fichier de personnalisation valide.

Cause

Ce problème se produit car le fichier de personnalisation de Microsoft Dynamics CRM Online doit être converti en un fichier de personnalisation de Microsoft Dynamics CRM 4.0 avant d'importer le fichier.

Résolution

Ce problème est résolu dans le correctif cumulatif plus récent de la mise à jour cumulative pour Microsoft Dynamics CRM 4.0.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
949256Mises à jour de Microsoft Dynamics CRM 4.0 et les correctifs

Après avoir installé le dernier correctif cumulatif cumulatif pour Microsoft Dynamics CRM, vous devez convertir le fichier de personnalisation de CRM en ligne dans un fichier de personnalisation de CRM 4.0. Pour ce faire, procédez comme suit :
  1. Téléchargement du correctif cumulatif 7 pour Microsoft Dynamics CRM 4.0. Pour cela, reportez-vous au site Web de Microsoft à l'adresse suivante : http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=a4893988-7804-4e23-ab58-740441cc696e
  2. Enregistrez le fichier téléchargé dans un dossier.
  3. Cliquez sur Démarrer, sur exécuter, tapez cmd et cliquez sur OK.
  4. Modifier les répertoires dans le dossier qui contient le fichier pour cumulatif 7 pour Microsoft Dynamics CRM 4.0, tapez CRMv4.0-KB971782-i386-Server-ENU.exe /x et appuyez sur la touche ENTRÉE.
  5. Lorsque vous êtes invité à enregistrer les fichiers extraits, cliquez sur Enregistrer.
  6. Modifier les répertoires dans le répertoire outils/Customizationmigrationprocessor. Se trouve le répertoire où les fichiers extraits ont été enregistrés dans l'étape 5.
  7. À l'invite de commandes, exécutez le fichier Migrationprocessortool.exe qui se trouve dans le dossier Customizationmigrationprocessor. Pour ce faire, exécutez la commande suivante :
    migrationprocessortool Customizationfile

    Notes
    • L'espace réservé Customizationfile représente l'emplacement du fichier de personnalisation en ligne de Microsoft CRM que vous souhaitez traiter.
    • Lorsque vous exécutez le fichier Migrationprocessortool.exe, l'outil traite les personnalisations. Ensuite, l'outil enregistre un nouveau fichier est nommé «ProcessedCustomization.xml» dans le dossier Customizationmigrationprocessor.
    • Le fichier ProcessedCustomization.xml contient un nouvel ensemble de personnalisations.
Après vous convertir le fichier de personnalisation de CRM en ligne dans un fichier de personnalisation de CRM 4.0, utilisez le fichier ProcessedCustomization.xml pour importer des personnalisations de Microsoft Dynamics CRM Online dans une organisation de Microsoft Dynamics CRM 4.0.

Plus d'informations

Les erreurs suivantes sont attendus pendant l'exécution de l'outil :
Erreurs de validation dans processeur InternetMarketingProcessor :
L'attribut 'GetStartedPanePath' n'est pas déclaré.
L'attribut 'GetStartedPanePathOutlook' n'est pas déclaré.
L'attribut 'GetStartedPanePathAdmin' n'est pas déclaré.
L'attribut 'GetStartedPanePathAdminOutlook' n'est pas déclaré.



Lors de l'outil MigrationProcessor, il s'exécute différents processeurs configurés dans le fichier de configuration de processeur. La version actuelle exécute les processeurs suivants :
  • Processeur de visualisations
  • Processeur de Marketing Internet
  • Processeur de Helpvisor
  • Processeur de la page d'accueil

Tous les processeurs, sauf le dernier processeur ont le IgnoreValidationErrors défini à true comme le travail n'est pas vraiment terminé et les validations n'aboutissent pas jusqu'à ce que le processeur dernière réussit dans le traitement si tous les processeurs traitent différents aspects de nettoyage dans le même élément. Dans ce cas lorsque le processeur Internet Marketing termine son travail il a toujours validation échecs againt site mapper xsd comme il y a toujours un travail de nettoyage nécessaire pour être effectuée par le processeur Visor aide et vous obtenez les erreurs de validation. Une fois que le dernier processeur défini dans le fichier de configuration s'exécute, nous n'attendent pas d'autres erreurs de validation que les processeurs de jeu terminé tout le travail de nettoyage.

Propriétés

Numéro d'article: 976978 - Dernière mise à jour: lundi 11 janvier 2010 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Dynamics CRM 4.0
Mots-clés : 
kbmt kberrmsg kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe KB976978 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 976978
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com