Microsoft Dynamics CRM オンラインのカスタマイズを Microsoft Dynamics CRM 4. 0 の組織にインポートしようとすると、エラー メッセージ:「か、ファイルをアップロードできませんでした、または有効なカスタマイズ ファイルではありません」

文書翻訳 文書翻訳
文書番号: 976978 - 対象製品
すべて展開する | すべて折りたたむ

現象

Microsoft Dynamics CRM オンラインのカスタマイズを Microsoft Dynamics CRM 4. 0 の組織にインポートしようとすると、次のエラー メッセージが表示されます。
ファイルをアップロードできませんでした、または有効なカスタマイズ ファイルではありません。

原因

この問題は、ファイルをインポートする前に、Microsoft Dynamics CRM オンライン カスタマイズ ファイルを Microsoft Dynamics CRM 4. 0 のカスタマイズ ファイルに変換する必要があるために発生します。

解決方法

Microsoft Dynamics CRM 4. 0 の最新の累積的な更新プログラムのロールアップでこの問題を解決します。
関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください:
949256Microsoft Dynamics CRM 4. 0 更新プログラムおよび修正プログラム

Microsoft Dynamics CRM の最新の累積的な更新プログラムのロールアップをインストールした後、CRM 4. 0 のカスタマイズ ファイルに変換、CRM オンライン カスタマイズ ファイル必要があります。 以下が手順例となります:
  1. Microsoft Dynamics CRM 4. 0 の更新プログラムのロールアップ 7 をダウンロードします。 これを行うには、次のマイクロソフト Web サイトを参照してください: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=a4893988-7804-4e23-ab58-740441cc696e
  2. ダウンロードしたファイルをフォルダーに保存します。
  3. [スタート] をクリックして、実行] をクリックして、cmd を入力し、[OK] をクリックします。
  4. 更新プログラムのロールアップ 7 を Microsoft Dynamics CRM 4. 0 のファイルを含むフォルダーにディレクトリを変更し、CRMv4.0-KB971782-i386-サーバー-ENU.exe/x を入力し、Enter キーを押します。
  5. 抽出したファイルを保存するかどうかを確認するメッセージが表示されたら [保存] をクリックします。
  6. ディレクトリ ツール/Customizationmigrationprocessor ディレクトリに変更します。 ディレクトリが展開されたファイルが保存された手順 5 で置かれています。
  7. コマンド プロンプトで、[Customizationmigrationprocessor] フォルダーにある、Migrationprocessortool.exe ファイルを実行します。 これを行うには、次のコマンドを実行します。
    migrationprocessortool Customizationfile

    メモ
    • Customizationfile プレースホルダーを処理する、Microsoft CRM オンライン カスタマイズ ファイルの場所を表します。
    • Migrationprocessortool.exe ファイルを実行すると、ツールのカスタマイズを処理します。 次に、ツール、Customizationmigrationprocessor フォルダーに ProcessedCustomization.xml という名前を新しいファイルを保存します。
    • ProcessedCustomization.xml ファイルには、カスタマイズの新しいセットが含まれています。
Microsoft Dynamics CRM オンライン カスタマイズを Microsoft Dynamics CRM 4. 0 の組織にインポートするのには、ProcessedCustomization.xml ファイルで、変換後、CRM オンライン カスタマイズ ファイルを CRM 4. 0 のカスタマイズ ファイルを使用します。

詳細

このツールの実行中に次のエラーが予想されます。
プロセッサ InternetMarketingProcessor で検証エラー:
'GetStartedPanePath' 属性が宣言されていません。
'GetStartedPanePathOutlook' 属性が宣言されていません。
'GetStartedPanePathAdmin' 属性が宣言されていません。
'GetStartedPanePathAdminOutlook' 属性が宣言されていません。



MigrationProcessor ツールを実行すると、さまざまなプロセッサをプロセッサ構成ファイルで構成を実行します。 現在のバージョンは、次のプロセッサを実行します。
  • 視覚エフェクトのプロセッサ
  • インターネット マーケティング プロセッサ
  • Helpvisor プロセッサ
  • ホーム ページ プロセッサ

最後のプロセッサを除く、すべてのプロセッサに作業が実際に完了していないクリーンアップでは、同じ要素のさまざまな側面のすべてのプロセッサを扱う場合の処理中に、最後のプロセッサが成功するまで、検証は失敗すると、True に設定して、IgnoreValidationErrors があります。 インターネット マーケティング プロセッサそのジョブが完了したらここで、まだ xsd がまだヘルプ バイザー プロセッサで完了するために必要なクリーンアップ作業と検証エラーを取得するためのマップ検証障害このようなサイトがあります。 構成ファイルの実行では、最後のプロセッサを設定すると一連のプロセッサをすべてクリーンアップのジョブ完了とそれ以上の検証エラー期待できません。

プロパティ

文書番号: 976978 - 最終更新日: 2010年1月11日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Dynamics CRM 4.0
キーワード:?
kberrmsg kbfix kbqfe kbmbsmigrate kbexpertiseinter kbmt kbsurveynew KB976978 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:976978
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com