Article ID: 977036 - Last Review: December 28, 2009 - Revision: 1.0

You have display problems in the "Tablet PC Settings" item in Control Panel on a Tablet PC that is running a non-English version of Windows 7

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SYMPTOMS

Consider the following scenario:
  • You have a Tablet PC that is running Windows 7.
  • You use a language version of Windows 7 that is not English, or you use a display language that is not English.
  • You open the Tablet PC Settings item in Control Panel.
In this scenario, you notice the following display problems in the Buttons tab:
  • The pictures under Button location and under Detailed view are very small. Therefore, it is difficult to distinguish the button locations that are highlighted in the pictures.
  • Part of the Buttons tab is displayed beyond the right border of the Tablet PC Settings dialog box. This causes the following problems:
    • The down arrow of the Button settings for list is not displayed.
    • Part of the vertical scroll bar of the button mapping table is not displayed.
    • Part of the Reset button is not displayed.
Note Although this problem does not occur in the English version of Windows 7 or in the English language pack for Windows 7, the English version of the user interface is used to describe the problem.

CAUSE

This problem occurs because of an error in the Windows Multilingual User Interface (MUI) files that are related to the Tablet PC Settings item.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows 7.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both of these operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tabletpc.cpl.mui6.1.7600.2057450,17613-Nov-200910:43Not applicable
Tabletpc.cpl.mui6.1.7600.2057431,74413-Nov-200910:05Not applicable
Tabletpc.cpl.mui6.1.7600.2057431,23213-Nov-200910:04Not applicable
Tabletpc.cpl.mui6.1.7600.2057448,12813-Nov-200910:40Not applicable
Tabletpc.cpl.mui6.1.7600.2057427,13613-Nov-200910:14Not applicable
Tabletpc.cpl.mui6.1.7600.2057427,64813-Nov-200910:05Not applicable
For all supported x64-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tabletpc.cpl.mui6.1.7600.2057450,17613-Nov-200911:52Not applicable
Tabletpc.cpl.mui6.1.7600.2057431,74413-Nov-200911:13Not applicable
Tabletpc.cpl.mui6.1.7600.2057431,23213-Nov-200911:13Not applicable
Tabletpc.cpl.mui6.1.7600.2057448,12813-Nov-200911:49Not applicable
Tabletpc.cpl.mui6.1.7600.2057427,13613-Nov-200911:22Not applicable
Tabletpc.cpl.mui6.1.7600.2057427,64813-Nov-200911:22Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply this hotfix, the display issues that are described in the "SYMPTOMS" section are resolved. However, you experience the following minor issues in the Buttons tab:
  • The shape of the pictures may become rectangular if the computer manufacturers use customized pictures. The original shape of the pictures is square.
  • There are no spaces in the description texts shown above the button mapping table.
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about how to install or change a display language in Windows 7, visit the following Microsoft Web site:
http://windows.microsoft.com/en-us/windows7/Install-or-change-a-display-language (http://windows.microsoft.com/en-us/windows7/Install-or-change-a-display-language)
For more information about how to effectively use a Tablet PC that is running Windows 7, visit the following Microsoft Web site:
http://windows.microsoft.com/en-US/windows7/Getting-more-out-of-your-Tablet-PC (http://windows.microsoft.com/en-US/windows7/Getting-more-out-of-your-Tablet-PC)

APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbfix kbqfe kbsurveynew kbhotfixserver kbexpertiseinter KB977036