The EXOLEDB component is not initialized successfully when you start Exchange Information Store Service on an Exchange Server 2007 server

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Article ID: 977181 - View products that this article applies to.
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SYMPTOMS

When you start the Microsoft Exchange Information Store service on a Microsoft Exchange Server 2007 server, you may find the EXOLEDB component is not initialized successfully. Additionally, the following event is logged in the Application log:


Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9542
Description: Initialization of external interface OLEDB failed; Error ecServerOOM.


Note Even though the Exchange Information Store service is started, there are various issues caused by the unavailability of the EXOLEDB component.

CAUSE

This issue occurs because there is a key under the HKEY_CLASSES_ROOT path and the default value of the key is not of the REG_SZ type. However, Exchange Server 2007 makes an invalid assumption that all default values of the keys under the HKEY_CLASSES_ROOT path are of the REG_SZ type.

RESOLUTION

To resolve this problem, install the following update rollup:
972076 Description of Update Rollup 2 for Exchange Server 2007 Service Pack 2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 977181 - Last Review: January 25, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 2, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbhotfixrollup kbqfe kbfix kbexpertiseinter kbsurveynew KB977181

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