Žádný soukromý klíč je přidružen k certifikátu po úspěšné instalaci certifikátu do počítače se systémem Windows 7 nebo Windows Server 2008 R2

Překlady článku Překlady článku
ID článku: 977222 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V počítačích se systémem Windows 7 nebo Windows Server 2008 R2 je nainstalovat certifikát obsahující soukromý klíč z externí zařízení. Po provedete, zobrazí se zpráva oznamující, že certifikát byla úspěšně nainstalována. K tomu dochází i v případě, že soukromý klíč není přidružen k certifikátu.

Navíc při otevření nainstalovaný certifikát v správy certifikátů, nic znamená, že soukromý klíč není přidružený k certifikátu. Proto nelze určit, zda tento certifikát lze použít k dešifrování dat.

Poznámka: K instalaci certifikátu můžete použít jednu z následujících metod:
  • Spustit Průvodce importem certifikátu.
  • Spuštění aplikace, která volá metodu IX509Enrollment::InstallResponse.

Příčina

K tomuto problému dochází, protože metoda IX509Enrollment::InstallResponse nehlásí chybu, jestliže soukromý klíč je spojeno s certifikátu není během instalace certifikátu.

Poznámka: Průvodce importem certifikátu také pomocí metody IX509Enrollment::InstallResponse nainstalujte certifikáty.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo řešení potíží je vyžadován, pravděpodobně budete muset vytvořit požadavek na samostatnou službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "K dispozici oprava Hotfix stahování" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, které musí být v počítači 7 v systému Windows nebo Windows Server 2008 R2.

Informace o registru

Pokud chcete použít tento balíček opravy hotfix, není nutné provádět žádné změny registru.

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

INFORMACE O SOUBORECH

Angličtina (Spojené státy) verze této opravy hotfix instaluje soubory, které mají atributy, které jsou uvedeny v následujících tabulkách. Data a časy těchto souborů jsou uvedeny koordinovaný světový čas (UTC). Data a časy těchto souborů v místním počítači jsou zobrazeny podle místního času a podle aktuálního nastavení letního času (DST). Navíc data a časy mohou změnit při provádění některých operací se soubory.
Poznámky k informacím o souborech systému Windows 7 a Windows Server 2008 R2

Důležité 7 V systému Windows a Windows Server 2008 R2 opravy hotfix jsou součástí stejné balíčků. Pouze jeden z těchto produktů však může být uvedena na stránce "Požadavek opravy hotfix". Vyžádat balíčku oprav hotfix vztahující se k systému Windows 7 i Windows Server 2008 R2, pouze vybrat produkt, který je uveden na stránce.
  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou listed separately v "Souborů Další informace o systému Windows Server 2008 R2 a Windows 7". Soubory MUM a MANIFEST a příslušné soubory CAT katalogu zabezpečení jsou důležité k uchování stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.
Pro všechny podporované verze x86 systému Windows 7
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Cryptui.dll6.1.7600.205671,003,52005. Listopad 200909: 33X86
Pro všechny podporované 64bitové verze x 7 v systému Windows a systému Windows Server 2008 R2
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Cryptui.dll6.1.7600.205671,065,98405. Listopad 200912: 50.X64
Pro všechny podporované verze IA-64 systému Windows Server 2008 R2
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Cryptui.dll6.1.7600.205671,609,21605. Listopad 200908: 39IA-64

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Další informace o metodě IX509Enrollment::InstallResponse na webu společnosti Microsoft:
http://msdn.microsoft.com/en-us/library/aa378051(VS.85).aspx

Určení, zda je soukromý klíč je přidružen k certifikátu

  1. Otevřete správy certifikátů. Chcete-li to provést, klepněte na tlačítko Start
    Zmenšit tento obrázekZvětšit tento obrázek
    the Start button
    , zadejte do pole Zahájit hledánícertmgr.msc a stiskněte klávesu ENTER.

    Zmenšit tento obrázekZvětšit tento obrázek
    User Account Control
    Jestliže se zobrazí výzva k zadání hesla správce nebo k potvrzení, zadejte heslo nebo potvrďte akci.
  2. Vyhledejte certifikát a potom poklepejte na jej otevřete.
  3. Na kartě Obecné ověřte, zda se zobrazí zpráva "Máte soukromý klíč, který odpovídá tomuto certifikátu".
    • Pokud se zobrazí tato zpráva, znamená to, že soukromý klíč je přidružen k certifikátu.
    • Pokud se tato zpráva nezobrazí, znamená to, že soukromý klíč není přidružen k certifikátu.

Další informace o souborech

Další informace o souborech pro 7 v systému Windows a Windows Server 2008 R2

Další soubory pro všechny podporované-verze x 86 systému Windows 7
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ x 86 ~ ~ 6.1.1.0.mumNelze použít1,94705. Listopad 200914: 41Nelze použít
X86_microsoft-windows-cryptui-dll_31bf3856ad364e35_6.1.7600.20567_none_8665f09f12828045.manifestNelze použít2,72805. Listopad 200910: 01Nelze použít
Další soubory pro všechny podporované 64bitové verze x 7 v systému Windows a systému Windows Server 2008 R2
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Amd64_microsoft-windows-cryptui-dll_31bf3856ad364e35_6.1.7600.20567_none_e2848c22cadff17b.manifestNelze použít2,73205. Listopad 200913: 30Nelze použít
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mumNelze použít2,87905. Listopad 200914: 41Nelze použít
Další soubory pro všechny podporované verze IA-64 systému Windows Server 2008 R2
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Ia64_microsoft-windows-cryptui-dll_31bf3856ad364e35_6.1.7600.20567_none_8667949512808941.manifestNelze použít2,73005. Listopad 200910: 25Nelze použít
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ ia64 ~ ~ 6.1.1.0.mumNelze použít1,95805. Listopad 200914: 41Nelze použít
Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 977222 - Poslední aktualizace: 8. prosince 2009 - Revize: 1.1
Informace v tomto článku jsou určeny pro produkt:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Klíčová slova: 
kbmt kbhotfixserver kbautohotfix kbsurveynew kbfix kbqfe kbexpertiseadvanced KB977222 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:977222

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com