No hay ninguna clave privada está asociada con un certificado después de instalar correctamente el certificado en un equipo que ejecuta Windows Server 2008 R2 o Windows 7

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Síntomas

En un equipo que ejecuta Windows Server 2008 R2 o Windows 7, instale un certificado que contiene una clave privada de un dispositivo externo. Después de hacerlo, recibirá un mensaje que indica que el certificado se instaló correctamente. Esto ocurre incluso si la clave privada no está asociada con el certificado.

Además, al abrir el certificado instalado en administración de certificados, nada indica que la clave privada no está asociada al certificado. Por consiguiente, no puede determinar si puede utilizar este certificado para descifrar los datos.

Nota Puede utilizar uno de los métodos siguientes para instalar un certificado:
  • Ejecutar el Asistente para certificados de importación.
  • Ejecutar una aplicación llama al método IX509Enrollment::InstallResponse.

Causa

Este problema se produce porque el método IX509Enrollment::InstallResponse no presenta un error si la clave privada no está asociada al certificado durante la instalación del certificado.

Nota El Asistente para importación de certificados también se utiliza el método IX509Enrollment::InstallResponse instalar certificados.

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, el equipo debe ejecutar Windows 7 o Windows Server 2008 R2.

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a una revisión lanzada anteriormente.

Información de archivo

La versión en inglés (Estados Unidos) de esta revisión instala los archivos que tienen los atributos que se enumeran en las tablas siguientes. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Se muestran las fechas y horas de estos archivos en el equipo local en horario local y con su actual (DST) horario de verano. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivo de Windows 7 y Windows Server 2008 R2

Importante Las revisiones de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, sólo uno de estos productos puede aparecer en la página "Solicitud de revisión". Para solicitar el paquete de hotfix que se aplica a Windows 7 y Windows Server 2008 R2, simplemente seleccione el producto que aparece en la página.
  • Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instalan para cada entorno están listed separately en la sección "Información para Windows Server 2008 R2 y Windows 7 de archivo adicional". MUM y MANIFEST archivos y los archivos de catálogo (.cat) seguridad asociados, son críticos para mantener el estado del componente actualizado. Los archivos del catálogo de seguridad, para el que los atributos no aparecen en la lista, están firmados con una firma digital de Microsoft.
Para todas las versiones 86 de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Cryptui.dll6.1.7600.205671,003,52005-Nov-200909: 33x 86
Para todas-versiones basadas en x 64 de Windows 7 y de Windows Server 2008 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Cryptui.dll6.1.7600.205671,065,98405-Nov-200912: 50x 64
Para todas las versiones basadas en IA-64 de Windows Server 2008 R2 compatibles
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Cryptui.dll6.1.7600.205671,609,21605-Nov-200908: 39IA-64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca del método IX509Enrollment::InstallResponse, visite el siguiente sitio Web de Microsoft:
http://msdn.microsoft.com/en-us/library/aa378051(VS.85).aspx

Cómo determinar si una clave privada se asocia con un certificado

  1. Abra Administración de certificados. Para ello, haga clic en
    Contraer esta imagenAmpliar esta imagen
    the Start button
    de inicio, escriba certmgr.msc en el cuadro Iniciar búsqueda y, a continuación, presione ENTRAR.

    Contraer esta imagenAmpliar esta imagen
    User Account Control
    Si se le pide una contraseña de administrador o que confirme la acción, escriba la contraseña o proporcione una confirmación.
  2. Busque el certificado y, a continuación, haga doble clic en él para abrirlo.
  3. En la ficha General, compruebe que aparece el mensaje "Tiene una clave privada que corresponde a este certificado".
    • Si aparece este mensaje, indica que una clave privada está asociada con el certificado.
    • Si no aparece este mensaje, indica que una clave privada no está asociada con el certificado.

Información adicional de archivos

Información adicional de archivos para Windows 7 y Windows Server 2008 R2

Archivos adicionales para todas las versiones 86 de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ x 86 ~ ~ 6.1.1.0.mumNo aplicable1,94705-Nov-200914: 41No aplicable
X86_microsoft-ventanas cryptui dll_31bf3856ad364e35_6.1.7600.20567_none_8665f09f12828045.manifestNo aplicable2,72805-Nov-200910: 01No aplicable
Archivos adicionales para todas-versiones basadas en x 64 de Windows 7 y de Windows Server 2008 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Amd64_microsoft-ventanas cryptui dll_31bf3856ad364e35_6.1.7600.20567_none_e2848c22cadff17b.manifestNo aplicable2,73205-Nov-200913: 30No aplicable
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mumNo aplicable2,87905-Nov-200914: 41No aplicable
Archivos adicionales para todas las versiones basadas en IA-64 de Windows Server 2008 R2 compatibles
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Ia64_microsoft-ventanas cryptui dll_31bf3856ad364e35_6.1.7600.20567_none_8667949512808941.manifestNo aplicable2,73005-Nov-200910: 25No aplicable
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ ia64 ~ ~ 6.1.1.0.mumNo aplicable1,95805-Nov-200914: 41No aplicable
Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 977222 - Última revisión: martes, 08 de diciembre de 2009 - Versión: 1.1
La información de este artículo se refiere a:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Palabras clave: 
kbmt kbhotfixserver kbautohotfix kbsurveynew kbfix kbqfe kbexpertiseadvanced KB977222 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 977222

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