Nessuna chiave privata Ŕ associata un certificato dopo l'installazione del certificato in un computer che esegue Windows Server 2008 R2 o Windows 7

Traduzione articoli Traduzione articoli
Identificativo articolo: 977222 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In un computer che esegue Windows Server 2008 R2 o Windows 7, Ŕ necessario installare un certificato contenente una chiave privata da un dispositivo esterno. Dopo avere effettuato questa operazione, viene visualizzato un messaggio che informa che il certificato Ŕ stato installato correttamente. Ci˛ si verifica anche se la chiave privata non Ŕ associata al certificato.

Inoltre, quando si apre il certificato installato in Gestione certificati, nulla indica che la chiave privata non Ŕ associata a tale certificato. Di conseguenza, non Ŕ possibile determinare se Ŕ possibile utilizzare questo certificato per decrittografare i dati.

Nota Per installare un certificato, Ŕ possibile utilizzare uno dei seguenti metodi:
  • Eseguire l'importazione guidata certificati.
  • Eseguire un'applicazione che chiama il metodo IX509Enrollment::InstallResponse.

Cause

Questo problema si verifica perchÚ il metodo IX509Enrollment::InstallResponse non segnala un errore se la chiave privata non Ŕ associata al certificato durante l'installazione del certificato.

Nota L'importazione guidata certificati inoltre utilizzato il metodo IX509Enrollment::InstallResponse per installare i certificati.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo aggiornamento rapido (hotfix) solo per i sistemi in cui si verificano il problema descritto in questo articolo. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se il problema non causa gravi difficoltÓ, si consiglia di attendere il successivo aggiornamento software contenente tale aggiornamento rapido (hotfix).

Se l'aggiornamento rapido (hotfix) Ŕ disponibile per il download, Ŕ disponibile una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se in questa sezione non viene visualizzato, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se Ŕ richiesta la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi del servizio supporto tecnico clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido (hotfix). Se non viene visualizzata la lingua desiderata, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo aggiornamento rapido (hotfix), il computer esegua Windows 7 o Windows Server 2008 R2.

Informazioni del Registro di sistema

Per utilizzare l'aggiornamento rapido (hotfix) in questo pacchetto, non Ŕ necessario apportare modifiche al Registro di sistema.

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce un aggiornamento rapido (hotfix) rilasciato in precedenza.

Informazioni sui file

La versione inglese (Stati Uniti) di questo aggiornamento rapido (hotfix) consente di installare file con gli attributi elencati nelle tabelle riportate di seguito. Le date e ore dei file sono elencate in UTC (Coordinated Universal Time). Vengono visualizzate le date e ore dei file sul computer locale in ora locale e con la differenza all'ora legale (DST) corrente. Inoltre, le date e ore potrebbero cambiare quando si eseguono determinate operazioni sui file.
Note relative alle informazioni sui file di Windows 7 e Windows Server 2008 R2

Importante Gli aggiornamenti rapidi di Windows 7 e Windows Server 2008 R2 sono inclusi in pacchetti stessi. Tuttavia, solo uno di questi prodotti pu˛ essere elencato nella pagina "Hotfix richiesta". Per richiedere il pacchetto di hotfix che si applica a Windows 7 e Windows Server 2008 R2, Ŕ sufficiente selezionare il prodotto elencato nella pagina.
  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono listed separately nella sezione "Informazioni per Windows Server 2008 R2 e Windows 7 di file aggiuntive". MUM e MANIFEST dei file e i file di catalogo (CAT) protezione associati sono fondamentali per mantenere lo stato del componente aggiornato. I file di catalogo della protezione, per cui non sono elencati gli attributi sono firmati mediante firma digitale Microsoft.
Per tutte le versioni x 86 versioni di Windows 7
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Cryptui.dll6.1.7600.205671,003,52005-Nov-200909: 33x 86
Per tutte le versioni x 64 basati su versioni di Windows 7 e Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Cryptui.dll6.1.7600.205671,065,98405-Nov-200912: 50x 64
Per tutte le versioni basate su IA-64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Cryptui.dll6.1.7600.205671,609,21605-Nov-200908: 39IA-64

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sul metodo IX509Enrollment::InstallResponse, visitare il seguente sito Web Microsoft:
http://msdn.microsoft.com/en-us/library/aa378051(VS.85).aspx

Come determinare se una chiave privata Ŕ associata un certificato

  1. Aprire Gestione certificati. A tale scopo, fare clic sul
    Riduci l'immagineEspandi l'immagine
    the Start button
    Start, digitare certmgr.msc nella casella Inizia la ricerca e quindi premere INVIO.

    Riduci l'immagineEspandi l'immagine
    User Account Control
    Se viene chiesto di immettere la password dell'amministratore o di confermare, digitare la password o confermare.
  2. Individuare il certificato e quindi fare doppio clic per aprirlo.
  3. Nella scheda Generale verificare che venga visualizzato il messaggio "L'utente possiede una chiave privata corrispondente al certificato".
    • Se viene visualizzato questo messaggio indica che una chiave privata Ŕ associata al certificato.
    • Se non viene visualizzato questo messaggio, indica che una chiave privata non Ŕ associata al certificato.

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows 7 e per Windows Server 2008 R2

File aggiuntivi per tutte le versioni x 86 versioni di Windows 7
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ x 86 ~ ~ 6.1.1.0.mumNon applicabile1,94705-Nov-200914: 41Non applicabile
Dll_31bf3856ad364e35_6.1.7600.20567_none_8665f09f12828045.manifest cryptui di finestre X86_microsoftNon applicabile2,72805-Nov-200910/01:Non applicabile
File aggiuntivi per tutte le versioni x 64 basati su versioni di Windows 7 e Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Dll_31bf3856ad364e35_6.1.7600.20567_none_e2848c22cadff17b.manifest cryptui di finestre Amd64_microsoftNon applicabile2,73205-Nov-200913: 30Non applicabile
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.0.mumNon applicabile2,87905-Nov-200914: 41Non applicabile
File aggiuntivi per tutte le versioni IA-64 di Windows Server 2008 R2 supportate
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Dll_31bf3856ad364e35_6.1.7600.20567_none_8667949512808941.manifest cryptui di finestre Ia64_microsoftNon applicabile2,73005-Nov-200910: 25Non applicabile
Package_for_kb977222_rtm ~ 31bf3856ad364e35 ~ ia64 ~ ~ 6.1.1.0.mumNon applicabile1,95805-Nov-200914: 41Non applicabile
Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 977222 - Ultima modifica: martedý 8 dicembre 2009 - Revisione: 1.1
Le informazioni in questo articolo si applicano a:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Chiavi:á
kbmt kbhotfixserver kbautohotfix kbsurveynew kbfix kbqfe kbexpertiseadvanced KB977222 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 977222
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com